Closed Bug 1074399 Opened 6 years ago Closed 5 years ago

crash in @0x0 | libgstflump3dec.so@0xeaeb

Categories

(Core :: Audio/Video: Playback, defect, P5)

31 Branch
x86
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 981869
Tracking Status
firefox36 --- affected
firefox37 --- unaffected
firefox38 --- unaffected

People

(Reporter: guigs, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-222af172-db84-4c2d-a614-4d0ba2140808.
=============================================================


When scrolling or navigating to Google+ this happens for many Linux users, help needed for further investigation.
This is with GStreamer Fluendo MP3 codec apparently, so it's pretty surely in Audio/Video code, moving there.
Component: General → Video/Audio
Product: Firefox → Core
I thought we blacklisted the Fluendo codec? Or maybe only the AAC one.
This bug affected me every time i start firefox for the first time on every boot. My OS is ubuntu 14.04. I stop having this problem when i purged "gstreamer1.0-fluendo-mp3" package. Since that day, i haven't had another crash.
This is climbing to the #13 top crash for Firefox 34. It seems Linux-specific. The crash stack doesn't have much information.  It is often but not always a startup crash.   I notice that it first appeared 2014-10-31 and is appearing on older version of Firefox as well as 34, from 30 on up to 34. Not yet appearing in 35-37 though. That makes me think it is a problem independent of Firefox. 


More reports: https://crash-stats.mozilla.com/report/list?product=Firefox&range_value=7&range_unit=days&date=2014-12-11&signature=%400x0+|+libgstflump3dec.so%400xeaea&version=Firefox%3A34.0#tab-sigsummary
I have been using firefox for one and a half month without any problems after i purged "gstreamer1.0-fluendo-mp3" package from Ubuntu. I don't know if it affects other linux distributions, but that solve the problem for me. It was a very annoying bug...
(In reply to Liz Henry :lizzard from comment #4)
> This is climbing to the #13 top crash for Firefox 34. It seems
> Linux-specific.

Yes. This is a crash in the MP3 decoder that is available on some Ubuntu Linux systems.

> The crash stack doesn't have much information.  It is often
> but not always a startup crash.  

Probably caused by people who restart after a crash and restore the tab that provoked the crash.
There are a ton of crash reports with the signature [@ @0x0 | libgstflump3dec.so@0xeaea]

It's one of the top Linux crashers.
This may be a duplicate of bug 981869
Adding the slightly different signature as noted in comment 7.
Crash Signature: [@ @0x0 | libgstflump3dec.so@0xeaeb] → [@ @0x0 | libgstflump3dec.so@0xeaeb] [@ @0x0 | libgstflump3dec.so@0xeaea ]
It isn't the topcrash range for Firefox 36; there are around 600 crashes reported with this signature in the last week for both 35 and 36. Looks like the problem may be fixed in Firefox 37.
I think this can be closed as a duplicate of bug 981869. The fix for that bug also fixed this.
Component: Audio/Video → Audio/Video: Playback
There still aren't any crashes with these signatures past Firefox 36, so I'm closing this bug as a duplicate as mentioned in comment 11.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 981869
You need to log in before you can comment on or make changes to this bug.