b2g crashes in MessageLoop::DoWork()

RESOLVED DUPLICATE of bug 1074419

Status

()

Core
IPC
P1
blocker
RESOLVED DUPLICATE of bug 1074419
4 years ago
4 years ago

People

(Reporter: tkundu, Unassigned)

Tracking

({crash})

unspecified
ARM
Gonk (Firefox OS)
crash
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.1+)

Details

(Whiteboard: [b2g-crash][caf-crash 376][caf priority: p1][CR 731471], crash signature)

Attachments

(2 attachments)

Created attachment 8497049 [details]
stack trace

STR:
1) Run random stability test cases for 24 hours. 

I attached stack trace for this crash.
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?

Updated

4 years ago
Whiteboard: [CR 731471] → [caf priority: p1][CR 731471]

Updated

4 years ago
Whiteboard: [caf priority: p1][CR 731471] → [b2g-crash][caf-crash 376][caf priority: p1][CR 731471]

Updated

4 years ago
Keywords: crash
We are seeing an error like 

09-29 01:51:06.993   212   688 I Gecko   : [Parent 212] WARNING: Message requires an excessive number of descriptors channel:957bb000 message-type:-1 header()->num_fds:10779 num_fds:0 fds_i:0: file ../../../../../../../../gecko/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 571

in logcat logs. 

Any ideas on it ?
Flags: needinfo?(khuey)
I don't know.  message-type being -1 sounds bad.
Component: Stability → IPC
Flags: needinfo?(khuey)
Product: Firefox OS → Core

Comment 6

4 years ago
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #5)
> I don't know.  message-type being -1 sounds bad.

This and bug 1074419 might be same root cause then since they have same message in log.
Flags: needinfo?(benjamin)

Updated

4 years ago
Flags: needinfo?(benjamin)
Flags: needinfo?(bbajaj)
And since Bluetooth appears to post tasks on the IPC thread as in

http://dxr.mozilla.org/mozilla-central/source/dom/bluetooth2/bluedroid/BluetoothSocket.cpp#372

I think it is highly likely.
Blocking on this due to impact of CAF FC release. I hope it turns out to be a DUP. We will resolve this as such once CAF provides feedback after trying bug 1074419
blocking-b2g: 2.1? → 2.1+
Flags: needinfo?(bbajaj)

Comment 10

4 years ago
(In reply to Greg Grisco from comment #6)
> (In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #5)
> > I don't know.  message-type being -1 sounds bad.
> 
> This and bug 1074419 might be same root cause then since they have same
> message in log.

(In reply to Cervantes Yu from comment #8)
> And since Bluetooth appears to post tasks on the IPC thread as in
> 
> http://dxr.mozilla.org/mozilla-central/source/dom/bluetooth2/bluedroid/
> BluetoothSocket.cpp#372
> 
> I think it is highly likely.

Hi Thomas,
  Do you think this bug is relevant to bug 1074419?
Flags: needinfo?(tzimmermann)
(In reply to Ken Chang[:ken] from comment #10)
> (In reply to Greg Grisco from comment #6)
> > (In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #5)
> > > I don't know.  message-type being -1 sounds bad.
> > 
> > This and bug 1074419 might be same root cause then since they have same
> > message in log.
> 
> (In reply to Cervantes Yu from comment #8)
> > And since Bluetooth appears to post tasks on the IPC thread as in
> > 
> > http://dxr.mozilla.org/mozilla-central/source/dom/bluetooth2/bluedroid/
> > BluetoothSocket.cpp#372
> > 
> > I think it is highly likely.
> 
> Hi Thomas,
>   Do you think this bug is relevant to bug 1074419?

The bug here is a duplicate of bug 1074419. Can we close it?
Flags: needinfo?(tzimmermann)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1074419

Updated

4 years ago
No longer blocks: 1025317
You need to log in before you can comment on or make changes to this bug.