SET CLIR not being called on bootup

VERIFIED FIXED in 2.1 S6 (10oct)

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: anshulj, Assigned: arthurcc)

Tracking

({regression})

unspecified
2.1 S6 (10oct)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [caf priority: p2][CR 732413])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
[Blocking Requested - why for this release]: This is a regression from FFOS 2.0.

STR
1. Go to Settings->Call Settings and change the Caller Id setting to something other than network default, say "Show number"
2. Reboot the device
3. Go to the Call Settings and check the caller ID setting.

Observed: The setting is reverted to the network default
Expected: The setting should be say "Show number"


Analysis: Since the network doesn't keep the setting persistent, FFOS is required to send the current Caller Id setting from the database to the network. This works fine in FFOS 2.0 but broke due to bug 1028544. I have confirmed that reverting bug 1028544 fixes the issue.

Comment 1

4 years ago
Triage: blocking. assign to Arthur, thanks.
Assignee: nobody → arthur.chen
blocking-b2g: 2.1? → 2.1+
Whiteboard: [CR 732413]
Whiteboard: [CR 732413] → [caf priority: p2][CR 732413]
Keywords: regression
Target Milestone: --- → 2.1 S6 (10oct)
Status: NEW → ASSIGNED
Created attachment 8499436 [details]
link to https://github.com/mozilla-b2g/gaia/pull/24745

Alive, could you help review this simple patch? We are not able to use `hasOwnProperty` to check the existence of a method on a native object. Thanks.
Attachment #8499436 - Flags: review?(alive)
Attachment #8499436 - Flags: review?(alive) → review+
master: b4463db231f76e720f2ed4a3aea8a97013bc8649
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → fixed
Resolution: --- → FIXED
Comment on attachment 8499436 [details]
link to https://github.com/mozilla-b2g/gaia/pull/24745

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1028544
[User impact] if declined: CLIR settings are not restored after restarting the phone.
[Testing completed]: Manual test is completed
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: N/A
Attachment #8499436 - Flags: approval-gaia-v2.1?
Attachment #8499436 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Verified fixed on Flame 2.2 (319mb/full flash) and Flame 2.1 (319mb/full flash) 

Actual result: The setting displays "Show number" after rebooting the device. 

Device: Flame 2.2
BuildID: 20141012040203
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 44168a7af20d
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Device: Flame 2.1
BuildID: 20141012001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.