Closed Bug 1074521 Opened 6 years ago Closed 6 years ago

B2G: Status Bar transition has shows some leftovers

Categories

(Firefox OS Graveyard :: Gaia::System, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S6 (10oct)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: gwagner, Assigned: jerry)

Details

(Keywords: regression)

Attachments

(3 files, 1 obsolete file)

Attached video VID_0014.3gp
On 2.1, the status bar hiding transition has some artifacts around the big blue notification icon.
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
OS: Mac OS X → Gonk (Firefox OS)
Priority: -- → P1
Hardware: x86 → ARM
QA Contact: ddixon
Branch Check

Issue DOES occur in Flame 2.2, 2.1

Note: Tested on Flame device with 512 MB memory.  

Device: Flame Master
Build ID: 20140930061521
Gaia: 77ef35f5429bc3dfe9ca192b9aacc3c0bf8857de
Gecko: 2ae57957e4bb
Version: 35.0a1 (Master)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
--------------------------------------------------
Device: Flame 2.1
Build ID: 20140930093624
Gaia: 89a13e9325948488fd4ae777a97f489189a7ed26
Gecko: 9550de0111d4
Version: 34.0a2 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
--------------------------------------------------
--------------------------------------------------
DOES NOT occur: 

Device: Flame 2.0
Build ID: 20140930095020
Gaia: 5c2303ec4e367da060aa1b807d541a6549b3d72a
Gecko: f19f4e07010a
Version: 32.0 (2.0)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
--------------------------------------------------
v180 Base Image
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
A shallow flash method was used for the Branch Check in Comment 2.
Regression-window is next
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Jerry, please check you can reproduce this issue or not.
Flags: needinfo?(hshih)
Assigning to Jerry while we're waiting to see if he can reproduce the problem so that we don't have unassigned blockers.
Assignee: nobody → hshih
Yes, I can reproduce this issue on my flame device.

my env:
---
gecko:
commit 9ccdefca9784a481fe5781d08c9bb5cf5c338731
Author: Robert Strong <robert.bugzilla@gmail.com>
Date:   Tue Sep 30 20:36:45 2014 -0700

gaia:
commit 8f452cbfb9049ffab7adc5c9283d373fbbbedafd
Author: Kevin Grandon <kevingrandon@yahoo.com>
Date:   Mon Sep 29 23:14:30 2014 -0700
Flags: needinfo?(hshih)
Jerry, are you analyzing this bug and working on a solution?
Flags: needinfo?(hshih)
System notification has two layer. One for black background and one for the text and the blue icon. They are in different rect size and use different type of css animation, so it might have animation sync problem.
I will check the css property and try to sync them.
Flags: needinfo?(hshih)
So I just realised what this bug was, and it may well be fixed by bug 1061969.
QA Contact: ddixon → ckreinbring
Hi Chris,
Please check attachment 8499774 [details] [diff] [review] and test again.
You can also extend the animation to 10s and see the result.
Flags: needinfo?(ckreinbring)
Comment on attachment 8499774 [details] [diff] [review]
align clip and transform animation

It's not related to gfx problem. The clip region should align with the overlay transform positon. So I change the end point of clip rect.
Attachment #8499774 - Flags: feedback?(chrislord.net)
To repro the bug this far back, take a couple of screenshots then watch the icon for the top screenshot notification while opening and closing the status bar.

Regression window
Last working
BuildID: 20140719190316
Gaia: d839242c2a4a6a445cbd8bc2443acbdf712a19fc
Gecko: 0894d2cdb16d
Platform Version: 33.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First broken
BuildID: 20140720121116
Gaia: d4583df788d33119f1fc4c68dca40a986a9bf18b
Gecko: 56bec3816967
Platform Version: 33.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Working Gaia / Broken Gecko = No repro
Gaia: d839242c2a4a6a445cbd8bc2443acbdf712a19fc
Gecko: 56bec3816967
Broken Gaia / Working Gecko = Repro
Gaia: d4583df788d33119f1fc4c68dca40a986a9bf18b
Gecko: 0894d2cdb16d
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/d839242c2a4a6a445cbd8bc2443acbdf712a19fc...d4583df788d33119f1fc4c68dca40a986a9bf18b


B2G Inbound
Last working
BuildID: 20140719022716
Gaia: 666a1fd98251412d7c55dcb2dee6fd78d2dab734
Gecko: 5db04c1ae82e
Platform Version: 33.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First broken
BuildID: 20140719053717
Gaia: 4c7f92ce401fcb784a2ef8a378451eaa9a9554c3
Gecko: eb321e5051c9
Platform Version: 33.0a1
Firmware Version: V123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Working Gaia / Broken Gecko = No repro
Gaia: 666a1fd98251412d7c55dcb2dee6fd78d2dab734
Gecko: eb321e5051c9
Broken Gaia / Working Gecko = Repro
Gaia: 4c7f92ce401fcb784a2ef8a378451eaa9a9554c3
Gecko: 5db04c1ae82e
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/666a1fd98251412d7c55dcb2dee6fd78d2dab734...4c7f92ce401fcb784a2ef8a378451eaa9a9554c3
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Comment on attachment 8499774 [details] [diff] [review]
align clip and transform animation

Review of attachment 8499774 [details] [diff] [review]:
-----------------------------------------------------------------

I didn't mean to say that this can't be fixed, just that bug 1061969 completely changes how this works and almost certainly also fixes the issue. However, that shouldn't stop us from landing the simpler fix first, good work!
Attachment #8499774 - Flags: feedback?(chrislord.net) → feedback+
Attachment #8500008 - Flags: review?(chrislord.net)
I also try the portrait and landscape mode. It works.
Comment on attachment 8500008 [details] [review]
align clip region and transform anim

I've left a question on github, I don't want to r+ this just yet.
(In reply to Chris Lord [:cwiiis] from comment #18)
> Comment on attachment 8500008 [details] [review]
> align clip region and transform anim
> 
> I've left a question on github, I don't want to r+ this just yet.

Thx, I just get the value instead of getComputedStyle().
Flags: needinfo?(chrislord.net)
Status: NEW → ASSIGNED
Comment on attachment 8500008 [details] [review]
align clip region and transform anim

Looks good :)
Attachment #8500008 - Flags: review?(chrislord.net) → review+
Flags: needinfo?(chrislord.net)
The linter fails because a line is too long - Gij is failing, but it looks like an infrastructure problem, so I've retriggered it. You can assume my r+ stands once tests pass.
(In reply to Chris Lord [:cwiiis] from comment #21)
> The linter fails because a line is too long - Gij is failing, but it looks
> like an infrastructure problem, so I've retriggered it. You can assume my r+
> stands once tests pass.

Fix the lint error, but the Gij is still failed. I can see a lot of try failed at Gij test.

Try result:
https://tbpl.mozilla.org/?tree=Gaia-Try&rev=cd2c14fffa03
Attachment #8499774 - Attachment is obsolete: true
In comment 22, the Gij test is failed. If it is ok, please land the attachment 8500008 [details] [review] to gaia master and v2.1.
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/gaia/commit/fdd378e53445bcec7145111cfe0e2d163ae29872

Please nominate this patch for Gaia v2.1 approval when you get a chance.
Flags: needinfo?(hshih)
Keywords: checkin-needed
Target Milestone: --- → 2.1 S6 (10oct)
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Component: Graphics → Gaia::System
Flags: needinfo?(hshih)
Product: Core → Firefox OS
approval for gaia v2.1

[Feature/regressing bug #]: none
[User impact if declined]: user will see some abnormal visual result as in video attachment 8497136 [details]
[Describe test coverage new/current, TBPL]: pass try test except Gij test, but Gij test has failed before this commit.
try result: https://tbpl.mozilla.org/?tree=Gaia-Try&rev=cd2c14fffa03
[Risks and why]: Low, just change the css animation clip region.
[String/UUID change made/needed]: none

---
I can't set the gaia approval request flag in this bug.
Flags: needinfo?(bbajaj)
Flags: needinfo?(ckreinbring)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
resolved, needs master verification, and wait until 2.1 is uplifted to verify also.
Flags: needinfo?(jmitchell)
Keywords: verifyme
Verified Fixed on Master  but still waiting on 2.1 uplift (keeping my NI to revisit this)

actual results: No leftovers when closing notification menu

Environmental Variables:
Device: Flame Master
Build ID: 20141007130518
Gaia: 9050edcda308b65d86577c8ed0eedc5c568d8e44
Gecko: 0c8ae792f1c0
Version: 35.0a1 (Master)
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
Status: RESOLVED → VERIFIED
[Approval Request Comment]
approval for gaia v2.1

[Feature/regressing bug #]: none
[User impact if declined]: user will see some abnormal visual result as in video attachment 8497136 [details]
[Describe test coverage new/current, TBPL]: pass try test except Gij test, but Gij test has failed before this commit.
try result: https://tbpl.mozilla.org/?tree=Gaia-Try&rev=cd2c14fffa03
[Risks and why]: Low, just change the css animation clip region.
[String/UUID change made/needed]: none
Attachment #8501551 - Flags: approval-gaia-v2.1?(bbajaj)
Flags: needinfo?(bbajaj)
Attachment #8501551 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+
VERIFIED FIXED on v2.1.

Environmental Variables:
Device: Flame 2.1 KK (319 MB)
BuildID: 20141012001201 (full flash)
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

No artifacts are seen and the notification bar functions cleanly.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: needinfo?(jmitchell)
You need to log in before you can comment on or make changes to this bug.