modifications to the DOM inside a new iframe disappear

RESOLVED DUPLICATE of bug 543435

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 543435
4 years ago
4 years ago

People

(Reporter: jonathantneal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8497169 [details]
iframe.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.124 Safari/537.36

Steps to reproduce:

I appended an iframe to a document.
I added content to that iframe's document.


Actual results:

The iframe displayed no content.


Expected results:

The iframe should have displayed its content.

Comment 1

4 years ago
Is this about the initial about:blank and the next about:blank?
Component: Layout → DOM
(Reporter)

Comment 2

4 years ago
I think so, yes. I have observed that while content either flashes briefly or never appears at all, the listeners on the iframe's window persist, which makes me think the browser is loading one document and then dumping it for another.

In the end, the spec isn't being followed, nor is the behavior consistent with other browsers.

http://dev.w3.org/html5/spec-preview/the-iframe-element.html
This is a known issue with initial about:blank.  Waiting until the load event on the iframe fires before modifying its DOM is a workaround if one is needed for now...
Whiteboard: DUPEME
Summary: iframe generated content disappears → modifications to the DOM inside a new iframe disappear
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 543435
You need to log in before you can comment on or make changes to this bug.