Closed Bug 1074582 Opened 5 years ago Closed 5 years ago

Warn user that sync does not work if master password is set

Categories

(Firefox :: Untriaged, defect)

32 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1013064

People

(Reporter: ross, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0 Iceweasel/32.0.3
Build ID: 20140925090808

Steps to reproduce:

Tonight I tried to migrate from the old version of Sync to the new FxA based sync using the directions at https://support.mozilla.org/en-US/kb/how-to-update-to-the-new-firefox-sync

I use a master password.  None of the documentation, and nothing in the application, warned me that this would be a problem.

Worse, the new firefox will not let me setup the old style sync.  So now I must choose: secure password storage or sync.


Actual results:

Firefox refused to sync my passwords via FxA


Expected results:

Ideally, Firefox should've warned me that it cannot do what I wanted.  At the very least, the documentation should warn the user before instructing them to delete configuration that they cannot get back.
Resolved by bug 1013064?
Yes, a warning is not needed with bug 1013064
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1013064
You need to log in before you can comment on or make changes to this bug.