Closed Bug 1074696 Opened 5 years ago Closed 5 years ago

As a user, I should be able to copy the room url to the clipboard or email the room url from the room preview

Categories

(Hello (Loop) :: Client, enhancement, P1)

enhancement
Points:
2

Tracking

(firefox35 verified, firefox36 verified)

VERIFIED FIXED
mozilla36
Iteration:
36.3
Tracking Status
firefox35 --- verified
firefox36 --- verified
Blocking Flags:
backlog Fx35+

People

(Reporter: standard8, Assigned: standard8)

References

()

Details

(Whiteboard: [rooms][strings])

User Story

* As a user, I should be able to copy the room url to the clipboard form the room preview, so that I can easily share the url

UX:
* Add the Invite someone text, implement the copy button
* When the copy button is pressed, copy the string and change the text to "Copied!"

Strings:
* Invite someone to join you.
* Copy Link
* Copied!

Implementation
* Use the mozLoop.copyString API to copy to clipboard

Attachments

(2 files)

Attached image Expected UX
No description provided.
User Story: (updated)
Whiteboard: [rooms] → [rooms][strings]
User Story: (updated)
backlog: --- → Fx35+
Assignee: nobody → dmose
Assignee: dmose → nobody
Priority: -- → P1
Assignee: nobody → standard8
Iteration: --- → 36.3
Points: --- → 2
This adds the simple bits necessary for copy and email. Although email isn't part of this bug, its just as simple and we didn't have a specific bug for it.
Attachment #8520659 - Flags: review?(nperriault)
Duplicate of this bug: 1090194
Summary: As a user, I should be able to copy the room url to the clipboard from the room preview → As a user, I should be able to copy the room url to the clipboard or email the room url from the room preview
Comment on attachment 8520659 [details] [diff] [review]
Allow the user to copy and email Loop room urls from the room preview

Review of attachment 8520659 [details] [diff] [review]:
-----------------------------------------------------------------

Look awesome!

::: browser/components/loop/content/js/roomViews.jsx
@@ +52,3 @@
>          // Used by the UI showcase.
>          roomState: this.props.roomState || storeState.roomState
> +      }, storeState);

*shudder*
Attachment #8520659 - Flags: review?(nperriault) → review+
https://hg.mozilla.org/integration/fx-team/rev/ded2b24c9ef3
Target Milestone: --- → mozilla36
https://hg.mozilla.org/mozilla-central/rev/ded2b24c9ef3
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Flags: qe-verify+
Flags: in-testsuite?
Flags: in-moztrap?
Verified fixed FF 35b4, 36.0a2 (2014-12-18) Ubuntu 13.04
Status: RESOLVED → VERIFIED
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.