Canvas artifact with HWA enabled

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: Loic, Assigned: bas)

Tracking

(Blocks: 1 bug, {regression})

34 Branch
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox32 unaffected, firefox33- wontfix, firefox34+ wontfix, firefox35+ wontfix, firefox36- affected, firefox37 affected, firefox-esr31 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8497463 [details]
screenshot-ff35.png

STR:
Open testcase https://bugzilla.mozilla.org/attachment.cgi?id=8497410

Result: thin vertical green line on the right with HWA enabled.

Expected: no vertical line like with HWA off.

Regression range:
good=2014-05-20
bad=2014-05-21
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cb9f34f73ebe&tochange=9d8d16695f6a

about:support

Adapter Description	Intel(R) HD Graphics 3000
Adapter Description (GPU #2)	NVIDIA GeForce GT 550M
Adapter Drivers	igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Adapter Drivers (GPU #2)	nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM	Unknown
Adapter RAM (GPU #2)	2048
ClearType Parameters	Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50
Device ID	0x0116
Device ID (GPU #2)	0x0df6
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.16571)
Driver Date	1-29-2014
Driver Date (GPU #2)	9-13-2014
Driver Version	9.17.10.3347
Driver Version (GPU #2)	9.18.13.4411
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Subsys ID	17121043
Subsys ID (GPU #2)	17121043
Vendor ID	0x8086
Vendor ID (GPU #2)	0x10de
WebGL Renderer	Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
(Reporter)

Updated

4 years ago
Keywords: regression

Comment 1

4 years ago
[Tracking Requested - why for this release]: regression

I can reproduce the problem when zoom in on normal DPI monitor.
status-firefox33: --- → unaffected
status-firefox34: --- → affected
status-firefox35: --- → affected
tracking-firefox34: --- → ?
tracking-firefox35: --- → ?
Version: 35 Branch → 34 Branch

Comment 2

4 years ago
[Tracking Requested - why for this release]:

Regression window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/bb8fc1380b00
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 ID:20140519202628
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/46d9ffb97fe3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 ID:20140519224628
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=bb8fc1380b00&tochange=46d9ffb97fe3

Regressed by: Bug 899785
Blocks: 899785
status-firefox32: --- → unaffected
status-firefox33: unaffected → affected
status-firefox-esr31: --- → unaffected
tracking-firefox33: --- → ?
(Reporter)

Comment 3

4 years ago
Ty for the reg bug.

Comment 4

4 years ago
Regression window force OMTC enabled
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/d11b778458e9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130509 Firefox/23.0 ID:20130509082217
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c5daf23a9a20
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130509 Firefox/23.0 ID:20130509083317Pushlog:
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d11b778458e9&tochange=c5daf23a9a20

Regressed by: Bug 830347
Blocks: 830347
This doesn't look significant enough (user experience, rather old if Firefox 23 is correct) to warrant taking at the end of the 33 cycle. I'm going to track for 34+ and get the gfx team to weigh in on this one.
status-firefox33: affected → wontfix
tracking-firefox33: ? → -
tracking-firefox34: ? → +
tracking-firefox35: ? → +
Flags: needinfo?(milan)
Assignee: nobody → bas
Blocks: 1036457
Flags: needinfo?(milan)
(Assignee)

Comment 6

4 years ago
I'm a little surprised this would be related to OMTC. I'll have a look.
Bas - Were you able to look into this?
Flags: needinfo?(bas)
(Assignee)

Comment 8

4 years ago
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #7)
> Bas - Were you able to look into this?

Not yet, there's sadly a long list of more important OMTC bugs we're still investigating.
Flags: needinfo?(bas)
If I was guessing, I'd first check if it's one of those repeat vs. clamp to edge vs. clamp to border issues...
This is lower priority than other bugs for 34. I'm leaving this tracked for future releases.
status-firefox34: affected → wontfix
status-firefox36: --- → affected
tracking-firefox36: --- → +
too late in the 35 cycle now, and fortunately this is cosmetic and not functional breakage.  wontfixing for 35 and leaving tracking for one more cycle.
status-firefox35: affected → wontfix
status-firefox37: --- → affected
No activity, we shipped several releases with this bug. I am not sure it is worth tracking anymore...
tracking-firefox36: + → -
I suspect is a page zoom of 1.25 in the screenshot (the line is 250px from the left edge of the canvas, and the canvas is 200 CSS pixels wide). So this look like the right edge of the CanvasLayer samples from its left edge during scaled composition.

Comment 14

3 years ago
FYI,
I can reproduce on Firefox35 win32 w/ HWA.
However, I cannot reproduce on Firefox36, 37, 38.0a2 and 39.0a1 win32 w/ HWA.
(Reporter)

Comment 15

3 years ago
Fixed on my side too.
Working range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a255a234946e&tochange=7e3c85754d32

Probably fixed by bug 1088417.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Depends on: 1088417
You need to log in before you can comment on or make changes to this bug.