Closed Bug 1074821 Opened 5 years ago Closed 5 years ago

On Windows 7 with lates updates installed, new Date(...) under some circumstances creates wrong date

Categories

(Core :: JavaScript: Standard Library, defect)

32 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1079720

People

(Reporter: oleg-elifantiev, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.77 Safari/537.36

Steps to reproduce:

While in Europe/Moscow timezone
in console run 
new Date(2014, 0, 1, 0, 0, 0, 0) 


Actual results:

Created a date object pointing to 1 Jan 2014 01:00:00.0
new Date(2014, 0, 1, 0, 0, 0, 0).getHours() returns 1


Expected results:

Created a date object pointing to 1 Jan 2014 00:00:00.0
new Date(2014, 0, 1, 0, 0, 0, 0).getHours() returns 0
Component: Untriaged → JavaScript: Standard Library
Product: Firefox → Core
Seems like this is not a FF issue, but a MS Windows one...
OS system settings can't change a date to 2014-01-01 00:00:00 cause' there are no such date, it is denied cause' of active DST
Duping forward to a bug that identified which Windows update caused this.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1079720
You need to log in before you can comment on or make changes to this bug.