GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

RESOLVED DUPLICATE of bug 833117

Status

()

Core
General
RESOLVED DUPLICATE of bug 833117
4 years ago
2 years ago

People

(Reporter: Raul Malea, Unassigned)

Tracking

35 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
After install Firefox Nightly I try to launch in konsole. Nightly starting but with following errors:

mrn:/opt # firefox-nightly 

(process:4629): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

(firefox:4629): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::sm-connect after class was initialised

(firefox:4629): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::show-crash-dialog after class was initialised

(firefox:4629): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::display after class was initialised

(firefox:4629): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::default-icon after class was initialised
1412100673113   addons.xpi      WARN    Disabling foreign installed add-on susefox@opensuse.org in app-system-share
mrn:/opt # 


I used openSUSE 13.2 Beta1, KDE 4.14.1

Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0 ID:20140930030202 CSet: 7c24470b6b3a

Also, please changing component for this bug in correct matter (I not are developer):P
(Reporter)

Comment 1

4 years ago
about:support ....

Application Basics
------------------

Name: Firefox
Version: 35.0a1
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Multiprocess Windows: 0/1

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: Adblock Plus
Version: 2.6.4
Enabled: true
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Add-on Compatibility Reporter
Version: 2.0.4
Enabled: true
ID: compatibility@addons.mozilla.org

Name: Bookmarks Checker - check for bad links
Version: 3.1.1
Enabled: true
ID: firefoxbookmarkchecker@everhelper.me

Name: British English Dictionary
Version: 1.19.1
Enabled: true
ID: en-GB@dictionaries.addons.mozilla.org

Name: Bugzilla Tweaks
Version: 1.12.1.1
Enabled: true
ID: jid0-qBnIpLfDFa4LpdrjhAC6vBqN20Q@jetpack

Name: Clearly
Version: 10.2.1.7
Enabled: true
ID: readable@evernote.com

Name: Evernote Web Clipper
Version: 5.9.1
Enabled: true
ID: {E0B8C461-F8FB-49b4-8373-FE32E9252800}

Name: feedly
Version: 16.0.528
Enabled: true
ID: feedly@devhd

Name: Google Shortcuts
Version: 2.1.8.2
Enabled: true
ID: {5C46D283-ABDE-4dce-B83C-08881401921C}

Name: Lightbeam
Version: 1.0.10.2
Enabled: true
ID: jid1-F9UJ2thwoAm5gQ@jetpack

Name: Nightly Tester Tools
Version: 3.7
Enabled: true
ID: {8620c15f-30dc-4dba-a131-7c5d20cf4a29}

Name: openSUSE Firefox Extensions
Version: 1.0.2
Enabled: true
ID: susefox@opensuse.org

Name: Pocket
Version: 3.0.5
Enabled: true
ID: isreaditlater@ideashower.com

Name: Quick Locale Switcher
Version: 1.7.8.5
Enabled: true
ID: {25A1388B-6B18-46c3-BEBA-A81915D0DE8F}

Name: Submit Word
Version: 1.1.0
Enabled: true
ID: submitword@suseromania.ro

Name: Bookmark Duplicate Cleaner
Version: 0.2
Enabled: false
ID: bookmarkdup@localghost.net

Name: Cheevos
Version: 1.5
Enabled: false
ID: jid1-bpzDizt9E1R7nw@jetpack

Name: Firebug
Version: 2.0.4
Enabled: false
ID: firebug@software.joehewitt.com

Name: Firefox OS Simulator
Version: 4.0.2
Enabled: false
ID: r2d2b2g@mozilla.org

Name: FlashGot
Version: 1.5.6.5
Enabled: false
ID: {19503e42-ca3c-4c27-b1e2-9cdb2170ee34}

Name: Greasemonkey
Version: 2.2
Enabled: false
ID: {e4a8a97b-f2ed-450b-b12d-ee082ba24781}

Name: ImageSearch
Version: 0.3.1
Enabled: false
ID: jid1-NOlwYOe3E3vApg@jetpack

Name: Mozilla Reps Companion
Version: 1.1
Enabled: false
ID: jid1-4QxcVDv2lBVyfQ@jetpack

Name: Mozmill Crowd
Version: 0.2
Enabled: false
ID: mozmill-crowd@quality.mozilla.org

Name: Mozmill test Addon
Version: initial.rev11
Enabled: false
ID: jid0-eXBmaisIIhuqsxKsdxROTr5TCwc@jetpack

Name: Test Pilot
Version: 1.2.3
Enabled: false
ID: testpilot@labs.mozilla.com

Name: Web Developer
Version: 1.2.5
Enabled: false
ID: {c45c406e-ab73-11d8-be73-000a95be3b12}

Name: YSlow
Version: 3.1.8
Enabled: false
ID: yslow@yahoo-inc.com

Graphics
--------

Adapter Description: nouveau -- Gallium 0.4 on NVCE
Device ID: Gallium 0.4 on NVCE
Driver Version: 3.0 Mesa 10.3.0-rc1
GPU Accelerated Windows: 0/1 Basic
Vendor ID: nouveau
WebGL Renderer: nouveau -- Gallium 0.4 on NVCE
windowLayerManagerRemote: false
AzureCanvasBackend: cairo
AzureContentBackend: cairo
AzureFallbackCanvasBackend: none
AzureSkiaAccelerated: 0

Important Modified Preferences
------------------------------

accessibility.typeaheadfind: true
accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size_cached_value: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 2
browser.places.importBookmarksHTML: false
browser.places.smartBookmarksVersion: 7
browser.sessionstore.upgradeBackup.latestBuildID: 20140930030202
browser.startup.homepage: about:home
browser.startup.homepage_override.buildID: 20140930030202
browser.startup.homepage_override.mstone: 35.0a1
dom.mozApps.used: true
extensions.lastAppVersion: 35.0a1
font.name.monospace.x-western: DejaVu Sans Mono
font.name.sans-serif.x-western: DejaVu Sans
font.name.serif.x-western: DejaVu Serif
media.gmp-gmpopenh264.autoupdate: true
media.gmp-gmpopenh264.lastUpdate: 1412101004
media.gmp-gmpopenh264.version: 1.0
media.gmp-manager.lastCheck: 1412101003
network.cookie.cookieBehavior: 3
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1412079363
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.libnpsoplugin: 2
privacy.donottrackheader.enabled: true
privacy.donottrackheader.value: 0
privacy.sanitize.migrateFx3Prefs: true
storage.vacuum.last.index: 0
storage.vacuum.last.places.sqlite: 1412079363

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.10.7
Version in use: 4.10.7

NSS
Expected minimum version: 3.17.1 Basic ECC
Version in use: 3.17.1 Basic ECC

NSSSMIME
Expected minimum version: 3.17.1 Basic ECC
Version in use: 3.17.1 Basic ECC

NSSSSL
Expected minimum version: 3.17.1 Basic ECC
Version in use: 3.17.1 Basic ECC

NSSUTIL
Expected minimum version: 3.17.1
Version in use: 3.17.1

Experimental Features
---------------------

Comment 2

4 years ago
Seems to be same bug than #956622?
Flags: needinfo?(raul.malea)

Comment 3

4 years ago
In my Ubuntu Firefox:  (process:4947): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

# firefox -v

(process:4947): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Mozilla Firefox 32.0.3

# uname -a
Linux harri-Veriton-X2610G 3.13.0-37-generic #64-Ubuntu SMP Mon Sep 22 21:28:38 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
# 
# strace -ff firefox -P auto-outlet /home/harri/testi2/x.html 2> log.strace 
# pg log.strace
...
gettid()                                = 4862
open("/usr/lib/x86_64-linux-gnu/charset.alias", O_RDONLY) = -1 ENOENT (No such file or directory)
write(2, "\n(process:4862): GLib-CRITICAL *"..., 93
(process:4862): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
) = 93
pipe([3, 4])                            = 0
clone(Process 4865 attached
...
Flags: needinfo?(raul.malea) → needinfo?(hiikezoe)
If glib version is higher than 2.35, it's definitely bug 833117.
Flags: needinfo?(hiikezoe)

Comment 5

4 years ago
(In reply to Hiroyuki Ikezoe (:hiro) from comment #4)
> If glib version is higher than 2.35, it's definitely bug 833117.

Is it possible that a missing ubuntu file is the issue?
...
gettid()                                = 4862
open("/usr/lib/x86_64-linux-gnu/charset.alias", O_RDONLY) = -1 ENOENT (No such file or directory)
write(2, "\n(process:4862): GLib-CRITICAL *"..., 93
(process:4862): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
) = 93
pipe([3, 4])                            = 0
clone(Process 4865 attached
...
(Reporter)

Comment 6

4 years ago
raul.malea@mrn:~> firefox-nightly -v

(process:2248): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Mozilla Firefox 35.0a1

raul.malea@mrn:~> uname -a
Linux mrn.mrn 3.16.3-1.gd2bbe7f-desktop #1 SMP PREEMPT Thu Sep 18 06:32:16 UTC 2014 (d2bbe7f) x86_64 x86_64 x86_64 GNU/Linux

Not bug 956622 (in this case Firefox starting , but with errors).

Perhaps is bug 833117.

I have installed: glibc - 2.19-16.2.5 and glib2-tools - 2.42.0-1.1

Comment 7

3 years ago
ubuntu 14.04, Gigabyte-B75M-HD3 motherB, Intel® Core™ i3-3240 CPU @ 3.40GHz × 4, 4Go Ram
>uname -a
Linux 3.13.0-43-generic #72-Ubuntu SMP Mon Dec 8 19:35:06 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
>synaptic : (run in GUI) asked "dpkg --configure -a" to be run
>dpkg --configure -a
Paramétrage de mime-support (3.54ubuntu1) ...
Paramétrage de firefox (34.0+build2-0ubuntu0.14.04.1) ...
Please restart all running instances of firefox, or you will experience problems.
>dpkg -l 'libglib2.0*'
[...]
ii  libglib2.0-bin 2.40.2-0ubun amd64        Programs for the GLib library

>firefox -v
(process:6202): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Mozilla Firefox 34.0

Note : Firefox runs fine from the guest account on the same PC/Ubuntu
Note : My system is relatively fresh from install appart from heavy fiddling to get OpenCL to work with GeForce GTX 650/PCIe/SSE2 graphics card. various flavors of drivers were installed and removed in the process.

Not fixed.

Comment 8

3 years ago
Ubuntu 14.04
latest firefox: 36.0+build2-0ubuntu0.14.04.4
---
When I run this comand from console: 

```
/usr/bin/firefox -remote "openURL(http://some-local-url.local/)"
```
I see this message: 
(process:7378): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

I can not run debuger in netbeans because this error exists. Please FIX THIS!!!

Comment 9

3 years ago
I cannot start Firefox from the sidebar and neither from the terminal.
The only way to start it is with sudo from terminal.

This is the message I can see in the terminal

(process:7820: GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

(firefox:7820): GLib-GIO-WARNING **: /home/bloom/.local/share/applications/defaults.list contains a [Added Associations] group, but it is not permitted here.  Only the non-desktop-specific mimeapps.list file may add or remove associations.

It is Firefox 38.0 
and 
Linux ubuntu 3.19.0-18-generic #18-Ubuntu SMP Tue May 19 18:31:35 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux


Any help would be appreciated.

Comment 11

3 years ago
Last night, after automatic updates on OpenSuse 13.2, I get this error.

This probably means that no OpenSuse 13.2 users with online updates enabled will be able to use firefox until this is fixed.

firefox 40.0
glibc 2.19

Comment 12

3 years ago
Looking around for a while, it *appears* that this particular error message is really normal and a warning. The crash that follows the message, however, is not normal. I had FF running when I ran my update. It crashed as soon as some package was upgraded. I do not know which one. Here is a list of what was updated:

/var/log$ grep  " upgrade " dpkg.log        
2015-09-03 09:39:26 upgrade nomachine:amd64 4.6.12-7 4.6.16-5
2015-09-03 10:27:01 upgrade libisc-export95:amd64 1:9.9.5.dfsg-9ubuntu0.2 1:9.9.5.dfsg-9ubuntu0.3
2015-09-03 10:27:01 upgrade libdns-export100:amd64 1:9.9.5.dfsg-9ubuntu0.2 1:9.9.5.dfsg-9ubuntu0.3
2015-09-03 10:27:01 upgrade libgnutls-openssl27:amd64 3.3.8-3ubuntu3 3.3.8-3ubuntu3.1
2015-09-03 10:27:02 upgrade libgnutls-deb0-28:i386 3.3.8-3ubuntu3 3.3.8-3ubuntu3.1
2015-09-03 10:27:02 upgrade libgnutls-deb0-28:amd64 3.3.8-3ubuntu3 3.3.8-3ubuntu3.1
2015-09-03 10:27:03 upgrade libisccfg-export90:amd64 1:9.9.5.dfsg-9ubuntu0.2 1:9.9.5.dfsg-9ubuntu0.3
2015-09-03 10:27:03 upgrade libirs-export91:amd64 1:9.9.5.dfsg-9ubuntu0.2 1:9.9.5.dfsg-9ubuntu0.3
2015-09-03 10:27:03 upgrade google-chrome-stable:amd64 44.0.2403.157-1 45.0.2454.85-1
2015-09-03 10:27:11 upgrade libkf5prison1:amd64 1.2+git20150822.0145+15.04-0 1.2+git20150901.0033+15.04-0
2015-09-03 10:27:37 upgrade dnsutils:amd64 1:9.9.5.dfsg-9ubuntu0.2 1:9.9.5.dfsg-9ubuntu0.3
2015-09-03 10:27:38 upgrade bind9-host:amd64 1:9.9.5.dfsg-9ubuntu0.2 1:9.9.5.dfsg-9ubuntu0.3
2015-09-03 10:27:38 upgrade libisc95:amd64 1:9.9.5.dfsg-9ubuntu0.2 1:9.9.5.dfsg-9ubuntu0.3
2015-09-03 10:27:38 upgrade libdns100:amd64 1:9.9.5.dfsg-9ubuntu0.2 1:9.9.5.dfsg-9ubuntu0.3
2015-09-03 10:27:39 upgrade libisccc90:amd64 1:9.9.5.dfsg-9ubuntu0.2 1:9.9.5.dfsg-9ubuntu0.3
2015-09-03 10:27:39 upgrade libisccfg90:amd64 1:9.9.5.dfsg-9ubuntu0.2 1:9.9.5.dfsg-9ubuntu0.3
2015-09-03 10:27:39 upgrade liblwres90:amd64 1:9.9.5.dfsg-9ubuntu0.2 1:9.9.5.dfsg-9ubuntu0.3
2015-09-03 10:27:40 upgrade libbind9-90:amd64 1:9.9.5.dfsg-9ubuntu0.2 1:9.9.5.dfsg-9ubuntu0.3
2015-09-03 10:27:40 upgrade ubuntu-release-upgrader-qt:all 1:15.04.14 1:15.04.14.1
2015-09-03 10:27:40 upgrade ubuntu-release-upgrader-gtk:all 1:15.04.14 1:15.04.14.1
2015-09-03 10:27:41 upgrade ubuntu-release-upgrader-core:all 1:15.04.14 1:15.04.14.1
2015-09-03 10:27:41 upgrade python3-distupgrade:all 1:15.04.14 1:15.04.14.1
2015-09-03 10:27:42 upgrade akonadi-backend-mysql:all 4:15.08.0+git20150828.1615+15.04-0 4:15.08.0+git20150901.0100+15.04-0
2015-09-03 10:27:42 upgrade akonadi-server:amd64 4:15.08.0+git20150828.1615+15.04-0 4:15.08.0+git20150901.0100+15.04-0
2015-09-03 10:27:42 upgrade libkf5akonadiprivate5:amd64 4:15.08.0+git20150828.1615+15.04-0 4:15.08.0+git20150901.0100+15.04-0
2015-09-03 10:27:43 upgrade atom:amd64 1.0.9-1~webupd8~0 1.0.10-1~webupd8~0
2015-09-03 10:27:44 upgrade breeze:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1234+15.04-0
2015-09-03 10:27:48 upgrade qml-module-qtquick-controls-styles-breeze:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1234+15.04-0
2015-09-03 10:27:48 upgrade breeze-cursor-theme:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1234+15.04-0
2015-09-03 10:27:49 upgrade breeze-icon-theme:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1234+15.04-0
2015-09-03 10:27:58 upgrade kde-style-breeze-qt4:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1234+15.04-0
2015-09-03 10:27:59 upgrade kde-style-breeze:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1234+15.04-0
2015-09-03 10:27:59 upgrade libkdecorations2private5v5:amd64 4:5.4.0+git20150831.1502+15.04-0 4:5.4.1+git20150903.1349+15.04-0
2015-09-03 10:28:00 upgrade libkdecorations2-5v5:amd64 4:5.4.0+git20150831.1502+15.04-0 4:5.4.1+git20150903.1349+15.04-0
2015-09-03 10:28:00 upgrade kwin-style-breeze:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1234+15.04-0
2015-09-03 10:28:00 upgrade fonts-oxygen:all 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1355+15.04-0
2015-09-03 10:28:00 upgrade freshplayerplugin:amd64 0.3.2+git20150831~webupd8~vivid 0.3.2+git20150902~webupd8~vivid
2015-09-03 10:28:01 upgrade libkf5service-bin:amd64 5.13.0+git20150829.0209+15.04-0 5.13.0+git20150903.0103+15.04-0
2015-09-03 10:28:01 upgrade libkf5service5:amd64 5.13.0+git20150829.0209+15.04-0 5.13.0+git20150903.0103+15.04-0
2015-09-03 10:28:02 upgrade libkf5service-data:all 5.13.0+git20150829.0209+15.04-0 5.13.0+git20150903.0103+15.04-0
2015-09-03 10:28:02 upgrade libkf5kiocore5:amd64 5.13.0+git20150828.0126+15.04-0 5.13.0+git20150902.0204+15.04-0
2015-09-03 10:28:02 upgrade qml-module-org-kde-extensionplugin:amd64 5.13.0+git20150829.0229+15.04-0 5.13.0+git20150903.0803+15.04-0
2015-09-03 10:28:03 upgrade libkf5activities5:amd64 5.13.0+git20150829.0229+15.04-0 5.13.0+git20150903.0803+15.04-0
2015-09-03 10:28:03 upgrade libkf5filemetadata3:amd64 5.13.0+git20150819.0807+15.04-0 5.13.0+git20150902.0043+15.04-0
2015-09-03 10:28:03 upgrade libkf5filemetadata-data:all 5.13.0+git20150819.0807+15.04-0 5.13.0+git20150902.0043+15.04-0
2015-09-03 10:28:04 upgrade libkf5kiowidgets5:amd64 5.13.0+git20150828.0126+15.04-0 5.13.0+git20150902.0204+15.04-0
2015-09-03 10:28:04 upgrade libkf5kiofilewidgets5:amd64 5.13.0+git20150828.0126+15.04-0 5.13.0+git20150902.0204+15.04-0
2015-09-03 10:28:05 upgrade gwenview:amd64 4:15.08.0+git20150827.1638+15.04-0 4:15.08.0+git20150901.1215+15.04-0
2015-09-03 10:28:05 upgrade libkf5plasma5:amd64 5.13.0+git20150829.0254+15.04-0 5.13.0+git20150903.0123+15.04-0
2015-09-03 10:28:06 upgrade libkf5plasmaquick5:amd64 5.13.0+git20150829.0254+15.04-0 5.13.0+git20150903.0123+15.04-0
2015-09-03 10:28:06 upgrade plasma-framework:amd64 5.13.0+git20150829.0254+15.04-0 5.13.0+git20150903.0123+15.04-0
2015-09-03 10:28:07 upgrade kactivities:amd64 5.13.0+git20150829.0229+15.04-0 5.13.0+git20150903.0803+15.04-0
2015-09-03 10:28:08 upgrade kde-cli-tools:amd64 4:5.4.0+git20150831.1501+15.04-0 4:5.4.1+git20150903.1244+15.04-0
2015-09-03 10:28:08 upgrade kde-cli-tools-data:all 4:5.4.0+git20150831.1501+15.04-0 4:5.4.1+git20150903.1244+15.04-0
2015-09-03 10:28:09 upgrade kde-config-gtk-style:amd64 4:5.4.0+git20150831.1501+15.04-0 4:5.4.1+git20150903.1349+15.04-0
2015-09-03 10:28:09 upgrade kde-config-gtk-style-preview:amd64 4:5.4.0+git20150831.1501+15.04-0 4:5.4.1+git20150903.1349+15.04-0
2015-09-03 10:28:09 upgrade kde-config-sddm:amd64 4:5.4.0+git20150831.1635+15.04-0 4:5.4.1+git20150903.1401+15.04-0
2015-09-03 10:28:10 upgrade liboxygenstyle5-5:amd64 4:5.4.0+git20150831.0032+15.04-0 4:5.4.1+git20150903.1623+15.04-0
2015-09-03 10:28:10 upgrade liboxygenstyleconfig5-5:amd64 4:5.4.0+git20150831.0032+15.04-0 4:5.4.1+git20150903.1623+15.04-0
2015-09-03 10:28:10 upgrade kde-style-oxygen-qt5:amd64 4:5.4.0+git20150831.0032+15.04-0 4:5.4.1+git20150903.1623+15.04-0
2015-09-03 10:28:11 upgrade plasma-theme-oxygen:amd64 4:5.4.0+git20150831.0032+15.04-0 4:5.4.1+git20150903.1623+15.04-0
2015-09-03 10:28:11 upgrade kwin-decoration-oxygen:amd64 4:5.4.0+git20150831.0032+15.04-0 4:5.4.1+git20150903.1623+15.04-0
2015-09-03 10:28:11 upgrade oxygen-sounds:all 4:5.4.0+git20150831.0032+15.04-0 4:5.4.1+git20150903.1623+15.04-0
2015-09-03 10:28:12 upgrade kde-style-oxygen-qt4:amd64 4:5.4.0+git20150831.0032+15.04-0 4:5.4.1+git20150903.1623+15.04-0
2015-09-03 10:28:12 upgrade libkf5ldap5:amd64 15.08.0+git20150826.2311+15.04-0 15.08.0+git20150901.0034+15.04-0
2015-09-03 10:28:13 upgrade kdepimlibs-kio-plugins:amd64 4:15.08.0+git20150831.0032+15.04-0 4:15.08.0+git20150903.0032+15.04-0
2015-09-03 10:28:13 upgrade sddm-theme-breeze:amd64 4:5.4.0+git20150831.0133+15.04-0 4:5.4.1+git20150903.1623+15.04-0
2015-09-03 10:28:13 upgrade libkf5xmlrpcclient5:amd64 5.13.0+git20150826.0226+15.04-0 5.13.0+git20150901.0050+15.04-0
2015-09-03 10:28:14 upgrade libkf5xmlrpcclient-data:all 5.13.0+git20150826.0226+15.04-0 5.13.0+git20150901.0050+15.04-0
2015-09-03 10:28:14 upgrade libkf5kiontlm5:amd64 5.13.0+git20150828.0126+15.04-0 5.13.0+git20150902.0204+15.04-0
2015-09-03 10:28:14 upgrade kio:amd64 5.13.0+git20150828.0126+15.04-0 5.13.0+git20150902.0204+15.04-0
2015-09-03 10:28:16 upgrade milou:amd64 4:5.3.95+git20150822.0324+15.04-0 4:5.4.1+git20150903.1355+15.04-0
2015-09-03 10:28:16 upgrade libkf5networkmanagerqt6:amd64 5.13.0+git20150827.1626+15.04-0 5.13.0+git20150901.1005+15.04-0
2015-09-03 10:28:16 upgrade libkf5screen6:amd64 4:5.4.0+git20150831.1602+15.04-0 4:5.4.1+git20150903.1354+15.04-0
2015-09-03 10:28:17 upgrade libkf5waylandserver5:amd64 4:5.4.0+git20150831.1602+15.04-0 4:5.4.1+git20150903.1349+15.04-0
2015-09-03 10:28:17 upgrade libkf5waylandclient5:amd64 4:5.4.0+git20150831.1602+15.04-0 4:5.4.1+git20150903.1349+15.04-0
2015-09-03 10:28:17 upgrade kwayland-data:all 4:5.4.0+git20150831.1602+15.04-0 4:5.4.1+git20150903.1349+15.04-0
2015-09-03 10:28:18 upgrade libprocesscore7:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1354+15.04-0
2015-09-03 10:28:18 upgrade libprocessui7:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1354+15.04-0
2015-09-03 10:28:18 upgrade libksignalplotter7:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1354+15.04-0
2015-09-03 10:28:19 upgrade libksgrd7:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1354+15.04-0
2015-09-03 10:28:19 upgrade libkf5sysguard-data:all 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1354+15.04-0
2015-09-03 10:28:19 upgrade libkf5sysguard-bin:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1354+15.04-0
2015-09-03 10:28:20 upgrade libkworkspace5-5:amd64 4:5.4.0+git20150831.0133+15.04-0 4:5.4.1+git20150903.1623+15.04-0
2015-09-03 10:28:20 upgrade libplasma-geolocation-interface5:amd64 4:5.4.0+git20150831.0133+15.04-0 4:5.4.1+git20150903.1623+15.04-0
2015-09-03 10:28:21 upgrade libtaskmanager5:amd64 4:5.4.0+git20150831.0133+15.04-0 4:5.4.1+git20150903.1623+15.04-0
2015-09-03 10:28:21 upgrade libweather-ion7:amd64 4:5.4.0+git20150831.0133+15.04-0 4:5.4.1+git20150903.1623+15.04-0
2015-09-03 10:28:21 upgrade plasma-workspace:amd64 4:5.4.0+git20150831.0133+15.04-0 4:5.4.1+git20150903.1623+15.04-0
2015-09-03 10:28:23 upgrade plasma-widgets-addons:amd64 4:5.4.0+git20150831.1502+15.04-0 4:5.4.1+git20150903.1245+15.04-0
2015-09-03 10:28:24 upgrade plasma-dataengines-addons:amd64 4:5.4.0+git20150831.1502+15.04-0 4:5.4.1+git20150903.1245+15.04-0
2015-09-03 10:28:24 upgrade plasma-runners-addons:amd64 4:5.4.0+git20150831.1502+15.04-0 4:5.4.1+git20150903.1245+15.04-0
2015-09-03 10:28:25 upgrade plasma-wallpapers-addons:amd64 4:5.4.0+git20150831.1502+15.04-0 4:5.4.1+git20150903.1245+15.04-0
2015-09-03 10:28:25 upgrade kwin-x11:amd64 4:5.4.0+git20150831.1715+15.04-0 4:5.4.1+git20150903.1457+15.04-0
2015-09-03 10:28:25 upgrade kwin-common:amd64 4:5.4.0+git20150831.1715+15.04-0 4:5.4.1+git20150903.1457+15.04-0
2015-09-03 10:28:26 upgrade kwin-addons:amd64 4:5.4.0+git20150831.1502+15.04-0 4:5.4.1+git20150903.1245+15.04-0
2015-09-03 10:28:26 upgrade kwin-data:all 4:5.4.0+git20150831.1715+15.04-0 4:5.4.1+git20150903.1457+15.04-0
2015-09-03 10:28:27 upgrade libkwinxrenderutils6:amd64 4:5.4.0+git20150831.1715+15.04-0 4:5.4.1+git20150903.1457+15.04-0
2015-09-03 10:28:28 upgrade libkwineffects6:amd64 4:5.4.0+git20150831.1715+15.04-0 4:5.4.1+git20150903.1457+15.04-0
2015-09-03 10:28:28 upgrade libkwinglutils6:amd64 4:5.4.0+git20150831.1715+15.04-0 4:5.4.1+git20150903.1457+15.04-0
2015-09-03 10:28:28 upgrade libkwin4-effect-builtins1:amd64 4:5.4.0+git20150831.1715+15.04-0 4:5.4.1+git20150903.1457+15.04-0
2015-09-03 10:28:29 upgrade kwin:all 4:5.4.0+git20150831.1715+15.04-0 4:5.4.1+git20150903.1457+15.04-0
2015-09-03 10:28:29 upgrade kdeplasma-addons-data:all 4:5.4.0+git20150831.1502+15.04-0 4:5.4.1+git20150903.1245+15.04-0
2015-09-03 10:28:29 upgrade kgamma5:amd64 4:5.4.0+git20150831.1502+15.04-0 4:5.4.1+git20150903.1246+15.04-0
2015-09-03 10:28:30 upgrade khelpcenter:amd64 4:5.4.0+git20150831.1502+15.04-0 4:5.4.1+git20150903.1246+15.04-0
2015-09-03 10:28:31 upgrade khotkeys:amd64 4:5.4.0+git20150826.1852+15.04-0 4:5.4.1+git20150903.1656+15.04-0
2015-09-03 10:28:31 upgrade khotkeys-data:all 4:5.4.0+git20150826.1852+15.04-0 4:5.4.1+git20150903.1656+15.04-0
2015-09-03 10:28:31 upgrade kinfocenter:amd64 4:5.4.0+git20150831.1715+15.04-0 4:5.4.1+git20150903.1457+15.04-0
2015-09-03 10:28:32 upgrade kmenuedit:amd64 4:5.4.0+git20150826.2126+15.04-0 4:5.4.0+git20150831.1921+15.04-0
2015-09-03 10:28:32 upgrade kscreen:amd64 4:5.4.0+git20150831.1715+15.04-0 4:5.4.1+git20150903.1442+15.04-0
2015-09-03 10:28:33 upgrade ksshaskpass:amd64 4:5.4.0+git20150831.1502+15.04-0 4:5.4.1+git20150903.1355+15.04-0
2015-09-03 10:28:33 upgrade ksysguard:amd64 4:5.4.0+git20150831.1715+15.04-0 4:5.4.1+git20150903.1442+15.04-0
2015-09-03 10:28:33 upgrade ksysguard-data:all 4:5.4.0+git20150831.1715+15.04-0 4:5.4.1+git20150903.1442+15.04-0
2015-09-03 10:28:34 upgrade ksysguardd:amd64 4:5.4.0+git20150831.1715+15.04-0 4:5.4.1+git20150903.1442+15.04-0
2015-09-03 10:28:34 upgrade kwalletmanager:amd64 4:15.08.0+git20150826.2341+15.04-0 4:15.08.0+git20150901.0049+15.04-0
2015-09-03 10:28:35 upgrade kwrited:amd64 4:5.4.0+git20150831.1602+15.04-0 4:5.4.1+git20150903.1350+15.04-0
2015-09-03 10:28:35 upgrade libkf5activitiesexperimentalstats1:amd64 4:5.4.0+git20150831.0035+15.04-0 4:5.4.1+git20150903.1656+15.04-0
2015-09-03 10:28:35 upgrade libkf5filemetadata-bin:amd64 5.13.0+git20150819.0807+15.04-0 5.13.0+git20150902.0043+15.04-0
2015-09-03 10:28:36 upgrade libkf5modemmanagerqt6:amd64 5.13.0+git20150813.0030+15.04-0 5.13.0+git20150901.0101+15.04-0
2015-09-03 10:28:36 upgrade libkfontinst5:amd64 4:5.4.0+git20150831.0035+15.04-0 4:5.4.1+git20150903.1656+15.04-0
2015-09-03 10:28:36 upgrade libkfontinstui5:amd64 4:5.4.0+git20150831.0035+15.04-0 4:5.4.1+git20150903.1656+15.04-0
2015-09-03 10:28:37 upgrade muon:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1355+15.04-0
2015-09-03 10:28:37 upgrade muon-updater:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1355+15.04-0
2015-09-03 10:28:37 upgrade muon-notifier:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1355+15.04-0
2015-09-03 10:28:38 upgrade muon-discover:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1355+15.04-0
2015-09-03 10:28:38 upgrade muon-common:all 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1355+15.04-0
2015-09-03 10:28:38 upgrade libmuon:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1355+15.04-0
2015-09-03 10:28:39 upgrade libpowerdevilcore2:amd64 4:5.4.0+git20150830.0032+15.04-0 4:5.4.1+git20150903.1656+15.04-0
2015-09-03 10:28:39 upgrade libpowerdevilui5:amd64 4:5.4.0+git20150830.0032+15.04-0 4:5.4.1+git20150903.1656+15.04-0
2015-09-03 10:28:40 upgrade libslp1:amd64 1.2.1-10 1.2.1-10ubuntu0.1
2015-09-03 10:28:40 upgrade libxenstore3.0:amd64 4.5.0-1ubuntu4.1 4.5.0-1ubuntu4.2
2015-09-03 10:28:40 upgrade libxen-4.5:amd64 4.5.0-1ubuntu4.1 4.5.0-1ubuntu4.2
2015-09-03 10:29:48 upgrade linux-headers-generic:amd64 3.19.0.27.26 3.19.0.28.27
2015-09-03 10:29:48 upgrade linux-headers-lowlatency:amd64 3.19.0.27.26 3.19.0.28.27
2015-09-03 10:30:06 upgrade linux-image-extra-virtual:amd64 3.19.0.27.26 3.19.0.28.27
2015-09-03 10:30:06 upgrade linux-image-generic:amd64 3.19.0.27.26 3.19.0.28.27
2015-09-03 10:30:06 upgrade linux-image-lowlatency:amd64 3.19.0.27.26 3.19.0.28.27
2015-09-03 10:30:07 upgrade linux-libc-dev:amd64 3.19.0-27.29 3.19.0-28.30
2015-09-03 10:30:09 upgrade marble-data:all 4:14.12.3-0ubuntu2 4:15.08.0+git20150901.1104+15.04-0
2015-09-03 10:30:13 upgrade pam-kwallet4:amd64 4:5.4.0+git20150831.1601+15.04-0 4:5.4.1+git20150903.1326+15.04-0
2015-09-03 10:30:13 upgrade pam-kwallet5:amd64 4:5.4.0+git20150831.1601+15.04-0 4:5.4.1+git20150903.1326+15.04-0
2015-09-03 10:30:13 upgrade kde-config-touchpad:all 4:5.4.0+git20150831.0035+15.04-0 4:5.4.1+git20150903.1656+15.04-0
2015-09-03 10:30:14 upgrade kde-touchpad:amd64 4:5.4.0+git20150831.0035+15.04-0 4:5.4.1+git20150903.1656+15.04-0
2015-09-03 10:30:14 upgrade plasma-desktop-data:all 4:5.4.0+git20150831.0035+15.04-0 4:5.4.1+git20150903.1656+15.04-0
2015-09-03 10:30:16 upgrade plasma-desktop:amd64 4:5.4.0+git20150831.0035+15.04-0 4:5.4.1+git20150903.1656+15.04-0
2015-09-03 10:30:17 upgrade polkit-kde-agent-1:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1356+15.04-0
2015-09-03 10:30:17 upgrade plasma-nm:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1356+15.04-0
2015-09-03 10:30:17 upgrade plasma-pa:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1443+15.04-0
2015-09-03 10:30:18 upgrade powerdevil:amd64 4:5.4.0+git20150830.0032+15.04-0 4:5.4.1+git20150903.1656+15.04-0
2015-09-03 10:30:18 upgrade powerdevil-data:all 4:5.4.0+git20150830.0032+15.04-0 4:5.4.1+git20150903.1656+15.04-0
2015-09-03 10:30:19 upgrade systemsettings:amd64 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1401+15.04-0
2015-09-03 10:30:19 upgrade about-distro:amd64 4:5.4.0+git20150831.1715+15.04-0 4:5.4.1+git20150903.1457+15.04-0
2015-09-03 10:30:20 upgrade khelpcenter4:all 4:5.4.0+git20150831.1502+15.04-0 4:5.4.1+git20150903.1246+15.04-0
2015-09-03 10:30:20 upgrade pam-kwallet:all 4:5.4.0+git20150831.1601+15.04-0 4:5.4.1+git20150903.1326+15.04-0
2015-09-03 10:30:20 upgrade polkit-kde-1:all 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1356+15.04-0
2015-09-03 10:30:21 upgrade ttf-oxygen-font-family:all 4:5.4.0+git20150831.1603+15.04-0 4:5.4.1+git20150903.1355+15.04-0
2015-09-03 10:30:21 upgrade user-manager:amd64 4:5.4.0+git20150831.1635+15.04-0 4:5.4.1+git20150903.1402+15.04-0

When I look at my submit.log in the FF directory I see an entry at:

[Thu 03 Sep 2015 10:28:23 AM MST] Crash report submitted successfully


Assuming that it took a few seconds for me to acknowledge the crash the update would have to have occurred before that time. 

Note firefox was not upgraded. Something else that FF depends on was.

Comment 13

3 years ago
Stack trace of failure:


$ firefox -g -safe-mode 
GNU gdb (Ubuntu 7.9-1ubuntu1) 7.9
Copyright (C) 2015 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/lib/firefox/firefox...Reading symbols from /usr/lib/debug//usr/lib/firefox/firefox...done.
done.
(gdb) run
Starting program: /usr/lib/firefox/firefox -safe-mode
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".

(process:9444): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

(firefox:9444): Gtk-WARNING **: Theme directory apps/system-power-actions of theme breeze has no size field


(firefox:9444): Gtk-WARNING **: Theme directory apps/toolbar of theme breeze has no size field


(firefox:9444): Gtk-WARNING **: Theme directory categories/kickoff-menu-tabs of theme breeze has no size field

[New Thread 0x7fffcb608700 (LWP 9494)]
[New Thread 0x7fffcae07700 (LWP 9493)]
[New Thread 0x7fffd987a700 (LWP 9491)]
[New Thread 0x7fffd1fff700 (LWP 9490)]
[New Thread 0x7fffd23ff700 (LWP 9489)]
[New Thread 0x7fffd2dfe700 (LWP 9488)]
[New Thread 0x7fffd35ff700 (LWP 9487)]
[New Thread 0x7fffd4088700 (LWP 9486)]
[New Thread 0x7fffd4889700 (LWP 9485)]
[New Thread 0x7fffd508a700 (LWP 9484)]
[New Thread 0x7fffd588b700 (LWP 9483)]
[New Thread 0x7fffd74ff700 (LWP 9481)]
[New Thread 0x7fffddc24700 (LWP 9480)]
[New Thread 0x7fffd83ff700 (LWP 9479)]
[New Thread 0x7fffd9079700 (LWP 9477)]
[New Thread 0x7fffda7ff700 (LWP 9475)]
[New Thread 0x7fffdb2ff700 (LWP 9474)]
[New Thread 0x7fffdc3ec700 (LWP 9473)]
[New Thread 0x7fffdc46d700 (LWP 9472)]
[New Thread 0x7fffdc4ee700 (LWP 9471)]
[New Thread 0x7fffdc56f700 (LWP 9470)]
[New Thread 0x7fffdc5f0700 (LWP 9469)]
[New Thread 0x7fffdc671700 (LWP 9468)]
[New Thread 0x7fffdc6f2700 (LWP 9467)]
[New Thread 0x7fffdcafd700 (LWP 9466)]
[New Thread 0x7fffe74bb700 (LWP 9465)]
[New Thread 0x7ffff6dbf700 (LWP 9464)]
[New Thread 0x7ffff7eb9700 (LWP 9463)]
[New Thread 0x7ffff7f3a700 (LWP 9462)]
[New Thread 0x7fffdd2fe700 (LWP 9461)]
[New Thread 0x7fffddaff700 (LWP 9460)]
[New Thread 0x7fffdfd65700 (LWP 9459)]
[New Thread 0x7fffe691d700 (LWP 9458)]
[New Thread 0x7fffe9416700 (LWP 9457)]

Program received signal SIGSEGV, Segmentation fault.
arena_dalloc (ptr=0x7fffc9cd2a04, offset=<optimized out>) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/memory/mozjemalloc/jemalloc.c:4709
4709    /build/firefox-VUtMNZ/firefox-40.0.3+build1/memory/mozjemalloc/jemalloc.c: No such file or directory.
(gdb) backtrace
#0  arena_dalloc (ptr=0x7fffc9cd2a04, offset=<optimized out>) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/memory/mozjemalloc/jemalloc.c:4709
#1  0x00007fffc9cbdd91 in ?? () from /usr/lib/mozilla/plugins/libfreshwrapper-pepperflash.so
#2  0x00007fffc9cbe4dc in ?? () from /usr/lib/mozilla/plugins/libfreshwrapper-pepperflash.so
#3  0x00007fffc9cbe813 in ?? () from /usr/lib/mozilla/plugins/libfreshwrapper-pepperflash.so
#4  0x00007fffc9cbe8cd in ?? () from /usr/lib/mozilla/plugins/libfreshwrapper-pepperflash.so
#5  0x00007fffc9c8ad58 in ?? () from /usr/lib/mozilla/plugins/libfreshwrapper-pepperflash.so
#6  0x00007fffc9c8cbd1 in ?? () from /usr/lib/mozilla/plugins/libfreshwrapper-pepperflash.so
#7  0x00007fffc9c8ce3b in NP_GetPluginVersion () from /usr/lib/mozilla/plugins/libfreshwrapper-pepperflash.so
#8  0x00007ffff250622d in nsPluginFile::GetPluginInfo (this=this@entry=0x7fffffff6670, info=..., outLibrary=outLibrary@entry=0x7fffffff6658)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/dom/plugins/base/nsPluginsDirUnix.cpp:333
#9  0x00007ffff24f8ed2 in nsPluginHost::ScanPluginsDirectory (this=this@entry=0x7fffd1352aa0, pluginsDir=<optimized out>, 
    aCreatePluginList=aCreatePluginList@entry=true, aPluginsChanged=aPluginsChanged@entry=0x7fffffff6868)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/dom/plugins/base/nsPluginHost.cpp:1958
#10 0x00007ffff24f93d3 in nsPluginHost::ScanPluginsDirectoryList (this=this@entry=0x7fffd1352aa0, dirEnum=0x7fffca5a22e0, 
    aCreatePluginList=aCreatePluginList@entry=true, aPluginsChanged=aPluginsChanged@entry=0x7fffffff68e3)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/dom/plugins/base/nsPluginHost.cpp:2064
#11 0x00007ffff24f9561 in nsPluginHost::FindPlugins (this=this@entry=0x7fffd1352aa0, aCreatePluginList=aCreatePluginList@entry=true, 
    aPluginsChanged=aPluginsChanged@entry=0x7fffffff6977) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/dom/plugins/base/nsPluginHost.cpp:2257
#12 0x00007ffff24f98bf in nsPluginHost::LoadPlugins (this=0x7fffd1352aa0)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/dom/plugins/base/nsPluginHost.cpp:2148
#13 0x00007ffff24f99de in nsPluginHost::GetPluginTags (this=0x7fffd1352aa0, aPluginCount=0x7fffffff6be0, aResults=0x7fffffff6bf8)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/dom/plugins/base/nsPluginHost.cpp:1124
#14 0x00007ffff161edf5 in NS_InvokeByIndex (that=<optimized out>, methodIndex=<optimized out>, paramCount=<optimized out>, params=<optimized out>)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/xpcom/reflect/xptcall/md/unix/xptcinvoke_x86_64_unix.cpp:176
#15 0x00007ffff19d4204 in Invoke (this=0x7fffffff6b98) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/xpconnect/src/XPCWrappedNative.cpp:2080
#16 Call (this=0x7fffffff6b98) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/xpconnect/src/XPCWrappedNative.cpp:1417
#17 XPCWrappedNative::CallMethod (ccx=..., mode=mode@entry=XPCWrappedNative::CALL_METHOD)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/xpconnect/src/XPCWrappedNative.cpp:1384
#18 0x00007ffff19da094 in XPC_WN_CallMethod (cx=0x7ffff6b49b00, argc=1, vp=0x7fffdc9f95c8)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/xpconnect/src/XPCWrappedNativeJSOps.cpp:1141
#19 0x00007ffff312f579 in CallJSNative (args=..., native=0x7ffff19d9eb0 <XPC_WN_CallMethod(JSContext*, unsigned int, JS::Value*)>, cx=0x7ffff6b49b00)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/jscntxtinlines.h:235
#20 js::Invoke (cx=0x7ffff6b49b00, args=..., construct=<optimized out>) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:736
---Type <return> to continue, or q <return> to quit---
#21 0x00007ffff31295c5 in Interpret (cx=0x7ffff6b49b00, state=...) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:2962
#22 0x00007ffff312f1a9 in js::RunScript (cx=cx@entry=0x7ffff6b49b00, state=...) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:683
#23 0x00007ffff312f4ab in js::Invoke (cx=cx@entry=0x7ffff6b49b00, args=..., construct=construct@entry=js::NO_CONSTRUCT)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:753
#24 0x00007ffff3130b3f in js::Invoke (cx=cx@entry=0x7ffff6b49b00, thisv=..., fval=..., argc=1, argv=<optimized out>, rval=...)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:790
#25 0x00007ffff34b6b75 in js::DirectProxyHandler::call (this=this@entry=0x7ffff554c480 <js::CrossCompartmentWrapper::singleton>, 
    cx=cx@entry=0x7ffff6b49b00, proxy=..., proxy@entry=..., args=...) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/proxy/DirectProxyHandler.cpp:77
#26 0x00007ffff34ca0a9 in js::CrossCompartmentWrapper::call (this=0x7ffff554c480 <js::CrossCompartmentWrapper::singleton>, cx=0x7ffff6b49b00, wrapper=..., 
    args=...) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/proxy/CrossCompartmentWrapper.cpp:289
#27 0x00007ffff34d8ada in js::Proxy::call (cx=cx@entry=0x7ffff6b49b00, proxy=proxy@entry=..., args=...)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/proxy/Proxy.cpp:391
#28 0x00007ffff34d8bea in js::proxy_Call (cx=cx@entry=0x7ffff6b49b00, argc=<optimized out>, vp=<optimized out>)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/proxy/Proxy.cpp:697
#29 0x00007ffff312f6cc in CallJSNative (args=..., native=0x7ffff34d8b90 <js::proxy_Call(JSContext*, unsigned int, JS::Value*)>, cx=0x7ffff6b49b00)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/jscntxtinlines.h:235
#30 js::Invoke (cx=0x7ffff6b49b00, args=..., construct=js::NO_CONSTRUCT) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:729
#31 0x00007ffff31295c5 in Interpret (cx=0x7ffff6b49b00, state=...) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:2962
#32 0x00007ffff312f1a9 in js::RunScript (cx=cx@entry=0x7ffff6b49b00, state=...) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:683
#33 0x00007ffff312f4ab in js::Invoke (cx=cx@entry=0x7ffff6b49b00, args=..., construct=construct@entry=js::NO_CONSTRUCT)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:753
#34 0x00007ffff3474a79 in js::CallOrConstructBoundFunction (cx=0x7ffff6b49b00, argc=1, vp=0x7fffffff8d08)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/jsfun.cpp:1570
#35 0x00007ffff312f579 in CallJSNative (args=..., native=0x7ffff3474820 <js::CallOrConstructBoundFunction(JSContext*, unsigned int, JS::Value*)>, 
    cx=0x7ffff6b49b00) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/jscntxtinlines.h:235
#36 js::Invoke (cx=cx@entry=0x7ffff6b49b00, args=..., construct=construct@entry=js::NO_CONSTRUCT)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:736
#37 0x00007ffff34517d9 in js::fun_call (cx=0x7ffff6b49b00, argc=<optimized out>, vp=0x7fffffff8d08)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/jsfun.cpp:1216
#38 0x00007ffff312f579 in CallJSNative (args=..., native=0x7ffff34516e0 <js::fun_call(JSContext*, unsigned int, JS::Value*)>, cx=0x7ffff6b49b00)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/jscntxtinlines.h:235
#39 js::Invoke (cx=cx@entry=0x7ffff6b49b00, args=..., construct=construct@entry=js::NO_CONSTRUCT)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:736
---Type <return> to continue, or q <return> to quit---
#40 0x00007ffff3130b3f in js::Invoke (cx=cx@entry=0x7ffff6b49b00, thisv=..., fval=..., argc=2, argv=<optimized out>, rval=...)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:790
#41 0x00007ffff34b6b75 in js::DirectProxyHandler::call (this=this@entry=0x7ffff554c480 <js::CrossCompartmentWrapper::singleton>, 
    cx=cx@entry=0x7ffff6b49b00, proxy=..., proxy@entry=..., args=...) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/proxy/DirectProxyHandler.cpp:77
#42 0x00007ffff34ca0a9 in js::CrossCompartmentWrapper::call (this=0x7ffff554c480 <js::CrossCompartmentWrapper::singleton>, cx=0x7ffff6b49b00, wrapper=..., 
    args=...) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/proxy/CrossCompartmentWrapper.cpp:289
#43 0x00007ffff34d8ada in js::Proxy::call (cx=cx@entry=0x7ffff6b49b00, proxy=proxy@entry=..., args=...)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/proxy/Proxy.cpp:391
#44 0x00007ffff34d8bea in js::proxy_Call (cx=cx@entry=0x7ffff6b49b00, argc=<optimized out>, vp=<optimized out>)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/proxy/Proxy.cpp:697
#45 0x00007ffff312f6cc in CallJSNative (args=..., native=0x7ffff34d8b90 <js::proxy_Call(JSContext*, unsigned int, JS::Value*)>, cx=0x7ffff6b49b00)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/jscntxtinlines.h:235
#46 js::Invoke (cx=0x7ffff6b49b00, args=..., construct=js::NO_CONSTRUCT) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:729
#47 0x00007ffff31295c5 in Interpret (cx=0x7ffff6b49b00, state=...) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:2962
#48 0x00007ffff312f1a9 in js::RunScript (cx=cx@entry=0x7ffff6b49b00, state=...) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:683
#49 0x00007ffff312f4ab in js::Invoke (cx=cx@entry=0x7ffff6b49b00, args=..., construct=construct@entry=js::NO_CONSTRUCT)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:753
#50 0x00007ffff3474a79 in js::CallOrConstructBoundFunction (cx=0x7ffff6b49b00, argc=0, vp=0x7fffdc9f9220)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/jsfun.cpp:1570
#51 0x00007ffff312f579 in CallJSNative (args=..., native=0x7ffff3474820 <js::CallOrConstructBoundFunction(JSContext*, unsigned int, JS::Value*)>, 
    cx=0x7ffff6b49b00) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/jscntxtinlines.h:235
#52 js::Invoke (cx=0x7ffff6b49b00, args=..., construct=<optimized out>) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:736
#53 0x00007ffff31295c5 in Interpret (cx=0x7ffff6b49b00, state=...) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:2962
#54 0x00007ffff312f1a9 in js::RunScript (cx=cx@entry=0x7ffff6b49b00, state=...) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:683
#55 0x00007ffff312f4ab in js::Invoke (cx=cx@entry=0x7ffff6b49b00, args=..., construct=construct@entry=js::NO_CONSTRUCT)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:753
#56 0x00007ffff3130b3f in js::Invoke (cx=cx@entry=0x7ffff6b49b00, thisv=..., fval=..., argc=1, argv=<optimized out>, rval=...)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:790
#57 0x00007ffff33fedaa in JS::Call (cx=cx@entry=0x7ffff6b49b00, thisv=..., thisv@entry=..., fval=..., fval@entry=..., args=..., rval=..., rval@entry=...)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/jsapi.cpp:4401
#58 0x00007ffff1ef7d18 in mozilla::dom::AnyCallback::Call (this=0x7fffd20c2850, cx=0x7ffff6b49b00, aThisVal=..., value=..., aRetVal=..., aRv=...)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/obj-x86_64-linux-gnu/dom/bindings/PromiseBinding.cpp:79
#59 0x00007ffff25e1a7d in Call (aCompartment=<optimized out>, aExceptionHandling=<optimized out>, aExecutionReason=<optimized out>, aRv=..., aRetVal=..., 
---Type <return> to continue, or q <return> to quit---
    value=..., this=<optimized out>) at ../../dist/include/mozilla/dom/PromiseBinding.h:134
#60 mozilla::dom::WrapperPromiseCallback::Call (this=0x7fffd20c2880, aCx=0x7ffff6b49b00, aValue=...)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/dom/promise/PromiseCallback.cpp:212
#61 0x00007ffff25dc326 in mozilla::dom::PromiseCallbackTask::Run (this=<optimized out>)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/dom/promise/Promise.cpp:100
#62 0x00007ffff25de233 in mozilla::dom::Promise::PerformMicroTaskCheckpoint () at /build/firefox-VUtMNZ/firefox-40.0.3+build1/dom/promise/Promise.cpp:504
#63 0x00007ffff19cbcc9 in nsXPConnect::AfterProcessNextEvent (this=<optimized out>, aThread=<optimized out>, aRecursionDepth=<optimized out>, 
    aEventWasProcessed=<optimized out>) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/xpconnect/src/nsXPConnect.cpp:980
#64 0x00007ffff1619aa2 in nsThread::ProcessNextEvent (this=0x7ffff6bd09d0, aMayWait=<optimized out>, aResult=0x7fffffffaf87)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/xpcom/threads/nsThread.cpp:906
#65 0x00007ffff162c339 in NS_ProcessNextEvent (aThread=<optimized out>, aThread@entry=0x7ffff6bd09d0, aMayWait=aMayWait@entry=true)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/xpcom/glue/nsThreadUtils.cpp:265
#66 0x00007ffff2adc538 in nsXULWindow::ShowModal (this=0x7fffd3765100) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/xpfe/appshell/nsXULWindow.cpp:367
#67 0x00007ffff2ab3b67 in nsWindowWatcher::OpenWindowInternal (this=0x7fffc9cd2a04, this@entry=0x7fffd9e3fc40, aParent=0x2, 
    aUrl=0x7fffffffb0d8 "\200Yy\323\377\177", aName=0x7fffffffb0e0 "\250\276q\323\377\177", aFeatures=0x5 <error: Cannot access memory at address 0x5>, 
    aCalledFromJS=5, aCalledFromJS@entry=false, aDialog=false, aNavigate=true, aOpeningTab=0x0, argv=0x0, _retval=0x7fffffffb5f8)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/embedding/components/windowwatcher/nsWindowWatcher.cpp:1001
#68 0x00007ffff2ab3dc2 in nsWindowWatcher::OpenWindow (this=0x7fffd9e3fc40, aParent=0x0, aUrl=0x7fffd3779460 "chrome://browser/content/safeMode.xul", 
    aName=0x7fffd5f0e650 "_blank", aFeatures=0x7fffd3799520 "chrome,centerscreen,modal,resizable=no", aArguments=<optimized out>, _retval=0x7fffffffb5f8)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/embedding/components/windowwatcher/nsWindowWatcher.cpp:347
#69 0x00007ffff161edf5 in NS_InvokeByIndex (that=<optimized out>, methodIndex=<optimized out>, paramCount=<optimized out>, params=<optimized out>)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/xpcom/reflect/xptcall/md/unix/xptcinvoke_x86_64_unix.cpp:176
#70 0x00007ffff19d4204 in Invoke (this=0x7fffffffb538) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/xpconnect/src/XPCWrappedNative.cpp:2080
#71 Call (this=0x7fffffffb538) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/xpconnect/src/XPCWrappedNative.cpp:1417
#72 XPCWrappedNative::CallMethod (ccx=..., mode=mode@entry=XPCWrappedNative::CALL_METHOD)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/xpconnect/src/XPCWrappedNative.cpp:1384
#73 0x00007ffff19da094 in XPC_WN_CallMethod (cx=0x7ffff6b49b00, argc=5, vp=0x7fffdc9f9178)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/xpconnect/src/XPCWrappedNativeJSOps.cpp:1141
#74 0x00007ffff312f579 in CallJSNative (args=..., native=0x7ffff19d9eb0 <XPC_WN_CallMethod(JSContext*, unsigned int, JS::Value*)>, cx=0x7ffff6b49b00)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/jscntxtinlines.h:235
#75 js::Invoke (cx=0x7ffff6b49b00, args=..., construct=<optimized out>) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:736
#76 0x00007ffff31295c5 in Interpret (cx=0x7ffff6b49b00, state=...) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:2962
#77 0x00007ffff312f1a9 in js::RunScript (cx=cx@entry=0x7ffff6b49b00, state=...) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:683
---Type <return> to continue, or q <return> to quit---
#78 0x00007ffff312f4ab in js::Invoke (cx=cx@entry=0x7ffff6b49b00, args=..., construct=construct@entry=js::NO_CONSTRUCT)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:753
#79 0x00007ffff3130b3f in js::Invoke (cx=cx@entry=0x7ffff6b49b00, thisv=..., fval=..., argc=3, argv=<optimized out>, rval=...)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/vm/Interpreter.cpp:790
#80 0x00007ffff33fee3a in JS_CallFunctionValue (cx=0x7ffff6b49b00, obj=..., fval=..., args=..., rval=...)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/src/jsapi.cpp:4389
#81 0x00007ffff19d8733 in nsXPCWrappedJSClass::CallMethod (this=0x7fffd9eb9900, wrapper=0x7fffffffc901, methodIndex=65024, info_=0x7fffca03f398,
    nativeParams=0x5) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/js/xpconnect/src/XPCWrappedJSClass.cpp:1212
#82 0x00007ffff161f9a0 in PrepareAndDispatch (self=0x7fffd85cf100, methodIndex=<optimized out>, args=<optimized out>, gpregs=0x7fffffffca00,
    fpregs=0x7fffffffca30) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/xpcom/reflect/xptcall/md/unix/xptcstubs_x86_64_linux.cpp:122
#83 0x00007ffff161ef07 in SharedStub () from /usr/lib/firefox/libxul.so
#84 0x00007ffff15fa2d4 in nsObserverList::NotifyObservers (this=<optimized out>, aSubject=aSubject@entry=0x0,
    aTopic=aTopic@entry=0x7ffff3937335 "final-ui-startup", someData=someData@entry=0x0)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/xpcom/ds/nsObserverList.cpp:113
#85 0x00007ffff15fa384 in nsObserverService::NotifyObservers (this=0x7fffe6092ba0, aSubject=0x0, aTopic=0x7ffff3937335 "final-ui-startup", aSomeData=0x0)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/xpcom/ds/nsObserverService.cpp:330
#86 0x00007ffff2c240d7 in XREMain::XRE_mainRun (this=this@entry=0x7fffffffccc0)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/toolkit/xre/nsAppRunner.cpp:4045
#87 0x00007ffff2c244b1 in XREMain::XRE_main (this=this@entry=0x7fffffffccc0, argc=argc@entry=2, argv=argv@entry=0x7fffffffe1e8,
    aAppData=aAppData@entry=0x7fffffffced8) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/toolkit/xre/nsAppRunner.cpp:4170
#88 0x00007ffff2c246ff in XRE_main (argc=2, argv=0x7fffffffe1e8, aAppData=0x7fffffffced8, aFlags=<optimized out>)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/toolkit/xre/nsAppRunner.cpp:4259
#89 0x00005555555587ae in do_main (argc=2, argv=0x7fffffffe1e8, xreDirectory=0x7ffff6b50780)
    at /build/firefox-VUtMNZ/firefox-40.0.3+build1/browser/app/nsBrowserApp.cpp:214
#90 0x0000555555557ee6 in main (argc=2, argv=0x7fffffffe1e8) at /build/firefox-VUtMNZ/firefox-40.0.3+build1/browser/app/nsBrowserApp.cpp:478

Comment 14

3 years ago
I Removed freshplayerplugin and it resolved the problem for me:

apt-get remove freshplayerplugin

Comment 15

3 years ago
 $ firefox -g -safe-mode 
GNU gdb (Ubuntu 7.7.1-0ubuntu5~14.04.2) 7.7.1
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/lib/firefox/firefox...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/lib/firefox/firefox -safe-mode
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
Traceback (most recent call last):
  File "/usr/share/gdb/auto-load/usr/lib/i386-linux-gnu/libstdc++.so.6.0.19-gdb.py", line 63, in <module>
    from libstdcxx.v6.printers import register_libstdcxx_printers
ImportError: No module named 'libstdcxx'
[New Thread 0xb2711b40 (LWP 4205)]
[Thread 0xb2711b40 (LWP 4205) exited]

(process:4200): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

(firefox:4200): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::sm-connect after class was initialised

(firefox:4200): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::show-crash-dialog after class was initialised

(firefox:4200): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::display after class was initialised

(firefox:4200): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::default-icon after class was initialised
[New Thread 0xb2711b40 (LWP 4207)]
[New Thread 0xaff27b40 (LWP 4208)]
[New Thread 0xaf726b40 (LWP 4209)]
[New Thread 0xb15f4b40 (LWP 4210)]
[New Thread 0xaedffb40 (LWP 4211)]
[New Thread 0xaed7eb40 (LWP 4212)]
[New Thread 0xaecfdb40 (LWP 4213)]
[New Thread 0xaec7cb40 (LWP 4214)]
[New Thread 0xadaffb40 (LWP 4215)]
[New Thread 0xacfffb40 (LWP 4216)]
[New Thread 0xac3ffb40 (LWP 4217)]
[New Thread 0xaeb89b40 (LWP 4218)]
[New Thread 0xab7ffb40 (LWP 4219)]
...

Comment 16

3 years ago
(In reply to Paul from comment #14)
> I Removed freshplayerplugin and it resolved the problem for me:
> 
> apt-get remove freshplayerplugin

I did an update yesterday (that I hadn't allowed in a week or so). Afterward firefox wouldn't start but firefox wasn't one of the items updated.

But I can confirm that removal of freshplayerplugin allowed firefox to start again.

Comment 17

3 years ago
Created attachment 8660142 [details]
case : server distrib of ubuntu + probably incomplete desktop bits added later -> bug

Comment 18

3 years ago
my issue was resolved by   1) in the Home folder, rename the hidden folder .mozilla to .mozillaBACKUP   2) restart firefox. done.

Comment 19

3 years ago
Mint 17.2, based on Ubuntu 14.04.1 bug is still here:

firefox -v

GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
Mozilla Firefox 41.0.1

Also, when firefox starts, it's slow and opens in blocks on the screen instead of all at once.
(Reporter)

Comment 20

2 years ago
For Firefox Nightly 47 , openSUSE leap 42.1 64 bits , Gnome 3.18.2, output here:

raulmalea@mrn /                                                                                                                                                                                      [17:39:46] 
> $ firefox                                                                                                                                                                                                    

(process:6045): GLib-CRITICAL **: g_path_get_basename: assertion 'file_name != NULL' failed
ERROR console.error: web_clipper: 
  Unsupported OS
  Linux
ERROR console.error: web_clipper: 
  Cannot load native lib
console.error: web_clipper: 
  Unsupported OS
Vector smash protection is enabled.
WARNING WARNING
I have this issue with Thunderbird as well as with Firefox in Mageia 5.
I don't use any testing or unstable medias, look here: http://pastebin.com/Z31CWrRX
My version of Thunderbird is 38.5.0.
My version of Firefox is 38.6.0.

The Thunderbird error appears when I install the program in the terminal, look here: http://pastebin.com/RhJw6Hma

I have checked if freshplayerplugin is installed in order to remove it, but it wasn't.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 833117
You need to log in before you can comment on or make changes to this bug.