Closed Bug 1075136 Opened 5 years ago Closed 5 years ago

Initialize TileClient::mCompositableClient correctly

Categories

(Core :: Graphics: Layers, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla35

People

(Reporter: sotaro, Assigned: sotaro)

References

Details

Attachments

(2 files)

TileClient::mCompositableClient is not initialized to a correct value. By it, RemoveTextureFromCompositableTracker is not used correctly.

It could cause tiled layer rendering's tearing/flickering problem.
Assignee: nobody → sotaro.ikeda.g
Attachment #8497757 - Flags: review?(nical.bugzilla)
Attachment #8497757 - Flags: review?(nical.bugzilla) → review+
https://hg.mozilla.org/mozilla-central/rev/f54ea093e836
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Commit https://hg.mozilla.org/integration/mozilla-inbound/rev/f54ea093e836 is causing failures in our automation: http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.b2g-inbound.ui.functional.smoke/316/HTML_Report/
We have test_clock_create_new_alarm.py failing because of this. 
Can you please back it out? Thanks!
Flags: needinfo?(cbook)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
STR to replicate the failure manually:
1. Launch Clock app
2. Tap Add new alarm button 

#Expected results:
Add new alarm page is displayed

#Actual results:
Clock app is closed and we are redirected to Homescreen
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
See also http://logs.glob.uno/?c=mozilla%23gfx&s=2%20Oct%202014&e=2%20Oct%202014#c203163 - :gerard-majax was seeing an error (the attachment shows the contents of his pastebin link, in case it expires) and this is the most likely change to have introduced the problem given his regression range.
I am going to back out the patch.
Flags: needinfo?(cbook)
(In reply to Sotaro Ikeda [:sotaro] from comment #8)
>  https://hg.mozilla.org/integration/mozilla-inbound/rev/64ec6cd769a6

backed out
TiledContentClient has a problem of how to call RemoveTextureFromCompositableAsync(). It caused the problem. This bug's commit just increase the frequency of the function call. Therefore the problem exist as a hidden problem even in current gecko. At first, this IPC problem should be addressed.
Depends on: 1076868
(In reply to Sotaro Ikeda [:sotaro] from comment #10)
> TiledContentClient has a problem of how to call
> RemoveTextureFromCompositableAsync(). It caused the problem. This bug's
> commit just increase the frequency of the function call. Therefore the
> problem exist as a hidden problem even in current gecko. At first, this IPC
> problem should be addressed.

Bug 1076868 handles the ipc problem.
Tested the mozilla-inbound back out build and our tests work as expected

Thanks for fixing this all

Gaia-Rev        191d805f4911628d37a8a90a1e23a6013995138f
Gecko-Rev       https://hg.mozilla.org/integration/mozilla-inbound/rev/64ec6cd769a6
Build-ID        20141002064626
Version         35.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141002.095610
FW-Date         Thu Oct  2 09:56:21 EDT 2014
Bootloader      L1TC10011800
Duplicate of this bug: 1077081
Duplicate of this bug: 1077310
Bug 1076868 was fixed. The STR in comment 5 does not cause the problem when applying the patch.
https://hg.mozilla.org/mozilla-central/rev/2fcc35b3ff89
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Depends on: 1085405
You need to log in before you can comment on or make changes to this bug.