Addon Debugging and Browser Toolbox fail when port is unavailable

RESOLVED DUPLICATE of bug 1392744

Status

RESOLVED DUPLICATE of bug 1392744
4 years ago
2 months ago

People

(Reporter: czerny.jakub, Unassigned)

Tracking

(Blocks: 2 bugs)

32 Branch
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140831201947

Steps to reproduce:

1. Make sure you have at least one debug-able addon installed.
2. Make sure addon debugging is allowed
  2.1 Open developer tools (Ctrl+Shift+k)
  2.2 Settings tab, gear icon
  2.3 Tick 'Enable chrome and addon debugging' in 'Advanced settings' section
2. Open about:addons
3. Click 'Debug' on arbitrary addon
4. Click 'Cancel' on 'Incoming connection' dialog (Empty window (uninitialized debugger) remains visible)
5. Click 'Debug' on arbitrary addon


Actual results:

Nothing happens.

If you run firefox from console, following message appears in console:
DBG-SERVER: Could not start debugging listener on '6080': [Exception... "Component returned failure code: 0x804b0036 (NS_ERROR_SOCKET_ADDRESS_IN_USE) [nsIServerSocket.initSpecialConnection]"  nsresult: "0x804b0036(NS_ERROR_SOCKET_ADDRESS_IN_USE)"  location: "JS frame :: resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/main.js :: DS_openListener :: line 463"  data: no]

If the empty window is closed, everything gets ok.


Expected results:

The empty debugger window should be automatically closed after the connection is refused in step 4 of Steps to reproduce.
(Reporter)

Updated

4 years ago
Component: Untriaged → Developer Tools
The same kind of thing happens if you use the browser toolbox in Firefox instance A, and then try to use it in Firefox instance B, too. No feedback at all - would be good if there was /some/ kind of feedback, at a minimum something like "The port we want to listen on (xxxx) is in use." with suggestions of how to remedy...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: Developer Tools → Developer Tools: Framework
Summary: Debug button at about:addons fails if debugging once refused → Addon Debugging and Browser Toolbox fail when port is unavailable
Blocks: 899054
Blocks: 1090423
This should be resolved by Bug 1392744, as the Browser Toolbox picks a random open port now.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1392744

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.