[Lockscreen] When user changes the loc of the device and locks the screen, the time on the lock screen will go lower each time.

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: SalvadorR, Assigned: gweng)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8497858 [details]
logcat_20140930_1633.txt

Description:
When user changes the language of the device and locks the screen. the timer in the lock screen will go lower every each time the language changes and the device is locked.
   
Repro Steps:
1) Update a Flame device to BuildID: 20140930040206
2) Navigate to settings and change the language of the device
3) After changing the langauge, press the power button
4) Press the power button again to navigate to the lock screen
5) Observe the placement of the timer in the lockscreen

Actual:
The Time in the lockscreen will be placed lower each time the language changes and device locks
  
Expected: 
The placement of the time in the lockscreen will not change when changing languages
  
Flame 2.2 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20140930040206
Gaia: 77ef35f5429bc3dfe9ca192b9aacc3c0bf8857de
Gecko: 7c24470b6b3a
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
  
Notes: When the time gets low enough to overlap the lock bar, the user will no longer be able to unlock their phone
  
Repro frequency: 3/3
See attached: Screenshot, Logcat
(Reporter)

Comment 1

4 years ago
Created attachment 8497859 [details]
Time lower.png
(Reporter)

Comment 2

4 years ago
This issue does not occur on Flame 2.0 KK (319mb) and Flame 2.1 KK (319mb)

Expected: 
The placement of the time in the lockscreen will not change when changing languages

Flame 2.0 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.0
BuildID: 20140930000204
Gaia: 5c2303ec4e367da060aa1b807d541a6549b3d72a
Gecko: 38a496c50d98
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 2.1 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20140930000203
Gaia: a00d102abfe8ae15c4fd14771efa2335c6d3b8d9
Gecko: cde28bd9a285
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Nominating 2.2? since this is a regression and can lead to the user not being able to unlock their phone.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Keywords: regressionwindow-wanted
QA Contact: jmercado
Bug 1057198 seems to be the cause for this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20140928200800
Gaia: 931d547dbd2f4664b6a3c1ff5e4244bca52f96ad
Gecko: a66e8e91480a
Version: 35.0a1 (2.2) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20140928234300
Gaia: 369e3579af3f41fcb9c9c3508d6358ff7b797b64
Gecko: 1085a98ece6c
Version: 35.0a1 (2.2) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Last Working gaia / First Broken gecko - Issue does NOT occcur
Gaia: 931d547dbd2f4664b6a3c1ff5e4244bca52f96ad
Gecko: 1085a98ece6c

First Broken gaia / Last Working gekko - Issue DOES occur
Gaia: 369e3579af3f41fcb9c9c3508d6358ff7b797b64
Gecko: a66e8e91480a

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/931d547dbd2f4664b6a3c1ff5e4244bca52f96ad...369e3579af3f41fcb9c9c3508d6358ff7b797b64
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Caused by Bug 1057198? Can you investigate Greg?
Blocks: 1057198
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Flags: needinfo?(gweng)
Flags: needinfo?(dharris)
(Assignee)

Updated

4 years ago
Assignee: nobody → gweng
Flags: needinfo?(gweng)
Created attachment 8500301 [details] [review]
Patch
Attachment #8500301 - Flags: review?(timdream)
Comment on attachment 8500301 [details] [review]
Patch

One more reason for us to work on lockscreen.js before moving on :)
Attachment #8500301 - Flags: review?(timdream) → review+
Since the only failed test on Gaia-Try is intermittent and irrelevant, I land this patch.
master: https://github.com/mozilla-b2g/gaia/commit/217f6e7b4467ce383d1cf638782a19b4b70691e7
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Derek, can you please verify that this issue is fixed?
Flags: needinfo?(dharris)
Keywords: verifyme
This issue is verified fixed on Flame 2.2

The time does not move down on the lock screen when changing the language and locking the phone, multiple times.


Flame 2.2

Device: Flame 2.2 Master KK (319mb) (Full Flash)
Build ID: 20141015040201
Gaia: 5f1f0960ae9d22acf2a324ad37a48174d6df87f6
Gecko: 62f0b771583c
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 36.0a1 (Master)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(dharris) → needinfo?(ktucker)
Status: RESOLVED → VERIFIED
status-b2g-v2.2: affected → verified
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Blocking 2.2+ for all fixed regressions.
blocking-b2g: 2.2? → 2.2+
You need to log in before you can comment on or make changes to this bug.