No SIM used by NetworkGeolocationProvider

RESOLVED FIXED in mozilla35

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gerard-majax, Assigned: gerard-majax)

Tracking

({dogfood, regression})

Trunk
mozilla35
ARM
Gonk (Firefox OS)
dogfood, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.0 disabled, b2g-v2.0M unaffected, b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

4 years ago
Looks like iterating on the SIM card regressed for MLS:

> 10-01 11:12:31.507   263   263 I Gecko   : *** WIFI GEO: getMobileInfo called
> 10-01 11:12:31.507   263   263 I Gecko   : *** WIFI GEO: getMobileInfo: esrvice=[xpconnect wrapped (nsISupports, nsIGonkMobileConnectionService, nsIMobileConnectionService)]
> 10-01 11:12:31.507   263   263 I Gecko   : *** WIFI GEO: getMobileInfo: found undefined MobileConnectionService

We have service.length being undefined. That makes NetworkGeolocationProvider unable to use the SIM infos to do its job.
(Assignee)

Comment 1

4 years ago
Reproduced on Flame and on Xperia ZR: no 'Looking for SIM X' logcat message is visible.
(Assignee)

Updated

4 years ago
Blocks: 949551
Keywords: dogfood
(Assignee)

Comment 2

4 years ago
Looks like since bug 1063304, service.length should be replaced by service.numItems.
Depends on: 1063304
(Assignee)

Comment 3

4 years ago
> 10-01 11:28:56.404   261   261 I Gecko   : *** WIFI GEO: getMobileInfo called
> 10-01 11:28:56.404   261   261 I Gecko   : *** WIFI GEO: Looking for SIM in slot:0 of 1
> 10-01 11:28:56.414   261   261 I Gecko   : *** WIFI GEO: Use request cache:false reason:No cached data
> 10-01 11:28:56.414   261   261 I Gecko   : *** WIFI GEO: Sending request
> 10-01 11:28:56.414   261   261 I Gecko   : *** WIFI GEO: sending {"cellTowers":[{"radio":"lte","mobileCountryCode":"208","mobileNetworkCode":"20","locationAreaCode":30142,"cellId":128117764}]}

After the change documented in comment 2.
(Assignee)

Comment 4

4 years ago
Created attachment 8498036 [details] [diff] [review]
Use numItems to iterate mobile connection providers r=garvank

Using .length attribute does not work anymore, probably after bug
1063304 landed. The GonkVoicemail code makes a similar use of the
MobileConnectionService and uses numItems to iterate over the providers.
(Assignee)

Updated

4 years ago
Attachment #8498036 - Flags: review?(gkeeley)

Comment 5

4 years ago
Comment on attachment 8498036 [details] [diff] [review]
Use numItems to iterate mobile connection providers r=garvank

Review of attachment 8498036 [details] [diff] [review]:
-----------------------------------------------------------------

The author of bug 1063304 should review this, and check the code for any other potential changes that were missed.
Attachment #8498036 - Flags: review?(gkeeley)
(Assignee)

Comment 6

4 years ago
Created attachment 8498161 [details] [diff] [review]
Use numItems to iterate mobile connection providers r=echen

Using .length attribute does not work anymore, probably after bug
1063304 landed. The GonkVoicemail code makes a similar use of the
MobileConnectionService and uses numItems to iterate over the providers.
(Assignee)

Comment 7

4 years ago
Comment on attachment 8498161 [details] [diff] [review]
Use numItems to iterate mobile connection providers r=echen

Review of attachment 8498161 [details] [diff] [review]:
-----------------------------------------------------------------

Edgar, since you reviewed bug 1063304, would you mind reviewing this? Thanks!
Attachment #8498161 - Flags: review?(echen)
(Assignee)

Updated

4 years ago
Attachment #8498036 - Attachment is obsolete: true

Comment 8

4 years ago
Comment on attachment 8498161 [details] [diff] [review]
Use numItems to iterate mobile connection providers r=echen

Review of attachment 8498161 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you.
Attachment #8498161 - Flags: review?(echen) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Should we uplift this fix to B2G 2.1 (Gecko 34)?
status-b2g-v2.0: --- → disabled
status-b2g-v2.0M: --- → unaffected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected

Comment 10

4 years ago
(In reply to Chris Peterson (:cpeterson) from comment #9)
> Should we uplift this fix to B2G 2.1 (Gecko 34)?

bug 1063304 isn't in 2.1 branch, so we don't need to uplift this fix to 2.1, either.
status-b2g-v2.1: affected → unaffected
https://hg.mozilla.org/integration/b2g-inbound/rev/32c885eeb5bc
Assignee: nobody → lissyx+mozillians
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/32c885eeb5bc
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Whiteboard: [systemsfe]
You need to log in before you can comment on or make changes to this bug.