[Messages][SMS] Messages cold-load-time longer than expected

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: echang, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected)

Details

Attachments

(4 attachments)

*** STR
1. How to get report
2. >adb forward tcp:2828 tcp:2828 
3. >b2gperf messages

*** Actual
Peak found in '20140930160205' (graph Screenshot from 2014-10-01 17:22:51.png)

Datazilla
https://datazilla.mozilla.org/b2g/?branch=v2.1&device=flame-319MB&range=7&test=cold_load_time&app_list=messages&app=messages&gaia_rev=86a3626055ed58b3&gecko_rev=6e7e0a39f73b&plot=avg

(peak)
Gaia-Rev        08be48c71d0b4999cedee89fe81de1a03c66436f 
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/6e7e0a39f73b
Build-ID        20140930160205
2014-10-01 15:03:21,247 B2GPerfRunner INFO    | Results for messages, cold_load_time: median:1752, mean:1812, std: 278, max:2664, min:1527, all:1743,1770,1792,1665,1863,1911,1688,1805,2632,1655,1527,1907,1599,1836,1640,1712,1625,1662,2664,1815,1581,1781,1596,1889,1628,1802,2468,1692,1662,1761

(ok)
Gaia-Rev        a00d102abfe8ae15c4fd14771efa2335c6d3b8d9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/cde28bd9a285
Build-ID        20140930000203
2014-10-01 15:12:13,338 B2GPerfRunner INFO    | Results for messages, cold_load_time: median:1384, mean:1297, std: 218, max:1613, min:912, all:1600,1107,1483,1328,1441,1028,1537,1114,1443,1053,1613,1105,1558,1034,1464,1066,1488,1182,1454,912,1469,1102,1465,1043,1597,1056,1482,1068,1443,1197

(ok)
Gaia-Rev        f6c96ea44ef1c772169336271a1eb9d03426a5e0
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/67a55550347d
Build-ID        20140929160206
2014-10-01 15:40:18,855 B2GPerfRunner INFO    | Results for messages, cold_load_time: median:1360, mean:1322, std: 210, max:1742, min:1027, all:1742,1198,1461,1225,1583,1093,1455,1074,1488,1059,1507,1027,1459,1187,1450,1158,1451,1098,1448,1095,1507,1090,1533,1092,1523,1118,1510,1100,1667,1272


### Version (peak)
Gaia-Rev        08be48c71d0b4999cedee89fe81de1a03c66436f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/6e7e0a39f73b
Build-ID        20140930160205
Version         34.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20140930.191901
FW-Date         Tue Sep 30 19:19:11 EDT 2014
Bootloader      L1TC10011800

### Version (ok)
Gaia-Rev        a00d102abfe8ae15c4fd14771efa2335c6d3b8d9
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/cde28bd9a285
Build-ID        20140930000203
Version         34.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20140930.041115
FW-Date         Tue Sep 30 04:11:26 EDT 2014
Bootloader      L1TC10011800

### Version (ok)
Gaia-Rev        f6c96ea44ef1c772169336271a1eb9d03426a5e0
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-aurora/rev/67a55550347d
Build-ID        20140929160206
Version         34.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20140929.193926
FW-Date         Mon Sep 29 19:39:37 EDT 2014
Bootloader      L1TC10011800
Reporter

Comment 1

5 years ago
Posted file 20140930160205
Reporter

Comment 2

5 years ago
Posted file 20140930000203
Reporter

Comment 3

5 years ago
Posted file 20140929160206
Reporter

Updated

5 years ago
QA Whiteboard: [COM=Gaia::SMS]
Reporter

Updated

5 years ago
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1074783
Hey Eric,

I'm reopening because bug 1074783 is for a different matter.

Here clearly something is wrong. This could be bug 1057915 that has just been uplifted.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
But it could also be just a bad point, we also have some on datazilla on master too.

Note also that if we look at the other measurements (ex: moz-app-loaded or moz-content-loaded) that are more meaningful, we have a huge improvement.

So let's wait some days to see if cold_load_time is good again but in the meantime I'd do nothing.
Eric, do you think we can close this now?
Flags: needinfo?(echang)
Reporter

Comment 9

5 years ago
"cold-load-time" is not supported in test, change to "moz-app-visually-complete" now, the time did drop around 2014/10/10..

https://datazilla.mozilla.org/b2g/?branch=v2.1&device=flame-319MB&range=30&test=startup_%3E_moz-app-visually-complete&app_list=calendar,communications/contacts,communications/dialer,sms&app=calendar&gaia_rev=86b3cdf8bc50698a&gecko_rev=e10231165da5&plot=avg  

Hi Wesley, Any comment?
Flags: needinfo?(echang) → needinfo?(whuang)
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Flags: needinfo?(whuang)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.