Closed Bug 1075532 Opened 6 years ago Closed 5 years ago

The "- Search with <engine>" string is not preceded by the search term after dismissing the suggestions bar

Categories

(Toolkit :: Places, defect)

35 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
firefox35 --- affected

People

(Reporter: avaida, Unassigned)

References

Details

Note: this is a follow-up bug for Bug 1067888.

Reproducible on:
 * Nightly 35.0a1 (2014-10-01)
using Windows 7 64-bit, Ubuntu 14.04 LTS 32-bit and Mac OS X 10.9.5.

STR:
1. Launch Firefox with a clean profile.
2. Type in a search term, e.g. 'example' (w/o apostrophe).
3. Dismiss the suggestions bar without pressing the <enter> key.
4. Click the arrow icon from the awesomebar to bring up the history pane.

ER:
2. The suggestions pane will display the following entry: "example - Search with <default engine>".
4. The awesomebar still displays the following entry: "example - Search with <default engine>".

AR:
4. The awesomebar still displays the following entry: "- Search with <default engine>", missing the search term from the string.

Additional notes:
- This issue is *not a regression*, given that it's reproducible starting with the build in which Bug 1067888 first landed.
- Screenshot depicting the issue: http://i.imgur.com/lziGDnW.png
Flags: qe-verify+
Blocks: 1071461
Currently I see only history items, no "Search with <default engine>", and I think it's right behavior

Version 	43.0a1
Build ID 	20150825030212
Update Channel 	nightly
User Agent 	Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
yeah I think bug 1176437 fixed this by hiding the first entry when the urlbar dropdown is used.
Status: NEW → RESOLVED
Closed: 5 years ago
Depends on: 1176437
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.