Intermittent browser_markupview_anonymous_02.js | application crashed [@ js::NewObjectCache::fill(int, js::Class const*, js::gc::Cell*, js::gc::AllocKind, JSObject*)] | Assertion failure: entry_ == makeIndex(clasp, key, kind), at /builds/slave/m-in-lx-d-

RESOLVED DUPLICATE of bug 1075546

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 1075546
3 years ago
3 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

({assertion, crash})

Trunk
x86
Linux
assertion, crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
Ubuntu VM 12.04 mozilla-inbound debug test mochitest-devtools-chrome-2

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=2685285&repo=mozilla-inbound

08:03:39 INFO - Assertion failure: entry_ == makeIndex(clasp, key, kind), at /builds/slave/m-in-lx-d-00000000000000000000/build/js/src/vm/Runtime.h:334 

08:03:53 WARNING - PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/markupview/test/browser_markupview_anonymous_02.js | application crashed [@ js::NewObjectCache::fill(int, js::Class const*, js::gc::Cell*, js::gc::AllocKind, JSObject*)] 

08:03:53 WARNING - PROCESS-CRASH | chrome://mochitests/content/browser/browser/devtools/markupview/test/browser_markupview_anonymous_02.js | application crashed [@ js::NewObjectCache::fill(int, js::Class const*, js::gc::Cell*, js::gc::AllocKind, JSObject*)]
08:03:53 INFO - Crash dump filename: /tmp/tmp6cotjM.mozrunner/minidumps/0d3bff61-a508-af31-09db4f60-22ac86a3.dmp
08:03:53 INFO - Operating system: Linux
08:03:53 INFO - 0.0.0 Linux 3.2.0-23-generic-pae #36-Ubuntu SMP Tue Apr 10 22:19:09 UTC 2012 i686
08:03:53 INFO - CPU: x86
08:03:53 INFO - GenuineIntel family 6 model 45 stepping 7
08:03:53 INFO - 1 CPU
08:03:53 INFO - Crash reason: SIGSEGV
08:03:53 INFO - Crash address: 0x0
08:03:53 INFO - Thread 0 (crashed)
08:03:53 INFO - 0 libxul.so!js::NewObjectCache::fill(int, js::Class const*, js::gc::Cell*, js::gc::AllocKind, JSObject*) [Runtime.h:f5ccdeb36843 : 334 + 0x18]
08:03:53 INFO - eip = 0xb48141ca esp = 0xbff9efc0 ebp = 0xbff9eff8 ebx = 0xb6ddf030
08:03:53 INFO - esi = 0x00000013 edi = 0xac700000 eax = 0x00000000 ecx = 0xb76148ac
08:03:53 INFO - edx = 0x00000000 efl = 0x00210282
08:03:53 INFO - Found by: given as instruction pointer in context
08:03:53 INFO - 1 libxul.so!js::NewObjectWithGivenProto(js::ExclusiveContext*, js::Class const*, js::TaggedProto, JSObject*, js::gc::AllocKind, js::NewObjectKind) [jsobj.cpp:f5ccdeb36843 : 1580 + 0x2c]
08:03:53 INFO - eip = 0xb4bb7353 esp = 0xbff9f000 ebp = 0xbff9f098 ebx = 0xb6ddf030
08:03:53 INFO - esi = 0xb6dd1020 edi = 0xac700000
08:03:53 INFO - Found by: call frame info
08:03:53 INFO - 2 libxul.so!js::NewObjectWithGivenProto(js::ExclusiveContext*, js::Class const*, js::TaggedProto, JSObject*, js::NewObjectKind) [jsobjinlines.h:f5ccdeb36843 : 974 + 0x27]
08:03:53 INFO - eip = 0xb48691e7 esp = 0xbff9f0a0 ebp = 0xbff9f0c8 ebx = 0xb6ddf030
08:03:53 INFO - esi = 0xb0132150 edi = 0xbff9f100
08:03:53 INFO - Found by: call frame info
08:03:53 INFO - 3 libxul.so!js::obj_create(JSContext*, unsigned int, JS::Value*) [jsobjinlines.h:f5ccdeb36843 : 981 + 0x22]
08:03:53 INFO - eip = 0xb48737b0 esp = 0xbff9f0d0 ebp = 0xbff9f168 ebx = 0xb6ddf030
08:03:53 INFO - esi = 0xb0132150 edi = 0xbff9f100
08:03:53 INFO - Found by: call frame info
08:03:53 INFO - 4 0xa682f088
08:03:53 INFO - eip = 0xa682f089 esp = 0xbff9f170 ebp = 0xbff9f1b4 ebx = 0x9e8e31a0
08:03:53 INFO - esi = 0x9ed1d882 edi = 0x992dd1d0
08:03:53 INFO - Found by: call frame info
08:03:53 INFO - 5 0x992dd1cf
08:03:53 INFO - eip = 0x992dd1d0 esp = 0xbff9f1bc ebp = 0xbff9f210
08:03:53 INFO - Found by: previous frame's frame pointer
08:03:53 INFO - 6 0xa682f5f0
08:03:53 INFO - eip = 0xa682f5f1 esp = 0xbff9f218 ebp = 0xbff9f234
08:03:53 INFO - Found by: previous frame's frame pointer
08:03:53 INFO - 7 0x992da56f
08:03:53 INFO - eip = 0x992da570 esp = 0xbff9f23c ebp = 0xbff9f2a8
08:03:53 INFO - Found by: previous frame's frame pointer
08:03:53 INFO - 8 0xa682f5f0
08:03:53 INFO - eip = 0xa682f5f1 esp = 0xbff9f2b0 ebp = 0xbff9f2dc
08:03:53 INFO - Found by: previous frame's frame pointer
08:03:53 INFO - 9 0x992147a7
08:03:53 INFO - eip = 0x992147a8 esp = 0xbff9f2e4 ebp = 0xbff9f370
08:03:53 INFO - Found by: previous frame's frame pointer
08:03:53 INFO - 10 0xa682f5f0
08:03:53 INFO - eip = 0xa682f5f1 esp = 0xbff9f378 ebp = 0xbff9f3a4
08:03:53 INFO - Found by: previous frame's frame pointer
08:03:53 INFO - 11 0x992147a7
08:03:53 INFO - eip = 0x992147a8 esp = 0xbff9f3ac ebp = 0xbff9f438
08:03:53 INFO - Found by: previous frame's frame pointer
08:03:53 INFO - 12 0xb02029ee
08:03:53 INFO - eip = 0xb02029ef esp = 0xbff9f440 ebp = 0xbff9f488
08:03:53 INFO - Found by: previous frame's frame pointer
08:03:53 INFO - 13 libxul.so!EnterBaseline [BaselineJIT.cpp:f5ccdeb36843 : 116 + 0x39]
08:03:53 INFO - eip = 0xb491ae32 esp = 0xbff9f490 ebp = 0xbff9f5a8
08:03:53 INFO - Found by: previous frame's frame pointer
08:03:53 INFO - 14 libxul.so!js::jit::EnterBaselineMethod(JSContext*, js::RunState&) [BaselineJIT.cpp:f5ccdeb36843 : 147 + 0x6]
08:03:53 INFO - eip = 0xb491b757 esp = 0xbff9f5b0 ebp = 0xbff9f6a8 ebx = 0xb6ddf030
08:03:53 INFO - esi = 0xb0132150 edi = 0xbff9f628
08:03:53 INFO - Found by: call frame info
08:03:53 INFO - 15 libxul.so!Interpret [Interpreter.cpp:f5ccdeb36843 : 2582 + 0x11]
08:03:53 INFO - eip = 0xb4cccf93 esp = 0xbff9f6b0 ebp = 0xbff9faa8 ebx = 0xb6ddf030
08:03:53 INFO - esi = 0x00000000 edi = 0xb0132150
08:03:53 INFO - Found by: call frame info
08:03:53 INFO - 16 libxul.so!js::RunScript(JSContext*, js::RunState&) [Interpreter.cpp:f5ccdeb36843 : 426 + 0x6]
08:03:53 INFO - eip = 0xb4cd03c7 esp = 0xbff9fab0 ebp = 0xbff9fb08 ebx = 0xb6ddf030
08:03:53 INFO - esi = 0xb0132150 edi = 0xbff9fae4
08:03:53 INFO - Found by: call frame info
08:03:53 INFO - 17 libxul.so!js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) [Interpreter.cpp:f5ccdeb36843 : 495 + 0xe]
08:03:53 INFO - eip = 0xb4cc21e5 esp = 0xbff9fb10 ebp = 0xbff9fde8 ebx = 0xb6ddf030
08:03:53 INFO - esi = 0x00000000 edi = 0xbff9fb58
08:03:53 INFO - Found by: call frame info
08:03:53 INFO - 18 libxul.so!js::Invoke(JSContext*, JS::Value const&, JS::Value const&, unsigned int, JS::Value const*, JS::MutableHandle<JS::Value>) [Interpreter.cpp:f5ccdeb36843 : 532 + 0x2e]
08:03:53 INFO - eip = 0xb4cd0d48 esp = 0xbff9fdf0 ebp = 0xbff9fee8 ebx = 0xb6ddf030
08:03:53 INFO - esi = 0xbff9fe68 edi = 0xbff9fe74
08:03:53 INFO - Found by: call frame info
08:03:53 INFO - 19 libxul.so!js::jit::DoCallFallback [BaselineIC.cpp:f5ccdeb36843 : 8653 + 0x4]
08:03:53 INFO - eip = 0xb4eeef78 esp = 0xbff9fef0 ebp = 0xbffa00c8 ebx = 0xb6ddf030
08:03:53 INFO - esi = 0x9ea14e6e edi = 0xb0132150
08:03:53 INFO - Found by: call frame info
08:03:53 INFO - 20 0xb0208d21
08:03:53 INFO - eip = 0xb0208d22 esp = 0xbffa00d0 ebp = 0xbffa012c ebx = 0xbffa00f4
08:03:53 INFO - esi = 0x9ed1a561 edi = 0x991ac550
08:03:53 INFO - Found by: call frame info
08:03:53 INFO - 21 0x991ac54f
08:03:53 INFO - eip = 0x991ac550 esp = 0xbffa0134 ebp = 0xbffa0198
08:03:53 INFO - Found by: previous frame's frame pointer
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 1075546
You need to log in before you can comment on or make changes to this bug.