Moving a tab with swapBrowsersAndCloseOther fails with e10s enabled

RESOLVED DUPLICATE of bug 918634

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 918634
3 years ago
2 years ago

People

(Reporter: Peter J. Sloetjes, Assigned: handyman)

Tracking

35 Branch
Points:
---

Firefox Tracking Flags

(e10sm3+)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20141001030205

Steps to reproduce:

My extension Monitor Master makes use of the browser utility function "swapBrowsersAndCloseOther".


Actual results:

This function fails with e10s enabled.


Expected results:

The code in swapBrowsersAndCloseOther or a function it calls (swapFrameLoaders?) probably needs a minor change to become compatible to e10s.
(Reporter)

Updated

3 years ago
tracking-e10s: --- → ?

Comment 1

3 years ago
I think this will hopefully just end up being a dupe of bug 1029750, but I guess it's possible that a fix there won't fix this directly if they rename functions, so marking a dep for now.
Component: Untriaged → Tabbed Browser
Depends on: 1029750
OS: Windows 7 → All
Hardware: x86_64 → All

Comment 2

3 years ago
It would be so nice if the awesomebar automatically removed bug links that were dupes from its list.
Depends on: 1012784
No longer depends on: 1029750
Assignee: nobody → davidp99
tracking-e10s: ? → m3+
Bug 918634 is the root cause here I think.
Depends on: 918634
No longer depends on: 1012784
(Assignee)

Comment 4

3 years ago
The patch in bug 918634 handles this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 918634

Comment 5

2 years ago
I am still getting NS_ERROR_NOT_IMPLEMENTED browser.xml:1210 when calling swapBrowsersAndCloseOther with e10s enabled. 

browser.xml:1210
--------------------
this.QueryInterface(Components.interfaces.nsIFrameLoaderOwner)
              .swapFrameLoaders(aOtherBrowser);

Fx 46.0a2

Comment 6

2 years ago
(In reply to v.ovcacik from comment #5)
> I am still getting NS_ERROR_NOT_IMPLEMENTED browser.xml:1210 when calling
> swapBrowsersAndCloseOther with e10s enabled. 
> 
> browser.xml:1210
> --------------------
> this.QueryInterface(Components.interfaces.nsIFrameLoaderOwner)
>               .swapFrameLoaders(aOtherBrowser);
> 
> Fx 46.0a2

Please file a new bug with a minimal testcase, ideally something to run from the browser console or somesuch.
You need to log in before you can comment on or make changes to this bug.