Loading a second call URL does not update the call URL

RESOLVED WONTFIX

Status

Hello (Loop)
Client
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: ashughes, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8498418 [details]
Screen Shot 2014-10-01 at 1.16.38 PM.png

Tested on today's Nightly on Mac OS X:
1. User X generates a call URL, copies it and shares it with User Y
2. User Y loads the URL
> Standalone page loads and displays the call URL
3. User X generates a new call URL, copies it and shares it with User Y
4. User Y loads that new URL
> Standalone page still displays the original call URL, not the new one

A screenshot is attached which shows the loaded URL (location bar) being different than what the Standalone page is showing.
(Reporter)

Comment 1

3 years ago
FWIW, also reproduces in Aurora.
status-firefox34: --- → affected
status-firefox35: --- → affected
I had a similar problem today with Nightly.
This is related to the way the browser works with hash.

Since the URL before the hash doesn't change, the page doesn't reload.
I think loop-client should handle the onHashChange event to handle that.
As written, this is actually not a bug in Loop or Firefox (the main browser).  We would need to change the format of the URL  to not use "#" for the parameter.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Reporter)

Updated

3 years ago
status-firefox34: affected → ---
status-firefox35: affected → ---
You need to log in before you can comment on or make changes to this bug.