Wrong sender address when reopening a previously sent message from the Drafts folder after copying it there

VERIFIED INVALID

Status

VERIFIED INVALID
4 years ago
4 years ago

People

(Reporter: supportdoc, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8498532 [details]
screen copy   thunderbird-send-mail-copy-in-drafts .jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

We have multiple accounts and want to resend a sended mail The mail was sent with the account hj.....

We copy the mail in the draft folder ... we open the mail in the draft folder


Actual results:

the mail comes on the eding screen and has as sender an other mail address from an other account .. 


Expected results:

a mail what was send from the account aaa  must be send from the accunt aaa and not from an other and it does not must need to delete other serders account infos ...

PLEASE review the full procedures of transferts, reply .... all have this problem. 

And add a RESEND option on the right mouse button options.
Copying a message to a different account does not change a message's "identity".  To get the identity of the current draft folder, you *must* compose the message and the save the draft *with* the desired identity.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

4 years ago
Dear Wayne Mery,

Do you have not understand the problem? 

I have send a mail from the account "aaa", do to the fact that te mail was not delivered to the receiver I have copied the send mail in the drafts folder ... I open it again .. and I will send the mail ... but now the sender and e the reply mail is not the account "aaa" but an other ... 

I would like that the developpers of Thunderbird stops to deny the fact taht there is a big problem in the send mail procedure. AND  I want also that you take note that teh multiple warning messages with an OK button in Thunderbird are stupid and not need .... 

I am a email expert and not a stupid "Smartphone-Informatic-freak" who will play stupid "games" ... I want that Thunderbird is a intelligent programm not a stupid Game to receive stupid SPAM.

best regards,
John
brainstuff
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 3

4 years ago
In general, "draft" messages have a special heading identifying the identity# of the "From:" address selected, which is used when clicking the "Edit" button. If you copy the message from somewhere else, it's not a "true" draft, and specifically doesn't have that heading. Thus, the default identity is chosen (reproducible also on SeaMonkey).

Now, doing it the "official" way and selecting a message sent from another folder, then using "Edit Message as New" to open it for resending (with or without editing) automagically provides the correct identity for the account from which it was sent.

Thus, it works as intended if the message is reopened as anticipated. Apparently the "Edit" button relies on the identity heading alone whereas "Edit Message as New" looks up the identify in the "From:" heading. This issue is in a similar category as bug 279846 (and likely a couple of related bugs) questioning the concept of using the "X-{Account,Identity}-Key:" headings for identification of draft identities to start with, and the best way might be to just use the "From:" heading as the source to re-associate the sender for all cases.

Updated

4 years ago
Component: Message Compose Window → Composition
OS: Windows 7 → All
Product: Thunderbird → MailNews Core
Hardware: x86_64 → All
Summary: false sender address → Wrong sender address when reopening a previously sent message from the Drafts folder after copying it there
Version: 24 → 32
(In reply to brainstuff John Scheb from comment #2)
> I have send a mail from the account "aaa", do to the fact that te mail was not delivered to the receiver 
> I have copied the send mail in the drafts folder ... 

This is phenomenon of Bug 780124. Did send error such as "Wrong recipient" occur in "Mail Send via SMTP"?

> I open it again .. and I will send the mail ... but now the sender and the reply mail is not the account "aaa" but an other ... 

As  rsx11m explained, "Edit Drafts" relies on X-Identity-Key: idX header of draft mail which is written by Tb if the draft mail is saved by Tb's mail composition.
Because your "draft mail" is copy of "Sent mail copy which was wrongly saved by Bug 780124, your "draft mail" doesn't have the X-Identity-Key: header. This is true on any received mail, any sent mail copy.

If draft mail doesn't have X-Identity-Key: header, or if idX in X-Identity-Key: header is not defined(bug 279846),
"Identity selection for pre-set From: in Edit draft" is;
   1. Default identity of account who owns the Drafts folder
   2. If "account who owns the Drafts folder" doesn't have associated identity(example, "Local Folders" account),
       Default identity of default account. (default account == accountN specified in mail.accountmanager.defaultaccount)
   3. If "default account" doesn't have associated identity, 
       Default identity of "First account who has associated identity" 
       which is defined in mail.accountmanager.accounts=accountNa,accounyNb, ... ,accounyNz.
       Note: This strange state can occur, after deletion of default account, or due to Tb's bug. See bug 881114.

> I have send a mail from the account "aaa", (snip)

Which account's which identity did you use as "From:" in your mail composition?
First identity of account which is named "aaa"?

> the mail was not delivered to the receiver, I have copied the send mail in the drafts folder ...

Drafts folder of which account? "Local Folders"?
Is mail.accountmanager.defaultaccount appropriately set in your environment?

> but now the sender and the reply mail is not the account "aaa" but an other ... 

As rsx11m explained, "Reply/Reply to All etc." != "Edit draft".
   Your Bug summary : when reopening => it sounds "Edit draft" case
   Your comment #2  : reply  mail           => it sounds "Reply etc." case
Which case?
Which account's which identity was actually used?
   Default account? First account in mail.accountmanager.accounts?
(Reporter)

Comment 5

4 years ago
Again: I have send a mail from the acccount "aaa" to freddy@freddy.org. Do to the fact that freddy@freddy.org  has hont fund my mail in his SPAM-folder (we are a stupid people where 90% of the needed mails are filtered by stupid filters in the SPAM folder!) I have copyed the sendet Mail (from aaa to freddy@freddy.org) into the drafts folder. I click to modify .... and I have my mail draft but the sender is now NOT the account "aaa" but "bbb" ! 

It is a simple system: the new "draft" must be a complete copy of the sendet mail ... with the right sender account and the right receiver address .... 

You have to review the complete procedure transfer mails, send mails and send a mail again. Mails who are send from a wrong senders account create a lot of problems ... 

There are a lot of stupid problems in the mail send procedures of thunderbird. 

Again: mails handeled on the account aaa must be independent of all settings of the account "bbb" 
Each account must be handeled sperately. 

Still the stupid "address-Book" of thunderbird must be account relative (with a possibility to build a addressbook for all accounts). The address book must also be divided into 2 parts ... a real address book (with adresses who the user uses actively) and a second address list for the stupid SPAM-Filter.  
I need NOT no reply addresses in my "address-Book" --- I do not call a "no reply" customer. 
 
All this is related with these false senders accounts. It is needed that you clean all these procedures in Thunderbird and that you begins to understand that email is in the moment in his last days when we do NOT made that email becomes again a simple, clear, reliable communications system. 

With false senders addresses and stupid SPAM-Filters we destruct the email system. 

Spam-Filters are stupid. The only way to made that we receive the mails who we need and who are usefuul for us is to clean all these procedures and to create a possibility to use a email system who I have developped: but my system needs a clear handling of each account.
stop posting issues that are not about the bug report.

And please answer the questions in comment 4.
Flags: needinfo?(supportdoc)
(Reporter)

Comment 7

4 years ago
AGAIN: I have multiple accounts on my Thunderbird. When I forward (transfer) or resend a mail who concerns my account "aaa@aaa.com" the mail must be handeled in the same way as if the mail is on a Thunderbird with only ONE account. The sender is the account "aaa@aaa.com", the Reply address is the reply address of the account "aaa@aaa.com" and NOT ANY INFORMATION OF AN OTHER ACCOUNT HAVE TO BE IN MY MAIL. You find again a screenshot of the **** what creates Thunderbird on the following link: 
http://mail2vip.com/vippages/thunderbird-transferts-with-false-sender-address/thunderbird%20resend%20mail.jpg  

AGAIN AND AGAIN : When Thunderbird handle multiple accounts, there must not be any link between the accounts. A mail who was received by the account "aaa@aaa.com" concerns only the account "aaa@aaa.com"! The reply address is "aaa@aaa.com" the sender account is "aaa@aaa.com". The "Organisation" is the Organisation specified in the "aaa@aaa.com" account and not an other ...  
  
On teh screenshot you will see that all is wrong: only the reply address ist the right one. All the rest comes from an other account. The Organisation, the sender. There is not any link between the reply address "hjxxxx" and the sender account "loxxxx". This mail concerns only the account "hjxxxxx" ... 

I handle a mail who was created with the "hjxxxx" account and there is not any need to include informations from the "loxxxx" account ... 


Please understand that each account on a thunderbird system with multiple accounts must work like an account on a Thunderbird with only ONE account. All mails related to the account "aaa@aaa.com" must be handeled by this account. ONLY when the user want to change the sender address, he must be able to change this under his own control ... then the account changes and the reply address also. But if I recive a mail on the "aaa@aaa.com" and I forward, transfer, send or resend the mail ... all informations on the mail stays the informations of the "aaa@aaa.com" account. 

On a system with a single thunderbird account you do also not send some time mails with the informations of the mail account of your grand-mother!!!
Flags: needinfo?(supportdoc)

Comment 8

4 years ago
Please answer the questions in comment 4, separately, by quoting which question you answer.
Flags: needinfo?(supportdoc)
(Reporter)

Comment 9

4 years ago
------
Which account's which identity did you use as "From:" in your mail composition?
First identity of account which is named "aaa"?

> the mail was not delivered to the receiver, I have copied the send mail in the drafts folder ...


Drafts folder of which account? "Local Folders"?
Is mail.accountmanager.defaultaccount appropriately set in your environment?
------

Again: all mails of the account "aaa@aaa.com" must be handeled separately from all other accounts. This also when all mails, from all accounts are stored in the same "incoming mail folder" 

-----
> but now the sender and the reply mail is not the account "aaa" but an other ... 

As rsx11m explained, "Reply/Reply to All etc." != "Edit draft".
   Your Bug summary : when reopening => it sounds "Edit draft" case
   Your comment #2  : reply  mail           => it sounds "Reply etc." case
Which case?
Which account's which identity was actually used?
   Default account? First account in mail.accountmanager.accounts?
------

First account in mail.accountmanager.accounts ....  Again: all mails of the account "aaa@aaa.com" must be handeled separately from all other accounts. In other words: Thunderbird with multiple accounts must handle each account like Thunderbird with only ONE account. The only thing that changes is that it must be possible to modify the sender mail address manually ... by the user, not by thunderbird.

Thunderbird must handle each mail relatet to the concerned mail account. Not to an other mail account if there are multiple accounts. A mail received on the account "aaa@aaa.com" must be handeled by the aaa@aaa.com account ... when I reply, transfer or copy a sendet mail in the draft folder ... the sender address must be aaa@aaa.com and the mail does not have any information from the other accounts. ,
Flags: needinfo?(supportdoc)
(Reporter)

Comment 10

4 years ago
And a remark to the "default" account: it must be possible to change the order of the accounts and to set the default account or you must work without any default account ..... the "default account" concerns ONLY the "write mail" fonction: If I write a new mail, the default sender account must be set as "sender" ... every time when I work on a mail who was received or edited on an other account, the datas of this account are to be used. Probably the best will be that you do not use a default mail function on thunderbird with multiple accounts: when the user create a new mail, he must select the appropriate account or confirm the "default sender account".

Comment 11

4 years ago
Please learn proper quoting by using the "Reply" button and removing unneeded lines. 
I have no idea which lines are by you and which line are quoted.
Flags: needinfo?(supportdoc)
(Reporter)

Comment 12

4 years ago
Lines with ">" on the begining are your questions , lines witout "<" are replys 

>------
>Which account's which identity did you use as "From:" in your mail composition?>
>First identity of account which is named "aaa"?

> the mail was not delivered to the receiver, I have copied the send mail in the drafts folder ...


>Drafts folder of which account? "Local Folders"?
>Is mail.accountmanager.defaultaccount appropriately set in your environment?
>------

Again: all mails of the account "aaa@aaa.com" must be handeled separately from all other accounts. This also when all mails, from all accounts are stored in the same "incoming mail folder" 

>-----
> but now the sender and the reply mail is not the account "aaa" but an other ... 
>
>As rsx11m explained, "Reply/Reply to All etc." != "Edit draft".
>   Your Bug summary : when reopening => it sounds "Edit draft" case
>   Your comment #2  : reply  mail           => it sounds "Reply etc." case
>Which case?
>Which account's which identity was actually used?
>   Default account? First account in mail.accountmanager.accounts?
>------

First account in mail.accountmanager.accounts ....  Again: all mails of the account "aaa@aaa.com" must be handeled separately from all other accounts. In other words: Thunderbird with multiple accounts must handle each account like Thunderbird with only ONE account. The only thing that changes is that it must be possible to modify the sender mail address manually ... by the user, not by thunderbird.

Thunderbird must handle each mail relatet to the concerned mail account. Not to an other mail account if there are multiple accounts. A mail received on the account "aaa@aaa.com" must be handeled by the aaa@aaa.com account ... when I reply, transfer or copy a sendet mail in the draft folder ... the sender address must be aaa@aaa.com and the mail does not have any information from the other accounts. ,
Flags: needinfo?(supportdoc)
(Reporter)

Comment 13

4 years ago
I have also the following related issue  .... I use a specific mail address to get mails from new customers in a specific folder.  

This is the system ... I give to the customer a specific Mail address ... by example support11@bbb.com. Then the customer send the mail to support11@bbb.com on the server we have a forwarder: support11@bbb.com goes to support@bbb.com . The mail comes in on Thunderbird account support@bbb.com and is in the filter  .. all mails with support11@bbb.com are mouved to the folder "new_support_customers" ... Then I find the mail in the folder "new_support_customers" when I responds to the mail ... Thunderbird use an other mail sender address as support@bbb.com.

Again when the receiver address is support@bbb.com then the address of the reply sender must be support@bbb.com NOT any other address of an other account.

Comment 14

4 years ago
Well, in that case I'd expect support11@bbb.com to be used as identity (or the default identity if it doesn't exist) given that this is the target address of the original message. Meaning, it shouldn't matter if the message was moved after that (by a filter rule or manually).

This is different though from what you've filed this bug for, which is specific to moving it to the Drafts folder (and reopening from there uses a different method than replying).
(Reporter)

Comment 15

4 years ago
@rsx11m   this is a "sub-issue" of the bug ... one of the multiple errors when I responds (or transfer) to messages. 

The target address is support@aaa.com (this due to the fact that the Mail server forwards support11@bbb.com to the mail account support@bbb.com). 

The basic problem of this bug is, that thunderbird does not handle each mail account seperately when there are multiple accounts on the tunderbirs session. 

Each mail account must be handeled like it is the only account. It is a very big problem that datas from an other account comes in a not systematic way in the procedure. 

The last issue that I have seen is very crazy ... the response to a mail who came in on support@bbb.com goes out from an other account and was send to the correspondent AND to support@bbb.com  ... I have only clicked on "reply" and the mail had completely false sender datas...  

thanks 

brainstuff
(Reporter)

Comment 16

4 years ago
Correction: AND to support11@bbb.com

Comment 17

4 years ago
A Bug report does not have subissues in the same report. If you want to express a dependency, file a separate report and set a dependency. One issue per report only.
(Reporter)

Comment 18

4 years ago
@andre Klapper  the complete procedure is full of "bugs" ... no need to create a bug report for all kind of these stupid errors. 

AGAIN: on a system with multiple accounts ... each acount must work independently of all other accounts. The only things who can be used for all accounts are the SPAM address Databank and the agreed Mail Adresses

-each account on a thunderbird with multiple accounts must be handles like a single account. 

- each account must have his own addressbook 

- the addressbook must be account realated (for really usefuul adresses  . will mean NOT for noreply@ adresses and NOT for other passive adresses .... passive adresses are adresses where the receiver receives messages but not have to send a response or to have to call the sender ) 

- the "not SPAM" addressbook must be at choice for all or only for one account. 

AND AGAIN: When I reply to a mail received on the mail account aaa@bbb.com all kind of actions (transfer, reply, forward..) must be handeled from the receiver account. Thunderbird does NOT use other accounts ... as long as the user does not change the related email account. 

thanks 
brainstuff

Comment 19

4 years ago
AGAIN: Please stay on the topic of this bug report, no need to reiterate over and over again what you think is the right behavior, and you are not making the rules here: meaning, one issue per bug.

Comment 20

4 years ago
(In reply to brainstuff John Scheb from comment #18)
> @andre Klapper  the complete procedure is full of "bugs" ... no need to
> create a bug report for all kind of these stupid errors. 

Yes, there IS a need to have only one bug per report if you are actually interested in having them properly tracked and giving anybody interested in fixing the chance to investigate. 
This is how bug tracking works, sorry.
(Reporter)

Comment 21

4 years ago
@andre Klapper  ... it is stupid to delete sub-bugs first ...  Again: the whole procedure is bugged! And there are multiple issues related to the first errors. 

Or do you handle a cancerous healt problem with a homeophatic remide? : you goes with a cancerous problem in the head to the orthopedist and he say: you are very healthy ... you do not have " athlete's foot " ? 

AGAIN: please debug the whole procedure, and o not fix you on sub-issues ... when you handle all accounts like an unique account, there will not exist any sub-bug.

Comment 22

4 years ago
Well, except that you are talking about two different pieces of code (one for handling editing drafts, where the originating identity has to be used; the other for replies, where the target identity has to be identified). While that's an "interesting" philosophical discussion, I don't think any more efforts trying explain it to you are worth it since you either don't get it or don't want to get it.
(Reporter)

Comment 23

4 years ago
@  rsx11m   no we do not talking about different pieces of code .. when we are "handling editing drafts" then draft must be handeled by the original account and it must be a choice to change this account. But Thunderbird does NOT change any thing. When Thunderbird handles "replies", Thunderbird must use the datas of the incomming mail and do NOT change from his side the concerned account .. 

All editing procedures of Thunderbird does have the same problems. And all must be debugged. The problem is, that thunderbird does NOT handle each account independent of the other accounts. AGAIN: a mail handeled by the account aaa@bbb.com concerns only the account aaa@bbb.com ... when I edit a draft created by the account aaa@bbb.com thunderbird does not change these account datas ... only when te USER wat to change by exemple the sender account, this is ok. The same must occurs when the user transfer a mail or when he reply to a mais. There is not any situation where Thunderbird have to change the used mail account by itself or to add false sent to addresses.

thanks 
brainstuff

Comment 24

4 years ago
Ok, I'm out of here. Bye. Since you seem to have such intimate knowledge of how things work, it shouldn't be a problem for you to come up with a patch to fix the issue.
Comment hidden (spam)

Comment 26

4 years ago
So write your own email application if you think that you are less stupid? 
It's free software. Take it and make it better. Your feedback here is not very useful - too unstructured.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → INVALID
Comment hidden (spam)

Comment 28

4 years ago
brainstuff, it is more than obviously time to stop here as further continuation won't go anywhere. Just for the record though, unless there is any private communication not documented in this report, you are the only one using the word "freak" here, and 21 out of 23 uses of "stupid" are from your side (of the remaining, one is a quote and the other an echoing of your choice of words). This doesn't take into account similar behavior in other bugs. If you come here with an attitude you can't expect people to be forthcoming. An academic title doesn't have any impact on the merit of your statements made.

I'd agree with Andre's assessment that the discussion here isn't useful at all, and given that the bug has been diluted with general and off-topic discussion it warrants closing. Having said that, comment #3 identifies an issue to be resolved, thus having some kind of fallback if the identity/account-key headers are missing (i.e., using the best-matching identity of the "From" header instead) should also resolve this fringe case. As a general solution to catch many cases tracked by meta bug 699681, getting rid of the key headers could just base the choice of identity on the "From" header alone.

Comment 29

4 years ago
Please do not reopen this ticket. If you do so, your account might get disabled.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → INVALID

Updated

4 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 30

4 years ago
@andre Klapper .... you have not to insult me ... 

The Bug is reallity and NOT INVALID.

You find more screens of this bug on:

http://mail2vip.com/vippages/thunderbird-transferts-with-false-sender-address/a/

The first picture is the received mail ... the second is the mail after I click to reply the third is when I change the sender account to the right and the picture 4 is the correct mail before I send it. 

AGAIN: Rewiev the complete procedure .... and stop to insult me. 

I ask also the chief of this forum to contact me ... I do a lot of work for this community and Andre think he can be agressive against me. I wait for apologies.

Updated

4 years ago
Duplicate of this bug: 1091581
(Reporter)

Comment 32

4 years ago
@Andre Klapper ... I wait still for your excuses ... The reply and transfer procedure of Thunderbird is still bugged and need to be rewieved....
Duplicate of this bug: 1091581

Comment 34

4 years ago
You won't get any apologies. I support Andre's decision to close this bug report due to trolling and off-topic discussions; opening new ones won't help you there and will only keep people busy.
(In reply to brainstuff John Scheb from comment #30)
> @andre Klapper .... you have not to insult me ... 
> 
> The Bug is reallity and NOT INVALID.

What is INVALID is the report, not the problem.

When you have pain in your heart, pain in your teeth and pain in a toenail, you ask a cardiologist to examine your heart, a dentist your teeth, and a pedologist your toenail.

Same thing here: one report, one issue. If you have several issues, open one report for each of them, otherwise the bug report will (as here) be RESOLVED INVALID.

See also:
https://bugzilla.mozilla.org/page.cgi?id=bug-writing.html
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

Comment 36

4 years ago
Tony, his account has been deactivated since, given that this wasn't his first episode.
You need to log in before you can comment on or make changes to this bug.