Closed Bug 1076701 Opened 6 years ago Closed 6 years ago

[Contact] Improve UI on index circle for the Contact list

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(tracking-b2g:backlog, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S8 (7Nov)
tracking-b2g backlog
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: Carol, Assigned: jmcf)

References

Details

Attachments

(4 files)

Attached image screenshot.png
the index circle need some adjustment.
I need info Fang for the UI spec.
Flags: needinfo?(fshih)
Attached image Contact_newindex.png
Attached the new visual spec, Thanks!
Flags: needinfo?(fshih)
Blocks: 1069288
Assignee: nobody → pivanov
This looks bad. Please fix
blocking-b2g: --- → 2.1?
Whiteboard: [Tako_Blocker]
Triage: This issue is a minor UI polish and cannot be considered as a blocker then (https://wiki.mozilla.org/B2G/Triage#Issues_that_Should_Not_Block). Moreover, the current implementation was signed off for 2.1 weeks ago.
blocking-b2g: 2.1? → -
As discussed can we look at the possibility to take this in case we are done with all our blockers?
Flags: needinfo?(francisco)
Will schedule it for next sprint, will take in this if we run out of work to do :P
Flags: needinfo?(francisco)
Target Milestone: --- → 2.1 S9 (21Nov)
blocking-b2g: - → backlog
Partner raised serious concern as this doesn't pass their UX criteria for v2.1. 
raised internal discussion for getting approval. (wilfred, wesley are in the loop)

may i understand the effort and the risk to fix this issue?
Flags: needinfo?(francisco)
I can take this bug if Pavel is swamped and happy to do reviews as well.
Assignee: pivanov → jmcf
Target Milestone: 2.1 S9 (21Nov) → 2.1 S8 (7Nov)
Hopefuly will be just a css change
Flags: needinfo?(francisco)
Attached file 25768.html
Attachment #8515932 - Flags: ui-review?(fshih)
Attachment #8515932 - Flags: review?(pivanov)
Comment on attachment 8515932 [details]
25768.html

only one nit:

"background: rgba(80, 80, 80, 0.8);"
can we use "background-color" instead "background"
Attachment #8515932 - Flags: review?(pivanov) → review+
Status: NEW → ASSIGNED
hi Bhavana,

since it's review+, i would like to request approval to uplift to 2.1
Flags: needinfo?(bbajaj)
Comment on attachment 8515932 [details]
25768.html

Overall it looks good. Just want to make sure the highlighted letter is horizontal / vertical centered inside of highlight circle. Now it seems a bit high. Thanks!
Attachment #8515932 - Flags: ui-review?(fshih) → ui-review-
(In reply to Fang Shih [:grasspizza] from comment #14)
> Comment on attachment 8515932 [details]
> 25768.html
> 
> Overall it looks good. Just want to make sure the highlighted letter is
> horizontal / vertical centered inside of highlight circle. Now it seems a
> bit high. Thanks!

Fang, the content inside the circle is both vertically and horizontally aligned. Probably that misalignment can be due to the different sizes of the different letters and the font family characteristics. I'm gonna land it. Please file a new bug in case you still feel there is a misalignment.
https://github.com/mozilla-b2g/gaia/commit/5b185fb3c26a814787b544cc9ef2770a8b223ec6
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Comment on attachment 8515932 [details]
25768.html

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Visual refresh contacts app
[User impact] if declined: Poor UX perception
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): No-risk patch. Only CSS changes
[String changes made]: none
Attachment #8515932 - Flags: approval-gaia-v2.1?
Attachment #8515932 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Attached video Verify_Video_Flame.MP4
This issue has been verified successfully on Flame 2.1 & 2.2.
See attachment: Verify_Video_Flame.MP4
Reproducing rate: 0/10

Flame v2.1 version:
Gaia-Rev        1bdd49770e2cb7a7321e6202c9bf036ab5d8f200
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/db893274d9a6
Build-ID        20141125001201
Version         34.0

Flame 2.2 version:
Gaia-Rev        824a61cccec4c69be9a86ad5cb629a1f61fa142f
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/acde07cb4e4d
Build-ID        20141125040209
Version         36.0a1
Status: RESOLVED → VERIFIED
Whiteboard: [Tako_Blocker]
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.