[Loop] The app is blocked on No Available window if the other parties is not available

VERIFIED FIXED

Status

--
blocker
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: mbarone976, Assigned: borjasalguero)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile app][blocking][tef-triage][patch available])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8498720 [details]
2014-10-02-10-15-05.png

Device: Flame kk (v180)
Loop version: d1e6002
Gaia/Gecko: 9725d18/b7ca55f

Precondition: Device B not logged into Loop with mobile ID

STR
1. Create a contact in device A with valid Loop mobile ID
2. In Device A, from Contact detail make a video call 

ACTUAL RESULT
When the Loop app discover that the user on device B is not available, the call is ends but the app remains on Not Available window.
Whiteboard: [mobile app][blocking] → [mobile app][blocking][tef-triage]
(Reporter)

Comment 1

4 years ago
I forgot, is not reproducible 100% and when the app remains on the Not available window, you have to restart the device because is not possible to kill the app

Updated

4 years ago
Assignee: nobody → carmen.jimenezcabezas
I think we've found a STR for this bug. 

1. Establish a Loop call between two users registered in Loop application (A and B). So you can see in the call log of Device A the corresponding entry for that specific user (B).
2. Remove B user from the Agenda in device A, so in the call log you can see the identity used for B to register in Loop instead of his contact name.
3. Log-out user B from Loop
4. User A makes a loop call to B by tapping the last entry in the Loop call log.

CURRENT RESULT:
Attention screen showing "Unavailable" status is not closed. You can only skip that error by restarting the device.

EXPECTED RESULT:
Unavailable status is shown and attention screen is closed. After that Share URL screen is offered to the user.
(Assignee)

Comment 3

4 years ago
I've found the issue, stealing for a quick fix!
Assignee: carmen.jimenezcabezas → borja.bugzilla
(Assignee)

Comment 4

4 years ago
Created attachment 8501251 [details] [review]
Pull Request
Attachment #8501251 - Flags: review?(josea.olivera)
Status: NEW → ASSIGNED
Whiteboard: [mobile app][blocking][tef-triage] → [mobile app][blocking][tef-triage][patch available]
Comment on attachment 8501251 [details] [review]
Pull Request

LGTM. r=me

Left a couple of nits on the patch, have a look and address them please. Land at will once that gets done. Thanks!
Attachment #8501251 - Flags: review?(josea.olivera) → review+
(Assignee)

Comment 6

4 years ago
Comments addressed! Thanks!
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 7

4 years ago
Verified on loop 1.1, V.e01ef76
Flame: 2.0.184based.Gecko-675d616.Gaia-2183b4f
FireE: firee-kk-v2.0-SW2E5-4
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.