Closed Bug 1076808 Opened 7 years ago Closed 7 years ago

[OpenH264] v1.0 displayed in License information and crash reports instead of v1.1

Categories

(External Software Affecting Firefox :: OpenH264, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: adalucinet, Unassigned)

References

(Blocks 1 open bug)

Details

Reproducible on:
Firefox 33 beta 8 (BuildID: 20140929180120):
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
latest Aurora 34.0a2 (BuildID: 20141001004005):
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
latest Nightly 35.0a1 (BuildID: 20141001030205): 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0

STR:
1. Launch Firefox with a clean profile.
2. Go to Add-ons Manager -> Plugins and click on the Options/Preferences button for the openH264 plugin.
3. Click on License information link.
4. Scroll to the bottom of the new opened page.

Expected results: v1.1 is displayed.

Actual results: v1.0 is displayed.

Notes:
1. Also reproducible on Ubuntu 14.04 32-bit, Mac OS X 10.9.5 and Surface Pro 2 (Windows 8.1 64-bit)
2. Version: 1.0 is also displayed on Crash Reports/Process Type: bp-dbacd42b-9e84-407d-ba83-3f5e72141002
The 1.0 is actually part of the original license, so this seems more like something for Cisco to change (and us to update then)?
http://www.openh264.org/faq.html#binary
v1.0 is the version of the license and is at the bottom there just in case we were to ever have to revise the license.  That is highly, highly unlikely.   It does not refer to code revisions.
Ah, thanks for the clarification.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 1.x → unspecified
You need to log in before you can comment on or make changes to this bug.