Closed Bug 1076841 Opened 8 years ago Closed 8 years ago

getUserMedia Video broken due to delayed init of MediaPlayers

Categories

(Firefox for Android Graveyard :: General, defect)

35 Branch
ARM
Android
defect
Not set
normal

Tracking

(firefox35 verified, fennec35+)

VERIFIED FIXED
Tracking Status
firefox35 --- verified
fennec 35+ ---

People

(Reporter: TeoVermesan, Assigned: gcp)

References

Details

(Keywords: regression, reproducible)

Attachments

(1 file)

Tested with:
Device: Samsung Galaxy S5 (Android 4.4)
Build: Firefox for Android 35.0a1 (02-10-2014)

Steps to reproduce:
1. Go to: http://mozilla.github.io/webrtc-landing/gum_test.html
2. Choose Video
3. Choose share from the doorhanger notification

Expected result:
- A video should appear with the built-in camera active showing the content from my camera.

Actual result:
- "Starting video failed" is displayed

May be bug 1074202 the cause?
Flags: needinfo?(teodora.vermesan)
tracking-fennec: --- → ?
I see W/GeckoEventDispatcher( 6810): No listeners for MediaPlayer:Get
Keywords: reproducible
(In reply to Aaron Train [:aaronmt] from comment #1)
> I see W/GeckoEventDispatcher( 6810): No listeners for MediaPlayer:Get

That is Chromecast related and should not be related to this issue. This is probably happening because we are delaying the MediaPlayerManager loading for performance reasons. Again, should not be related to this bug.
Last good revision: 124797ab4a5c
First bad revision: a1d7b16101c7
Pushlog:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=124797ab4a5c&tochange=a1d7b16101c7

wjohnston@mozilla.com
Wed Oct 01 16:43:41 2014 +0000	a1d7b16101c7	Wes Johnston — Bug 1064669 - Initialize MediaPlayers in delayed startup. r=mfinkle
Blocks: 1064669
Flags: needinfo?(teodora.vermesan)
Summary: Video / getUserMedia is broken → Regression: getUserMedia Video broken due to delayed init of MediaPlayers
I'll investigate closer what's really up here.
Assignee: nobody → gpascutto
E/WEBRTC-JC(13864): startCapture failed
E/WEBRTC-JC(13864): java.lang.IllegalThreadStateException: Expected thread 1 ("main"), but running on thread 483 ("Thread-483")
E/WEBRTC-JC(13864):     at org.mozilla.gecko.util.ThreadUtils.assertOnThreadComparison(ThreadUtils.java:171)
E/WEBRTC-JC(13864):     at org.mozilla.gecko.util.ThreadUtils.assertOnUiThread(ThreadUtils.java:116)
E/WEBRTC-JC(13864):     at org.mozilla.gecko.GeckoApp.addAppStateListener(GeckoApp.java:250)
E/WEBRTC-JC(13864):     at org.webrtc.videoengine.VideoCaptureAndroid.startCapture(VideoCaptureAndroid.java:210)
E/WEBRTC-JC(13864):     at dalvik.system.NativeStart.run(Native Method)
D/WEBRTC-JC(13864): stopCapture
(In reply to Aaron Train [:aaronmt] from comment #3)

> Wed Oct 01 16:43:41 2014 +0000	a1d7b16101c7	Wes Johnston — Bug 1064669 -
> Initialize MediaPlayers in delayed startup. r=mfinkle

This is indeed the bug that caused it, the patch for it is simply completely broken.
Attachment #8499491 - Flags: review?(mark.finkle)
Attachment #8499491 - Flags: review?(mark.finkle) → review+
Backed out, see 1064669.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
tracking-fennec: ? → 35+
Flags: qe-verify+
Flags: in-testsuite?
Summary: Regression: getUserMedia Video broken due to delayed init of MediaPlayers → getUserMedia Video broken due to delayed init of MediaPlayers
Verified as fixed in Firefox for Android 35 Beta 1 with Nexus 4 (Android 4.4.4).
Status: RESOLVED → VERIFIED
Based on comment 9, I will remove the qe-verify flag, thanks.
Flags: qe-verify+
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.