Make LogicalMargin and LogicalRect's IsEmpty have the same semantic as the base classes

RESOLVED FIXED in mozilla35

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: smontagu, Assigned: smontagu)

Tracking

Trunk
mozilla35
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Created attachment 8498994 [details] [diff] [review]
is.empty.diff

Back in bug 789096 I added an IsEmpty shorthand to LogicalMargin and LogicalRect. What I didn't notice is that nsMargin and nsRect already have an IsEmpty, and the semantic is different.

This is the cause of some of the bugs in my w-i-p patch for bug 1062963.
Attachment #8498994 - Flags: review?(jfkthame)
(Assignee)

Updated

4 years ago
Assignee: nobody → smontagu
Attachment #8498994 - Flags: review?(jfkthame) → review+
https://hg.mozilla.org/mozilla-central/rev/e2ae0efd508a
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
You need to log in before you can comment on or make changes to this bug.