Firefox 33 Beta 8 processes keyboard events very slow

RESOLVED DUPLICATE of bug 1089183

Status

()

defect
RESOLVED DUPLICATE of bug 1089183
5 years ago
5 years ago

People

(Reporter: frfxtst, Unassigned)

Tracking

33 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

Open the add-ons dialog via the "Tools/Add-ons" menu and go to the "Extensions" section. Press the "alt" key. Type some text in the search box.


Actual results:

It takes very long until the menue is shown. Typing is pretty sluggish.
When I try the same with Firefox 33 Beta 7, everything is fine.

I found this problem when I tried my add-on EPUBReader with this Firefox version. When I use the add-on everything is very slow, e.g. paging, opening/closing the table of content tab. Using Firefox 33 Beta 7 everyhing is fine.

As I assume, that many other add-ons are effected, the priority of this problem is in my opinion high.
Just to make it clear: this problem occurs without any add-ons installed.
Here is the output of about support for the graphics section:

Direct2D aktiviert	true
DirectWrite aktiviert	true (6.1.7600.16385)
Geräte-ID	0x68f9
GPU #2 aktiv	false
GPU-beschleunigte Fenster	1/1 Direct3D 10
Karten-Beschreibung	ATI Radeon HD 5450
Karten-RAM	1024
Karten-Treiber	atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Treiber-Datum	12-9-2009
Treiber-Version	8.682.1.0
Vendor-ID	0x1002
WebGL-Renderer	Google Inc. -- ANGLE (ATI Radeon HD 5450 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	false
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Here is the english output of the graphics section:

Adapter Description	ATI Radeon HD 5450
Adapter Drivers	atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM	1024
Device ID	0x68f9
Direct2D Enabled	true
DirectWrite Enabled	true (6.1.7600.16385)
Driver Date	12-9-2009
Driver Version	8.682.1.0
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 11 (OMTC)
Vendor ID	0x1002
WebGL Renderer	Google Inc. -- ANGLE (ATI Radeon HD 5450 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated
because this is only occurring while layers.offmainthreadcomposition.enabled is set to true (discussed in #firefox on irc), this is probably (re?)introduced by bug 1074045.

needinfoing bas schouten because bug 1074045 was assigned to him, if there is more troubleshooting information that would be helpful gathering here...
Flags: needinfo?(bas)
I just made some further testing with ff33 beta 8. It seems to be that typing is very sluggish in general. No matter if i enter an url in the url bar or type some text in an input field on a website. So it's really not much fun using this version.

I guess I'm not the only one with such problems. Would it be possible to set layers.offmainthreadcomposition.enabled back to "false" in the final ff33 release?
Component: Untriaged → Graphics
Product: Firefox → Core
I'm experiencing similar keyboard input events being very slow to be processed, with FF 33.02 on windows 7. This was also reported independently by other users into https://support.mozilla.org/en-US/questions/1022825

I'm experiencing this lag when using the address bar, or using web sites (e.g. google docs) which become unuseable. Not better after starting from a fresh profile, updating all plugins. I thought it could come from by computer, but the problem does not reproduce in chrome or other windows apps, only in FF
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1089183
Flags: needinfo?(bas)
You need to log in before you can comment on or make changes to this bug.