Closed Bug 1077277 Opened 5 years ago Closed 4 years ago

Testcase were a solid white video comes out solid gray

Categories

(Core :: Audio/Video: Playback, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jya, Unassigned)

References

Details

Attachments

(1 file)

From https://bugzilla.mozilla.org/show_bug.cgi?id=941296#c92

"I'm not sure if this is the right place but this link pointed me to this bug: https://developer.mozilla.org/en-US/docs/Web/HTML/Supported_media_formats

I'm having some issues with MP4:s that we are using in a current project. Our videos have a solid white background but in OS X Nightly (as of 2014-10-02) the background comes out as light gray. The same video works correctly in Chrome and Safari.

Screenshot of how it looks in Chrome: http://cl.ly/XqAI

Screenshot of how it looks in Nightly: http://cl.ly/XqDx

These screenshots are of the attached test-case."
See Also: → 941296
Works for me on both aurora and nightly. This is on a mac pro 2013 with a D500 graphic card

Aurora uses YUV420 output format (and studio level).
Nightly uses RGB32, as such the PC vs Studio level aren't relevant (unless Apple HW conversion is wrong)
(Original commenter)

I'm on an MBPr (late 2013) with a NVIDIA GeForce GT 750M 2048 MB graphics card.

I tried it in Aurora and it works properly there: http://cl.ly/XrbS
Works fine on MBA late-2013 with intel HD5000
(In reply to Johan Larsson from comment #2)
> (Original commenter)
> 
> I'm on an MBPr (late 2013) with a NVIDIA GeForce GT 750M 2048 MB graphics
> card.
> 
> I tried it in Aurora and it works properly there: http://cl.ly/XrbS

are you sure you are using the built-in video decoder and not some plugins ?
confirmed that with nvidia video card on MBPr late 2013 it's grey.

I would lodge a bug with Apple that their format conversion is buggy there.

Would probably be fixed if we completed bug 1061525
Depends on: 1061525
Bug lodged upstream as Apple bug 18546407
It's grey here too. FF33 new profile, Windows 8.1, GTS450, which has nothing to do with apple.
On central it seems to be okay.
This is likely related to bug 879099.

It appears that nvidia handles colour conversion differently (and are actually the only ones doing it right)
(In reply to Jean-Yves Avenard [:jya] from comment #8)
> This is likely related to bug 879099.
> 
> It appears that nvidia handles colour conversion differently (and are
> actually the only ones doing it right)

I don't think that bug is the same. I still get gray video, even though I use the workaround for that bug to get proper video.
And if I set limited range, I get an even grayer video.
Component: Audio/Video → Audio/Video: Playback
on mac, unlikely since we are using YUV all the way with no RGB conversion
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.