[v2.0] Investigate test_camera_capture_video failure

RESOLVED DUPLICATE of bug 1081473

Status

RESOLVED DUPLICATE of bug 1081473
4 years ago
4 years ago

People

(Reporter: cynthiatang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8499498 [details]
screenshot

[Description]
Running test_camera_capture_video on V2.0 is failed on Jenkins because the camera app fails to record a video.

I can reproduce it locally on my desktop. 

Reproduction rate: 100%

Traceback (most recent call last):
  File "/var/lib/jenkins/JenkinsCI/B2G_Flame_2dot0_Kitkat/gaia/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client_mozilla_b2g32_v2_0-0.1-py2.7.egg/marionette/marionette_test.py", line 170, in run
    testMethod()
  File "/var/lib/jenkins/JenkinsCI/B2G_Flame_2dot0_Kitkat/gaia/tests/python/gaia-ui-tests/gaiatest/tests/functional/camera/test_camera_capture_video.py", line 28, in test_capture_a_video
    self.camera.record_video(3)
  File "/var/lib/jenkins/JenkinsCI/B2G_Flame_2dot0_Kitkat/gaia/tests/python/gaia-ui-tests/gaiatest/apps/camera/app.py", line 64, in record_video
    self.wait_for_video_capturing()
  File "/var/lib/jenkins/JenkinsCI/B2G_Flame_2dot0_Kitkat/gaia/tests/python/gaia-ui-tests/gaiatest/apps/camera/app.py", line 103, in wait_for_video_capturing
    self.wait_for_condition(lambda m: self.marionette.find_element(
  File "/var/lib/jenkins/JenkinsCI/B2G_Flame_2dot0_Kitkat/gaia/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 54, in wait_for_condition
    Wait(self.marionette, timeout).until(method, message=message)
  File "/var/lib/jenkins/JenkinsCI/B2G_Flame_2dot0_Kitkat/gaia/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client_mozilla_b2g32_v2_0-0.1-py2.7.egg/marionette/wait.py", line 143, in until
    cause=last_exc)
TimeoutException: TimeoutException: Timed out after 30.1 seconds


https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/tests/functional/camera/test_camera_capture_video.py

https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/apps/camera/app.py
(Reporter)

Comment 1

4 years ago
This issue could be reproduced after flashing the phone. But it work well when I use PDB to debug.  

[Attachment]
logcat.txt

[Build Information]
Gaia-Rev        092d2b7678774c8b0b06dca0e0a8119e9eafdec3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/69ca61f7edf3
Build-ID        20141006000202
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141006.034615
FW-Date         Mon Oct  6 03:46:38 EDT 2014
Bootloader      L1TC10011800
(Reporter)

Comment 2

4 years ago
Created attachment 8500911 [details]
logcat.txt
I can't reproduce this issue manually.


The camera app object is really old. I will try to put together some updates
Cynthia can you try to uplift the updates the changes from master to v.20 

https://github.com/mozilla-b2g/gaia/commits/master/tests/python/gaia-ui-tests/gaiatest/apps/camera/app.py
Flags: needinfo?(ctang)
(Reporter)

Comment 5

4 years ago
Hi Florin, 

I tried to run Gaia UI test for Camera function after updating "app.py". But it doesn't work. 

====================================================
starting httpd
running webserver on http://192.168.47.130:54681/
TEST-START test_camera_multiple_shots.py
test_capture_multiple_shots (test_camera_multiple_shots.TestCameraMultipleShots)
https://moztrap.mozilla.org/manage/case/1325/ ... ERROR

======================================================================
ERROR: None
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/u/Flame20/virenv/gu/local/lib/python2.7/site-packages/marionette_client_mozilla_b2g32_v2_0-0.1-py2.7.egg/marionette/marionette_test.py", line 170, in run
    testMethod()
  File "/home/u/Flame20/gaia/tests/python/gaia-ui-tests/gaiatest/tests/functional/camera/test_camera_multiple_shots.py", line 51, in test_capture_multiple_shots
    self.wait_for_condition(lambda m: len(self.data_layer.picture_files) == self.previous_number_of_pictures + 3, 10)
  File "/home/u/Flame20/gaia/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 881, in wait_for_condition
    Wait(self.marionette, timeout).until(method, message=message)
  File "/home/u/Flame20/virenv/gu/local/lib/python2.7/site-packages/marionette_client_mozilla_b2g32_v2_0-0.1-py2.7.egg/marionette/wait.py", line 143, in until
    cause=last_exc)
TEST-UNEXPECTED-FAIL | test_camera_multiple_shots.py test_camera_multiple_shots.TestCameraMultipleShots.test_capture_multiple_shots | TimeoutException: TimeoutException: Timed out after 10.1 seconds

----------------------------------------------------------------------
Ran 1 test in 54.124s

FAILED (errors=1)
TEST-START test_camera_capture_photo.py
test_capture_a_photo (test_camera_capture_photo.TestCamera)
https://moztrap.mozilla.org/manage/case/1325/ ... ok

----------------------------------------------------------------------
Ran 1 test in 40.597s

OK
TEST-START test_camera_flash_modes.py
test_camera_flash_modes (test_camera_flash_modes.TestCameraFlashModes) ... ok

----------------------------------------------------------------------
Ran 1 test in 47.042s

OK
TEST-START test_camera_capture_video.py
test_capture_a_video (test_camera_capture_video.TestCamera)
https://moztrap.mozilla.org/manage/case/2477/ ... ERROR

======================================================================
ERROR: None
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/u/Flame20/virenv/gu/local/lib/python2.7/site-packages/marionette_client_mozilla_b2g32_v2_0-0.1-py2.7.egg/marionette/marionette_test.py", line 170, in run
    testMethod()
  File "/home/u/Flame20/gaia/tests/python/gaia-ui-tests/gaiatest/tests/functional/camera/test_camera_capture_video.py", line 28, in test_capture_a_video
    self.camera.record_video(3)
  File "/home/u/Flame20/gaia/tests/python/gaia-ui-tests/gaiatest/apps/camera/app.py", line 63, in record_video
    self.wait_for_video_capturing()
  File "/home/u/Flame20/gaia/tests/python/gaia-ui-tests/gaiatest/apps/camera/app.py", line 120, in wait_for_video_capturing
    self.wait_for_condition(lambda m: self.marionette.find_element(
  File "/home/u/Flame20/gaia/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 54, in wait_for_condition
    Wait(self.marionette, timeout).until(method, message=message)
  File "/home/u/Flame20/virenv/gu/local/lib/python2.7/site-packages/marionette_client_mozilla_b2g32_v2_0-0.1-py2.7.egg/marionette/wait.py", line 143, in until
    cause=last_exc)
TEST-UNEXPECTED-FAIL | test_camera_capture_video.py test_camera_capture_video.TestCamera.test_capture_a_video | TimeoutException: TimeoutException: Timed out after 10.0 seconds

----------------------------------------------------------------------
Ran 1 test in 51.463s

FAILED (errors=1)

SUMMARY
-------
passed: 2
failed: 2
todo: 0

FAILED TESTS
-------
test_camera_multiple_shots.py test_camera_multiple_shots.TestCameraMultipleShots.test_capture_multiple_shots
test_camera_capture_video.py test_camera_capture_video.TestCamera.test_capture_a_video
Flags: needinfo?(ctang)

Comment 6

4 years ago
These ERRORs might relate to Bug 1066885.
After patch of Bug 1066885 lands on v2.0, the following camera test cases are fail.
 - test_camera_multiple_shots.py
 - test_camera_capture_video.py
 - test_camera_capture_photo.py

Two bugs were submitted.
1. Bug 1081473 [Flame][v2.0][Camera] Need to modify function - "tap_capture()" after patch of Bug 1066885 lands on v2.0  Sat 16:18
2. Bug 1081470 [Flame][v2.0][Camera] Need to modify function - "camera.tap_switch_source()" after patch of Bug 1066885 lands on v2.0
QA Whiteboard: [fxosqa-auto-backlog-]
QA Whiteboard: [fxosqa-auto-backlog-] → [fxosqa-auto-backlog-] [fxosqa-auto-dropped-s1]

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1081473
You need to log in before you can comment on or make changes to this bug.