All users were logged out of Bugzilla on October 13th, 2018

Difficulty selecting a cell in a nested table if the nested table is inserted in a joined cell.

VERIFIED DUPLICATE of bug 102249

Status

VERIFIED DUPLICATE of bug 102249
17 years ago
14 years ago

People

(Reporter: TucsonTester1, Assigned: mjudge)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.4)
Gecko/20011019 Netscape6/6.2
BuildID:    20011022

This problem occurs when you insert a table into the cell of another table, if
the cell you insert into is created by joining cells across multiple rows in the
original table.  When trying to select a cell in the upper half of the nested
table, you can click anywhere in a cell to select it.  When trying to select a
cell in the lower half of the nested table, the only way to select a cell using
the mouse is to place the mouse pointer at the left edge of the cell, at the
precise location the caret would appear when the cell is selected.  If the mouse
pointer is anywhere else in the cell, clicking on it will select a cell in the
original table, not the cell the mouse pointer is in.

Reproducible: Always
Steps to Reproduce:
1.Open a blank page in composer
2.Click on the table button and create a 2 x 2 table
3.While holding down the ctrl key, click once on each cell in the first column
so that they are both highlighted
4.Right click and select Join Selected Cells
5.Right click in the cell created by joining cells
6.Select Table Insert->Table
7.Create a table with 5 rows and 5 columns
8.Click in the different cells of the 5x5 table and observe where the caret appears.

Actual Results:  In the first 3 rows of the table, clicking anywhere in a cell
will put the caret in that cell.  In the 4th and 5th rows, if you place the
mouse pointer precisely where the caret should appaar (against left edge), the
caret will appear in the correct place.  If you click anywhere else in a cell in
the 4th or 5th row, the caret will appear in the second cell of the second column.

Expected Results:  I would expect to be able to click anywhere in any cell to
put the caret in the cell I am clicking on.  I would not expect to have to be
very precise in putting the mouse pointer in the exact spot that the caret
should appear in.

The problem seems to be the way the joined cell is being handled.  From trying
different sizes of tables, it appears that any cells that are at least partially
in the space that was originally part of row 1, those cells are working
normally.  Any cells that are fully in the space that was originally part of row
2, the cells are not working properly.  They are being treated like they are in
row 2 and clicking there is being treated like a click in row 2, so the caret is
being placed in the next cell in row 2.  Unless you click on the exact spot
where the caret should appear.

Left clicking and right clicking both have same problem.  The caret does move
correctly when using the tab key.  Once you do manage to get the caret into the
cell, entering content (text, image, etc.) works correctly.

Comment 1

17 years ago
Looks like a fundamental caret positioning bug
Assignee: syd → mjudge
Whiteboard: EDITORBASE
(Reporter)

Comment 2

17 years ago
I have seen some additional effects that appear to be caused by the same bug. 
If you enter two lines of text into the joined cell, instead of entering a
nested table, and then attempt to select the text by dragging the mouse through
it, the blank space in the cell at the end of the second line of text is being
treated like it is in a cell in the second row of the table.

Steps to reproduce:
1.Open a blank page in composer
2.Click on table, create a 2 x 2 table
3.Number the cells (top row 1,2 bottom row 3,4)
4.While holding down the cntrl key, click on 1 and 3
5.Right click and select join selected cells
6.Place the mouse pointer just to the left of the number 1
7.While holding down left mouse button, drag mouse through the number 3
8.Observe what gets highlighted

Actual results:  If you are careful to keep the mouse pointer within the space
occupied by the number 3, then just 1 and 3 are highlighted.  But if the pointer
is moved into the blank space after the 3, then the 2 also becomes highlighed,
just as if you had moved the mouse into a cell in the second row.  Basically,
the blank space in the joined cell is being treated as if the cell had not been
joined.

Expected results:  I would expect that anywhere you place the mousepointer
within the cell when selecting text, you would only select content within the cell.

Bug was originally filed using build 20011022, still present in build 2001110903

Comment 3

17 years ago
Looks like a dupe of 102249.

*** This bug has been marked as a duplicate of 102249 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.