Scrolling bookmarks changes their font

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: mayankleoboy1, Unassigned)

Tracking

({regression})

34 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox33 unaffected, firefox34+ wontfix, firefox35- wontfix, firefox36- wontfix, firefox37 wontfix, firefox38 wontfix, firefox38.0.5 wontfix, firefox39 affected, firefox40 affected, firefox41 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8500012 [details]
bookmarks-2014-10-04.json

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20141004030203

Steps to reproduce:

1. create a new profile
2. Import the attached bookmarks
3. Open the bookmarks menu
4. Scroll in the bookmark list


Actual results:

The font of the bookmarks changed


Expected results:

not so
(Reporter)

Comment 1

4 years ago
basically, if you have enough bookmarks to make them scroll, you should see this behaviour

Comment 2

4 years ago
Created attachment 8500044 [details]
screenshot

Bookmarks text rendered with grayscale anti-aliasing after scroll bookmarks menu and Bookmarks widget dropdowm.

Regression window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e620a9b140fa
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140730143007
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c1622eb8d6fc
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140730150925
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e620a9b140fa&tochange=c1622eb8d6fc



In local build
Last Good:  bb9d2f1e6619 + eed9b58c0ce3+c1622eb8d6fc
First Bad:  80a866643304 + eed9b58c0ce3+c1622eb8d6fc

Regressed by: 
	80a866643304	Robert O'Callahan — Bug 1041530. Be more careful about contributing opaque areas to the window region. r=mattwoodrow

Comment 3

4 years ago
[Tracking Requested - why for this release]: Fount rendering regression since 34
Blocks: 1041530
Status: UNCONFIRMED → NEW
status-firefox33: --- → unaffected
status-firefox34: --- → affected
status-firefox35: --- → affected
tracking-firefox34: --- → ?
tracking-firefox35: --- → ?
Ever confirmed: true
Keywords: regression

Updated

4 years ago
Version: Trunk → 34 Branch
tracking-firefox34: ? → +
tracking-firefox35: ? → +
Component: General → Layout: Text
Jet - Seems like a bit of an odd bug. Can you please have someone investigate? I'm interested in whether this behaviour will appear anywhere else in the product.
Flags: needinfo?(bugs)
I can't reproduce this bug. I also can't see how the patch applied to fix bug 1041530 would change font rendering.
Flags: needinfo?(bugs)
(In reply to Jet Villegas (:jet) from comment #5)
> I can't reproduce this bug. I also can't see how the patch applied to fix
> bug 1041530 would change font rendering.

IIUC, we switch between subpixel and grayscale antialiasing depending on whether we're rendering to an opaque background or not; and therefore bug 1041530 does seem to have the potential to change this behavior. I haven't tried to reproduce this on Windows, though, which is where it's most likely to be visible.
status-firefox36: --- → affected
tracking-firefox36: --- → ?
Given that we're at the end of the beta cycle, there hasn't been progress on this bug, and this bug doesn't seem critical enough to fix in 34 at this point in the cycle, I'm marking this as wontfix. I would like to see an investigation to at least understand the source of the issue soon. 

Jet - Where does this bug fit on your priority list? Do you have someone who can investigate while 35 is still on Aurora?
status-firefox34: affected → wontfix
Flags: needinfo?(bugs)
tracking-firefox36: ? → +
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #7)
> Jet - Where does this bug fit on your priority list? 
It's not very high on the list, considering the screenshot attached. Let me know if you see this looking worse elsewhere.

> Do you have someone who can investigate while 35 is still on Aurora?
We can bump up the priority if needed, but bug 1041530 is a fix we'll want to keep in the tree if this is the worst regression.
Flags: needinfo?(bugs)
Given Jet's update in comment 8 I'm removing tracking from this bug.
tracking-firefox35: + → -
tracking-firefox36: + → -
status-firefox37: --- → affected
status-firefox38: --- → affected
status-firefox38.0.5: --- → affected
status-firefox39: --- → affected
status-firefox40: --- → affected
status-firefox41: --- → affected
status-firefox35: affected → wontfix
status-firefox36: affected → wontfix
status-firefox37: affected → wontfix
status-firefox38: affected → wontfix
status-firefox38.0.5: affected → wontfix
(Reporter)

Comment 10

3 years ago
cant reproduce anymore.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.