Closed Bug 1077881 Opened 6 years ago Closed 6 years ago

[email] Remove hardcoded mozilla.com autoconfig entry from gaia

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(b2g-v2.2 fixed)

RESOLVED FIXED
2.1 S7 (24Oct)
Tracking Status
b2g-v2.2 --- fixed

People

(Reporter: asuth, Assigned: asuth)

Details

Attachments

(1 file)

The mozilla.com autoconfig entry in gaia was originally added as a latency thing and is an exact copy of the mozilla.com hosted ISPDB entry.  We've overhauled the autoconfig process to be much faster now (as of v2.1) so that reason for including it locally is no longer relevant.  Since the mozilla.com email server is going to transition soon, shipping it locally also limits transition possibilities.  Specifically, Mozilla IT can improve things by hosting an autoconfig server, but only if we lose the local entry.

Patch coming imminently (need bug number).
I propose not requesting uplift since the form is a hassle and by effectively compelling people onto v2.2 we can make sure that they're also getting any gmail enhancements we make (like addressing the delete/archive bug.)
Attachment #8500082 - Flags: review?(jrburke)
Comment on attachment 8500082 [details] [review]
no longer host the mozilla.com entry locally; we'll get it from the ISPDB instead.

Looks fine. As far as asking for uplift, it seems more of an issue of what release people are more likely to use when the email system changes. If the issue is that configuring mozilla.com will not work and 2.1 is the active release, then I would tend towards asking for uplift, just to avoid hassle about having to inform people of needing the manual config and communicating those prefs. Some messaging is likely either way though, in particular for accounts already configured.
Attachment #8500082 - Flags: review?(jrburke) → review+
landed in gaia/master:
https://github.com/mozilla-b2g/gaia/pull/24788
https://github.com/mozilla-b2g/gaia/commit/dedd8c658df4f83e19531098a74394a3bf9cd2ae

verification: if anyone wants to validate, you just make sure you can still create a mozilla.com account with a build with this fix via autoconfig.  The account in question must also be hosted on the Mozilla Zimbra server.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S7 (24Oct)
You need to log in before you can comment on or make changes to this bug.