offline storage permission setting not working correctly

RESOLVED DUPLICATE of bug 1334411

Status

()

RESOLVED DUPLICATE of bug 1334411
4 years ago
a year ago

People

(Reporter: WilliamWJimenes, Unassigned)

Tracking

(Blocks: 1 bug, {privacy})

36 Branch
privacy
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

(Whiteboard: [tor][fingerprinting])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8500115 [details]
preferences->advanced->network

I've noticed in multiple instances while editing my preferences that some websites are "allowed to store data for offline use" (the blacked-out box in attachment "preferences->advanced->network" is how I've noticed this is happening) ...

But my settings require that I am prompted before this can happen (see highlighted portions of attachments "preferences->advanced->network" and "about:permissions default permissions for all sites"), and I have never seen a prompt for offline storage.

I then checked the individual domain's permissions and noticed that the permission to "Maintain Offline Storage" is set to "Use Default", but to the right of that it shows the default as "Allow" (see highlighted portions of attachment "permissions for specific domain") ... this inconsistency is apparently what is allowing any domain to use offline storage without prompting the user.
(Reporter)

Comment 1

4 years ago
Created attachment 8500116 [details]
about:permissions default permissions for all sites
(Reporter)

Comment 2

4 years ago
Created attachment 8500117 [details]
permissions for specific domain

Comment 3

4 years ago
Mark, you recently worked on some permissions manager stuff, can you make sense of these prefs? I have to agree it's pretty confusing.
Component: Untriaged → Preferences
Flags: needinfo?(mhammond)
I've no insights here, but at face value, something sure looks either broken or terribly misleading.  The "Advanced" pane for me does have the "tell me when a website asks to store data for offline use" option, but site-specific permissions seem to imply the default for "Maintain Offline Storage" is allow.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(mhammond)
(Reporter)

Updated

4 years ago
Version: 32 Branch → 36 Branch

Comment 5

4 years ago
I can confirm this is happening exactly as described by William.

In addition, I went to the about:permissions page and set the "Maintain Offline Storage" option to "Block".  That had no effect.

I went to the target website, right-clicked, then "View Page Info" -> "Permissions" tab, and blocked it from there.  Still no effect.

Updated

a year ago
status-firefox57: --- → affected
Blocks: 1329996
Keywords: privacy
Whiteboard: [tor][fingerprinting]

Comment 6

a year ago
Don't know if this can be the same in Firefox 57, here's the steps to reproduce the problem:

1) Open www.youtube.com
2) Display the Info page window and select the "Permissions" panel.
3) Scroll to "Maintain Offline Storage" and change "Use default" to "Block".
4) Delete content already saved locally.
5) Reload the page.

Result: YouTube will continue to save local content.

Expected result: YouTube should not save any local content if I have explicitly denied to do so.
Yes, we're about to remove it (see also bug 1405742 and bug 1354500).
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1334411
You need to log in before you can comment on or make changes to this bug.