Calendar app fails to launch

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: viorela, Unassigned)

Tracking

({qablocker, regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
qablocker, regression, smoketest

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Trying to launch Calendar app is showing a black screen.

#STR:
Launch Calendar app
 
#Expected:
Calendar app is successfully launched

#Actual:
Calendar app is not launched, black screen is displayed instead

Repro frequency: 5 out of 5 times

Regresion range based on b2g-i:

Last working:
Device firmware (date) 	03 Oct 2014 13:06:26
Device firmware (incremental) 	eng.cltbld.20141003.160615
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	03 Oct 2014 12:22:21
Gaia revision 	2eb25dc8e599
Gecko build 	20141003133253
Gecko revision 	0aa4a97aa8f3
Gecko version 	35.0a1

First failing:
Device firmware (date) 	03 Oct 2014 16:11:27
Device firmware (incremental) 	eng.cltbld.20141003.191111
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	03 Oct 2014 14:42:07
Gaia revision 	56d949e8d1c6
Gecko build 	20141003150730
Gecko revision 	6598d0d66427
Gecko version 	35.0a1

Gaia diff:
https://github.com/mozilla-b2g/gaia/compare/2eb25dc8e599...56d949e8d1c6

Gecko diff:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=0aa4a97aa8f3&tochange=6598d0d66427

This is causing test_calendar_new_event_appears_on_all_calendar_views.py to fail:  http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.b2g-inbound.ui.functional.smoke/374/HTML_Report/
(Reporter)

Comment 1

4 years ago
Created attachment 8500405 [details]
logcat
Nominating for blocking - functional regression that blocks use.
blocking-b2g: --- → 2.2?
(In reply to Marcia Knous [:marcia - use needinfo] from comment #2)
> Nominating for blocking - functional regression that blocks use.

Sorry, forgot to add this is seen in the latest Flame user builds:

Gaia   470826d13ae130a5c3d572d1029e595105485fb0
SourceStamp e0d714f43edc
BuildID 20141006040204
Version 35.0a1
base: v184
(Reporter)

Comment 4

4 years ago
We found the bug that must have broke Calendar app and we asked for a back out in https://bugzilla.mozilla.org/show_bug.cgi?id=1027707#c14
Hope Calendar app will work as expected due to the back out.
(Reporter)

Comment 5

4 years ago
The back out didn't help, we still need to find the cause of this.
Gareth, Miller, can you investigate?  this blocks trunk smoketests.

Thanks,
Tony
Flags: needinfo?(mmedeiros)
Flags: needinfo?(gaye)
Keywords: qablocker, smoketest
Requesting a window to see if we can find some additional information to help.
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
Keywords: qaurgent, regression, regressionwindow-wanted
QA Contact: jmercado
Bug 1027707 seems to be the cause for this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141003133253
Gaia: 2eb25dc8e5999de4d1ee32cf7d5131e25ca360fe
Gecko: 0aa4a97aa8f3
Version: 35.0a1 (2.2) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141003150730
Gaia: 56d949e8d1c66abb5ee2a0188eac6c0974417212
Gecko: 6598d0d66427
Version: 35.0a1 (2.2) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: 2eb25dc8e5999de4d1ee32cf7d5131e25ca360fe
Gecko: 6598d0d66427

First Broken gaia / Last Working gekko - Issue DOES occur
Gaia: 56d949e8d1c66abb5ee2a0188eac6c0974417212
Gecko: 0aa4a97aa8f3

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/2eb25dc8e5999de4d1ee32cf7d5131e25ca360fe...56d949e8d1c66abb5ee2a0188eac6c0974417212
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qaurgent, regressionwindow-wanted
Bug 1027707 seems to be the cause for this issue - patch author Gareth already has a NI on him.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
This should be working now on latest master.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(mmedeiros)
Flags: needinfo?(gaye)
Resolution: --- → FIXED
QAWanted to verify by pulling latest gaia.
Keywords: qaurgent, qawanted, verifyme
This issue does NOT occur in the latest 2.2 Flame KK build.

Results: The Email app opens as expected

Environmental Variables:
Device: Flame 2.2
BuildID: 20141006132816
Gaia: 83de447d9ae9a59459d7a445f9348a254c661850
Gecko: 435515999f39
Version: 35.0a1 (2.2) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qaurgent, qawanted, verifyme
Status: RESOLVED → VERIFIED
status-b2g-v2.2: affected → verified
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
(In reply to Jayme Mercado [:JMercado] from comment #12)
> This issue does NOT occur in the latest 2.2 Flame KK build.
> 
> Results: The Email app opens as expected

Jayme, did you mean *Calendar* app?
Flags: needinfo?(jmercado)
Dylan, Yes I meant the Calendar app.
Flags: needinfo?(jmercado)
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.