Closed Bug 1078261 Opened 5 years ago Closed 5 years ago

Authentication error in the Loop panel on 1:1 calls

Categories

(Hello (Loop) :: Client, defect)

defect
Not set
Points:
2

Tracking

(firefox34 verified, firefox35 verified)

VERIFIED FIXED
mozilla35
Iteration:
35.3
Tracking Status
firefox34 --- verified
firefox35 --- verified

People

(Reporter: pauly, Assigned: MattN)

References

Details

(Keywords: regression, Whiteboard: [loop-uplift])

Attachments

(2 files)

STR:
1. Start a call between 2 FF profiles
2. Open the Loop panel on the callee side

Actual results:
authentication error

Last good revision: b85c260821ab (2014-10-03)
First bad revision: 229801d17f7e (2014-10-04)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b85c260821ab&tochange=229801d17f7e
Last good revision: 60e90dd7f64f
First bad revision: 7a45d556f280
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=60e90dd7f64f&tochange=7a45d556f280
Probably from bug 1047164
Blocks: 1047164
Probably worth nothing that at least for me this happened without being logged in to any FireFox Account. So the red icon is probably correct/expected if the user is using an FF Account. But if no account is being used, this error message should be suppressed.
FYI: This isn't happening to me.  I started out not logged in (no red bubble) and then logged in with no problems (no red bubble).  NOTE: I had logged in prior to today, and Nils had not.  To repro, you may need to use a fresh profile -- or not have logged into FxA before.
Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Iteration: --- → 35.3
Points: --- → 3
Flags: qe-verify+
Flags: firefox-backlog+
We were trying to fetch FxA call data even if we aren't logged in.
Attachment #8500697 - Flags: review?(pkerr)
Attachment #8500697 - Flags: review?(pkerr) → review+
Thanks.

https://hg.mozilla.org/integration/fx-team/rev/805fa09191ab
OS: Windows 7 → All
Hardware: x86_64 → All
Whiteboard: [fixed-in-fx-team]
Comment on attachment 8500697 [details] [diff] [review]
v.1 Don't fetch Loop call data for the FxA session if we aren't logged in

Approval Request Comment
[Feature/regressing bug #]: bug 1047164 and bug 1065155
[User impact if declined]: Once bug 1047164 gets uplifted users would see an authentication error bar upon receiving a call as a guest.
[Describe test coverage new/current, TBPL]: xpcshell test and manual test by me. The problem was obvious and has a simple fix.
[Risks and why]: Low risk straightforward fix.
[String/UUID change made/needed]: None.
Attachment #8500697 - Flags: approval-mozilla-aurora?
FYI:  This will be part of the second uplift to Aurora that I am planning for this Thursday.  

For Sheriffs or anyone doing Aurora uplifts -- Please ping me (mreavy on irc) before doing any Loop bug uplifts to Aurora.  Thanks.
https://hg.mozilla.org/mozilla-central/rev/805fa09191ab
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla35
Whiteboard: [loop-uplift]
(In reply to Carsten Book [:Tomcat] from comment #9)
> https://hg.mozilla.org/mozilla-central/rev/805fa09191ab

Paul, please verify this is fixed in tomorrow's Nightly.
Flags: needinfo?(paul.silaghi)
QA Contact: anthony.s.hughes → paul.silaghi
Verified fixed 35.0a1 (2014-10-08) Win 7, Ubuntu 13.04, OS X 10.9.5
Status: RESOLVED → VERIFIED
Flags: needinfo?(paul.silaghi)
Flags: needinfo?(paul.silaghi)
Verified fixed FF 34b1 OS X 10.9.5, Win 7
Flags: needinfo?(paul.silaghi)
Comment on attachment 8500697 [details] [diff] [review]
v.1 Don't fetch Loop call data for the FxA session if we aren't logged in

Post landed approval (already landed)
Attachment #8500697 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Does this regression have Engineering test coverage?
Flags: in-testsuite?
Clearing in-testsuite requests for features that are being removed from Hello as part of te user journey work in bug 1209713.
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.