Open Bug 1078286 Opened 7 years ago Updated 6 years ago

Lenovo X1 carbon 34xx default camera driver not working with WebRTC video

Categories

(Core :: WebRTC, defect)

x86_64
Windows 8
defect
Not set
normal

Tracking

()

REOPENED
Blocking Flags:
backlog parking-lot

People

(Reporter: RT, Unassigned)

References

Details

Steps to reproduce:
1 Generate call-back URL
2 Click call-back URL on computer used to generate the URL
3 Click to initiate the call on the standalone link clicker UI
4 Accept the incoming call on the Loop client
5 Accept gUM dialog on the standalone link clicker UI
6 PC crash - blue screen with BAD_POOL_CALLER error

This happens on windows 8 Lenovo X1 carbon
I've been able to reproduce 3 times.
This is most likely to be a core issue, lets start with WebRTC to begin with.

Also, which version(s) of Firefox have you tested this on?
Component: Client → WebRTC
Product: Loop → Core
QA Contact: anthony.s.hughes
Today's nightly
RT -- This sounds like a problem in your graphics drivers or web cam drivers.   Do you get a crash when you do an audio only call?   Do you get a crash when you open the gUM test?  Also, are you using the same browser or two separate browsers on the same machine?
Flags: needinfo?(rtestard)
(In reply to Mark Banner (:standard8) from comment #1)
> This is most likely to be a core issue, lets start with WebRTC to begin with.
> 
> Also, which version(s) of Firefox have you tested this on?

Nothing the browser does should be able to blue-screen you, so it's a driver problem of some sort.
Thanks both.
I updated the driver of the camera and I don't seem able to reproduce the issue.
Closing this now.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Flags: needinfo?(rtestard)
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
I am re-opening this bug since I re-installed my computer from scratch and the Lenovo driver still has not been updated. This is a fairly mainstream laptop (Lenovo X1 carbon 34xx) and a lot of users may be affected.
Driver details: http://support.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-x-series-laptops/thinkpad-x1-carbon-type-34xx/downloads/DS032187

The user experience is a blank screen on Firefox and a computer crash on Chrome.
I wonder if this is an issue with Firefox having to support this driver or an issue that has to be addressed by webrtc.org directly?
Flags: needinfo?(mreavy)
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---
The only organization who can do something about this is Lenovo, by pushing out the camera driver to everyone (perhaps by getting it WHQL certified so Microsoft will push it).  Contorting things in the hope of avoiding this (fixed-in-newer-driver) bug is path that leads to madness. If there was a simple known workaround that didn't impact other things (nulling out some data before making a call), maybe, but we have no idea of what to even look at.

You can also report it to Chrome.  Likely they'll say the same thing.  (Note Chrome uses slightly different capture code than we do - we use the code from webrtc.org; they use something specific to Chrome).
Can we not blacklist the driver ? It appears we can make _some_ call into webrtc.org webcam code (since we're displaying a list of devices), we might be able to get a device driver identifier before it blows up?
Tricky, since we'd also have to identify the version of driver as well.  And very few devices blue screen you (and users tend to update).  We could file a bug for adding a blacklist feature, and see how feasible it is.  This would be very platform-specific (read windows-specific really) code.
I believe the best path forward is to turn this bug into an evangelism bug.  We (Mozilla) should reach out to Lenovo and explain the lousy experience that both Firefox and Chrome users are currently having with the old driver.  Lenovo should have a patch for this as part of Windows update such that if a user reinstalls from scratch as RT did, Windows Update will update the Lenovo driver.  

Any other path would mean our spending many man hours to blacklist, test, and roll out an update that still would result in a lousy user experience (i.e. users with this old driver still can't use Firefox).  We should also put this in our release notes -- I'll be sure to add this at the top of our Fx40 release notes wiki page as a known Lenovo driver bug that affects both Firefox and Chrome.
Flags: needinfo?(mreavy)
Thanks. What I meant by "black screen" was that the area where my camera should be rendered is displayed as a black box - there is no stability issue on Firefox (Chrome although makes my computer crash as I accept gUM).
So as far as Firefox is concerned, if there is no way to get the camera to actually work then what's in place currently seems OK indeed.
Updating the title so it reflects the issue.
Also for completeness Skype and Vidyo both work fine which may mean that the issue could be fixed be defaulting to H264?
Summary: Computer crash as you accept gUM in Loop calls to yourself → Lenovo X1 carbon 34xx default camera driver not working with WebRTC video
(In reply to Romain Testard [:RT] from comment #12)
> Updating the title so it reflects the issue.
> Also for completeness Skype and Vidyo both work fine which may mean that the
> issue could be fixed be defaulting to H264?

Cameras working has nothing to do with codecs.

BTW you should also test with a simpler version: https://mozilla.github.io/webrtc-landing/gum_test.html
That should show the same thing.  (Note: firefox only; you can test Chrome using other getusermedia demos or apprtc)
backlog: --- → parking-lot
You need to log in before you can comment on or make changes to this bug.