crash in NPE: Attempt to invoke virtual method ''int org.mozilla.gecko.db.LocalBrowserDB.getCount(android.content.ContentResolver, java.lang.String)'' on a null object reference at org.mozilla.gecko.db.BrowserDB.getCount(BrowserDB.java)

RESOLVED DUPLICATE of bug 1077858

Status

()

Firefox for Android
Data Providers
--
critical
RESOLVED DUPLICATE of bug 1077858
3 years ago
3 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

({crash, reproducible})

35 Branch
All
Android
crash, reproducible
Points:
---

Firefox Tracking Flags

(firefox35 affected, fennec35+)

Details

(crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-f2b19f2f-33a9-4a03-8431-dce322141005.
=============================================================

java.lang.NullPointerException: Attempt to invoke virtual method 'int org.mozilla.gecko.db.LocalBrowserDB.getCount(android.content.ContentResolver, java.lang.String)' on a null object reference
	at org.mozilla.gecko.db.BrowserDB.getCount(BrowserDB.java:236)
	at org.mozilla.gecko.BrowserApp.handleMessage(BrowserApp.java:1481)
	at org.mozilla.gecko.EventDispatcher.dispatchEvent(EventDispatcher.java:168)
	at org.mozilla.gecko.GeckoAppShell.handleGeckoMessage(GeckoAppShell.java:2348)
	at org.mozilla.gecko.mozglue.GeckoLoader.nativeRun(Native Method)
	at org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:369)
	at org.mozilla.gecko.GeckoThread.run(GeckoThread.java:190)
(Reporter)

Comment 1

3 years ago
I hit this again today on startup; slightly different stack

java.lang.NullPointerException
	at org.mozilla.gecko.db.BrowserDB.getCount(BrowserDB.java:237)
	at org.mozilla.gecko.BrowserApp.handleMessage(BrowserApp.java:1514)
	at org.mozilla.gecko.EventDispatcher.dispatchEvent(EventDispatcher.java:168)
	at org.mozilla.gecko.GeckoAppShell.handleGeckoMessage(GeckoAppShell.java:2348)
	at org.mozilla.gecko.mozglue.GeckoLoader.nativeRun(Native Method)
	at org.mozilla.gecko.mozglue.GeckoLoader.nativeRun(Native Method)
	at org.mozilla.gecko.mozglue.GeckoLoader.nativeRun(Native Method)
	at org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:369)
	at org.mozilla.gecko.GeckoThread.run(GeckoThread.java:190)

bp-5295e2de-04b9-4497-bcb4-a35b72141010
(Reporter)

Updated

3 years ago
Crash Signature: [@ java.lang.NullPointerException: Attempt to invoke virtual method ''int org.mozilla.gecko.db.LocalBrowserDB.getCount(android.content.ContentResolver, java.lang.String)'' on a null object reference at org.mozilla.gecko.db.BrowserDB.getCount(Browse… → [@ java.lang.NullPointerException: Attempt to invoke virtual method ''int org.mozilla.gecko.db.LocalBrowserDB.getCount(android.content.ContentResolver, java.lang.String)'' on a null object reference at org.mozilla.gecko.db.BrowserDB.getCount(Browse…
(Reporter)

Comment 2

3 years ago
[Tracking Requested - why for this release]:

I'm also hitting this while idle on today's Nightly (10/08).
tracking-fennec: --- → ?
status-firefox35: --- → affected
(Reporter)

Comment 3

3 years ago
STR: new profile, launch Nightly, check back for a crash in a minute or two

10-10 11:24:40.228 D/GeckoHealthRec(26504): Finishing init.
10-10 11:24:40.238 D/GeckoHealthRec(26504): Checking for orphan session.
10-10 11:24:44.548 D/GeckoHardwareUtils(26504): HardwareUtils already inited.
10-10 11:26:39.558 I/GeckoWebappsUpdateTimer(26504): periodic check for webapp updates
10-10 11:26:39.558 D/GeckoWebappManager(26504): checkForUpdates
10-10 11:26:39.558 D/GeckoWebapps(26504): getAll
10-10 11:27:40.168 E/GeckoAppShell(26504): >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 1222 ("Gecko")
10-10 11:27:40.168 E/GeckoAppShell(26504): java.lang.NullPointerException
10-10 11:27:40.168 E/GeckoAppShell(26504): 	at org.mozilla.gecko.db.BrowserDB.getCount(BrowserDB.java:237)
(Reporter)

Updated

3 years ago
Keywords: reproducible
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1077858
tracking-fennec: ? → 35+
kevin, why is this tracking 35?

Updated

3 years ago
Flags: needinfo?(kbrosnan)
Because that is what we do with dupes that are regressions.
Flags: needinfo?(kbrosnan)
You need to log in before you can comment on or make changes to this bug.