assertion while entering bug report

VERIFIED DUPLICATE of bug 10456

Status

()

Toolkit
Form Manager
P3
normal
VERIFIED DUPLICATE of bug 10456
19 years ago
11 months ago

People

(Reporter: ppandit, Assigned: Stephen P. Morse)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
using debug build (7/29/99)
bug is being reported under Autofill because I do not see a menu item for
wallet.

1) start apprunner
2) go to bugzilla
3) enter all the info for a bug report
4) press submit
5) wallet dialog comes up - asks if I want to save values for this form
6) I click CANCEL checkbox then okay
7) get the following assertion

NTDLL! DbgBreakPoint@0 address 0x77f76148
nsDebug::Break(const char * 0x0a330cf0, int 166) line 143
nsDebug::Error(const char * 0x0a330d28, const char * 0x0a330cf0, int 166) line
204 + 13 bytes
nsHTTPChannel::OpenInputStream(nsHTTPChannel * const 0x0aca9dd0, unsigned int 0,
int -1, nsIInputStream * * 0x0012e0e0) line 166 + 21 bytes
wallet_FetchFromNetCenter(char * 0x099138e4, char * 0x099138d4) line 1343 + 20
bytes
wallet_FetchFieldSchemaFromNetCenter() line 1393 + 15 bytes
wallet_Initialize() line 1627
wallet_Capture(nsIDocument * 0x0aa3a1d0, nsString {...}, nsString {...},
nsString {...}) line 1993
WLLT_OnSubmit(nsIContent * 0x0aa59900) line 2612 + 63 bytes
nsWalletlibService::Notify(nsWalletlibService * const 0x00b32628, nsIContent *
0x0aa59900) line 182 + 9 bytes
nsFormFrame::OnSubmit(nsFormFrame * const 0x09dde8a8, nsIPresContext *
0x0aa395e0, nsIFrame * 0x0a3154e0) line 455
nsButtonControlFrame::MouseClicked(nsIPresContext * 0x0aa395e0) line 362
nsFormControlFrame::HandleEvent(nsFormControlFrame * const 0x0a3154e0,
nsIPresContext & {...}, nsGUIEvent * 0x0012f86c, nsEventStatus &
nsEventStatus_eConsumeDoDefault) line 597
nsButtonControlFrame::HandleEvent(nsButtonControlFrame * const 0x0a3154e0,
nsIPresContext & {...}, nsGUIEvent * 0x0012f86c, nsEventStatus &
nsEventStatus_eConsumeDoDefault) line 587
nsEventStateManager::CheckForAndDispatchClick(nsEventStateManager * const
0x0aac20d0, nsIPresContext & {...}, nsMouseEvent * 0x0012fb9c, nsEventStatus &
nsEventStatus_eConsumeDoDefault) line 740 + 30 bytes
nsEventStateManager::PostHandleEvent(nsEventStateManager * const 0x0aac20d0,
nsIPresContext & {...}, nsGUIEvent * 0x0012fb9c, nsIFrame * 0x0a3154e0,
nsEventStatus & nsEventStatus_eConsumeDoDefault, nsIView * 0x0aa50090) line 261
+ 24 bytes
PresShell::HandleEvent(PresShell * const 0x0aa4b9a4, nsIView * 0x0aa50090,
nsGUIEvent * 0x0012fb9c, nsEventStatus & nsEventStatus_eConsumeDoDefault) line
2263 + 43 bytes
nsView::HandleEvent(nsView * const 0x0aa50090, nsGUIEvent * 0x0012fb9c, unsigned
int 8, nsEventStatus & nsEventStatus_eConsumeDoDefault, int & 0) line 834
nsView::HandleEvent(nsView * const 0x0aa4d420, nsGUIEvent * 0x0012fb9c, unsigned
int 8, nsEventStatus & nsEventStatus_eConsumeDoDefault, int & 0) line 819
nsView::HandleEvent(nsView * const 0x0aa4d4b0, nsGUIEvent * 0x0012fb9c, unsigned
int 8, nsEventStatus & nsEventStatus_eConsumeDoDefault, int & 0) line 819
nsView::HandleEvent(nsView * const 0x0aa4bda0, nsGUIEvent * 0x0012fb9c, unsigned
int 28, nsEventStatus & nsEventStatus_eConsumeDoDefault, int & 0) line 819
nsViewManager::DispatchEvent(nsViewManager * const 0x0aa4bf70, nsGUIEvent *
0x0012fb9c, nsEventStatus & nsEventStatus_eConsumeDoDefault) line 1736
HandleEvent(nsGUIEvent * 0x0012fb9c) line 67
nsWindow::DispatchEvent(nsWindow * const 0x0aa4d2e4, nsGUIEvent * 0x0012fb9c,
nsEventStatus & nsEventStatus_eIgnore) line 490 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012fb9c) line 515
nsWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000) line 3257 +
15 bytes
ChildWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000) line
3430
nsWindow::ProcessMessage(unsigned int 514, unsigned int 0, long 38404239, long *
0x0012fdd0) line 2525 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x005f0218, unsigned int 514, unsigned int 0, long
38404239) line 563 + 27 bytes
USER32! DispatchMessageWorker@8 + 135 bytes
USER32! DispatchMessageA@4 + 11 bytes
nsAppShell::Run() line 70
nsAppShellService::Run(nsAppShellService * const 0x00ae7030) line 466
main1(int 1, char * * 0x00a419c0) line 744 + 12 bytes
main(int 1, char * * 0x00a419c0) line 812 + 13 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! BaseProcessStart@4 + 64 bytes
(Reporter)

Updated

19 years ago
Summary: assertion while entering bug report
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 1

19 years ago
*** This bug has been marked as a duplicate of 10456 ***
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 2

19 years ago
VERIFIED as DUPLICATE

Updated

10 years ago
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: paulmac → form.manager
You need to log in before you can comment on or make changes to this bug.