Firefox 31.0 and later ignore CSS font assignment for MathML tags containing a single character

RESOLVED INVALID

Status

()

Core
MathML
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Bruce Augustine, Unassigned)

Tracking

31 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8500654 [details]
Testcase displays muliple and single character MathML tags showing the font-family assignment failure

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.124 Safari/537.36

Steps to reproduce:

Create a series of MathML tags, some of which contain multiple characters, and some of which contain a single character.  Using CSS, assign a san-serif font-family to all tags on the page

Verify that elements have proper font assigned, both visually and using Firebug or Web Developer Tools


Actual results:

Multiple character tags are properly rendered using the correct sans-serif font.  Single character tags are rendered using a default serif font.

Firebug indicates that the assigned CSS font is being applied.


Expected results:

Both multiple and single character tags should be rendered using the assigned CSS font.
No more inbounds to bisect
Last good revision: 3c090ccefb70
First bad revision: 58c5a3427997
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=3c090c
cefb70&tochange=58c5a3427997
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout: Text
Ever confirmed: true
Product: Firefox → Core
Can you bisect on m-c?  Some of the changesets in there seem to have come from an m-c merge..
Last good revision: e4843f4f08a7 (2014-05-15)
First bad revision: 58c5a3427997 (2014-05-16)

Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e4843f4f08a7&tochange=58c5a3427997
Hmm.  I guess maybe there are just no in-between builds there....

Jonathan, you have some text-related changes in there?
Flags: needinfo?(jfkthame)
maybe :
Frédéric Wang — Bug 930504 - When possible, use character substitution for basic mathvariants. r=karlt

I'm doing a local bisecting at the moment
Flags: needinfo?(jfkthame) → needinfo?(fred.wang)
This is specified and intended behavior for <mi>.

http://www.w3.org/TR/MathML3/chapter3.html#presm.mi

  mathvariant

  Specifies the logical class of the token. The default is "normal" (non-slanted)
  unless the content is a single character, in which case it would be "italic". 

http://www.w3.org/TR/MathML3/chapter3.html#presm.commatt

  In particular, the mathvariant attribute does not follow the CSS inheritance
  model;

  A token element that uses the unstyled character in combination with the
  corresponding mathvariant value is equivalent to a token element that uses
  the mathematical alphanumeric symbol character without the mathvariant
  attribute. Note that the appearance of a mathematical alphanumeric symbol
  character should not be altered by surrounding mathvariant or other style
  declarations."
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Component: Layout: Text → MathML
Resolution: --- → INVALID
Flags: needinfo?(fred.wang)
You need to log in before you can comment on or make changes to this bug.