Closed Bug 1078916 Opened 7 years ago Closed 7 years ago

Write a Mercurial extension to siphon pushed bundles into S3

Categories

(Developer Services :: Mercurial: hg.mozilla.org, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1055298

People

(Reporter: gps, Assigned: glandium)

References

(Blocks 1 open bug)

Details

(Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1332] )

As part of headless try we're going to create a Mercurial extension that siphons pushed data into S3. The goal is for vanilla Mercurial clients to `hg push` like normal and the server will take the uploaded bundle data and store it in S3 instead of applying it on the server-side repository.

glandium has experiments validating this approach.
For the record, the patch attached to bug 1055298 is one of the first attempts at that.
Whiteboard: [kanban:engops:https://kanbanize.com/ctrl_board/6/88]
Whiteboard: [kanban:engops:https://kanbanize.com/ctrl_board/6/88] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1321] [kanban:engops:https://kanbanize.com/ctrl_board/6/88]
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1321] [kanban:engops:https://kanbanize.com/ctrl_board/6/88] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1326] [kanban:engops:https://kanbanize.com/ctrl_board/6/88]
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1326] [kanban:engops:https://kanbanize.com/ctrl_board/6/88] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1327] [kanban:engops:https://kanbanize.com/ctrl_board/6/88]
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1327] [kanban:engops:https://kanbanize.com/ctrl_board/6/88] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1332] [kanban:engops:https://kanbanize.com/ctrl_board/6/88]
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1332] [kanban:engops:https://kanbanize.com/ctrl_board/6/88] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1332]
Duplicate of this bug: 1078918
Let's just use the main bug to track this.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1055298
You need to log in before you can comment on or make changes to this bug.