Closed Bug 1079233 Opened 5 years ago Closed 2 years ago

Intermittent test_export_contacts_to_sdcard.py TestExportContactsToSDCard.test_export_contacts_to_sdcard | ElementNotVisibleException: ElementNotVisibleException: Element is not currently visible and may not be manipulated

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: RyanVM, Assigned: viorela)

Details

(Keywords: intermittent-failure)

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=302510&repo=mozilla-aurora

builder 	b2g_ubuntu64_vm mozilla-aurora opt test gaia-ui-test
buildid 	20141007000203
builduid 	d998b9f397bb4577b15ea08225901b3e
results 	warnings (1)
revision 	b9d04c58580a
slave 		tst-linux64-spot-939
starttime 	Tue Oct 07 2014 04:28:18 GMT-0400 (Eastern Standard Time)

02:06:08 INFO - TEST-START | test_export_contacts_to_sdcard.py TestExportContactsToSDCard.test_export_contacts_to_sdcard
02:06:36 ERROR - TEST-UNEXPECTED-ERROR | test_export_contacts_to_sdcard.py TestExportContactsToSDCard.test_export_contacts_to_sdcard | ElementNotVisibleException: ElementNotVisibleException: Element is not currently visible and may not be manipulated
02:06:36 INFO - Traceback (most recent call last):
02:06:36 INFO - File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette/marionette_test.py", line 174, in run
02:06:36 INFO - testMethod()
02:06:36 INFO - File "/builds/slave/test/gaia/tests/python/gaia-ui-tests/gaiatest/tests/functional/contacts/test_export_contacts_to_sdcard.py", line 30, in test_export_contacts_to_sdcard
02:06:36 INFO - contacts_app.tap_select_all()
02:06:36 INFO - File "/builds/slave/test/gaia/tests/python/gaia-ui-tests/gaiatest/apps/contacts/app.py", line 77, in tap_select_all
02:06:36 INFO - self.marionette.find_element(*self._select_all_button_locator).tap()
02:06:36 INFO - File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette/marionette.py", line 90, in tap
02:06:36 INFO - return self.marionette._send_message('singleTap', 'ok', id=self.id, x=x, y=y)
02:06:36 INFO - File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette/decorators.py", line 35, in _
02:06:36 INFO - return func(*args, **kwargs)
02:06:36 INFO - File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette/marionette.py", line 638, in _send_message
02:06:36 INFO - self._handle_error(response)
02:06:36 INFO - File "/builds/slave/test/build/venv/local/lib/python2.7/site-packages/marionette/marionette.py", line 678, in _handle_error
02:06:36 INFO - raise errors.ElementNotVisibleException(message=message, status=status, stacktrace=stacktrace)
02:06:36 INFO - TEST-INFO took 27634ms
QA Whiteboard: [fxosqa-auto-backlog+]
Assignee: nobody → viorela.ioia
QA Whiteboard: [fxosqa-auto-backlog+] → [fxosqa-auto-backlog+][fxosqa-auto-s5]
I haven't seen  test_export_contacts_to_sdcard.py failing on desktopb2g lately.
I also ran the test locally several times, and I wasn't able to reproduce the failure:

TEST-START | test_export_contacts_to_sdcard.py TestExportContactsToSDCard.test_export_contacts_to_sdcard
TEST-PASS | test_export_contacts_to_sdcard.py TestExportContactsToSDCard.test_export_contacts_to_sdcard | took 21190ms

SUMMARY
-------
passed: 51
failed: 0
todo: 0

I will close the bug, as the issue is not reproducible anymore.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Clearing the backlog tag since the issue has been assigned (and is now resolved)
QA Whiteboard: [fxosqa-auto-backlog+][fxosqa-auto-s5] → [fxosqa-auto-s5]
If we check last 'Treeherder' jobs, 90% of them are showing a failure in this test again[1]. Reopening as some other bugs has been reverted due to this intermittent failure.

[1] https://treeherder.mozilla.org/#/jobs?repo=gaia
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(In reply to Borja Salguero [:borjasalguero] from comment #5)
> If we check last 'Treeherder' jobs, 90% of them are showing a failure in
> this test again[1]. Reopening as some other bugs has been reverted due to
> this intermittent failure.
> 
> [1] https://treeherder.mozilla.org/#/jobs?repo=gaia

I've looked at the log of the last Treeherder failure, but it's a completely different failure than what this bug was originally about:
TEST-UNEXPECTED-ERROR | test_export_contacts_to_sdcard.py TestExportContactsToSDCard.test_export_contacts_to_sdcard | TimeoutException: TimeoutException: Timed out after 10.1 seconds


Traceback (most recent call last):
  File "/home/tester/git_checkout/ci_venv/local/lib/python2.7/site-packages/marionette_client-0.13-py2.7.egg/marionette/marionette_test.py", line 296, in run
    testMethod()
  File "/home/tester/git_checkout/tests/python/gaia-ui-tests/gaiatest/tests/functional/contacts/test_export_contacts_to_sdcard.py", line 33, in test_export_contacts_to_sdcard
    self.assertIn('1/1 contacts exported', contacts_app.status_message)
  File "/home/tester/git_checkout/tests/python/gaia-ui-tests/gaiatest/apps/contacts/app.py", line 110, in status_message
    Wait(self.marionette).until(expected.element_displayed(status))
  File "/home/tester/git_checkout/ci_venv/local/lib/python2.7/site-packages/marionette_driver-0.7-py2.7.egg/marionette_driver/wait.py", line 143, in until
    cause=last_exc)

I think it's better to file a new bug for this intermittent failure.
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Closed: 5 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.