Closed Bug 1079251 Opened 5 years ago Closed 5 years ago

Fix ConvertOmxYUVFormatToRGB565() does not care about gralloc buffer height in HAL_PIXEL_FORMAT_YV12 case

Categories

(Core :: Graphics: Layers, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

()

RESOLVED FIXED
mozilla35
blocking-b2g 2.0M+
Tracking Status
firefox33 --- wontfix
firefox34 --- wontfix
firefox35 --- fixed
b2g-v2.0 --- affected
b2g-v2.0M --- fixed
b2g-v2.1 --- fixed
b2g-v2.2 --- fixed

People

(Reporter: sotaro, Assigned: sotaro)

References

Details

(Keywords: verifyme)

Attachments

(2 files, 1 obsolete file)

ConvertOmxYUVFormatToRGB565() does not care about gralloc buffer height. Therefore, if gralloc buffer size and valid size is different, it failed to to convert color correctly.
Attached patch temporary patch (obsolete) — Splinter Review
This seems to fix the problem.
The change of attachment 8501056 [details] [diff] [review] is going to be handled as part of bug 1075077.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1075077
It seems better to handle this bug as separate from Bug 1075077.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Attachment #8501056 - Attachment is obsolete: true
Attachment #8501803 - Flags: review?(nical.bugzilla)
nical, can you review the patch soon?
Flags: needinfo?(nical.bugzilla)
Assignee: nobody → sotaro.ikeda.g
Attachment #8501803 - Flags: review?(nical.bugzilla) → review+
Flags: needinfo?(nical.bugzilla)
Nominate to b2g-v2.0M+. This bug blocks b2g-v2.0M+ bug.
blocking-b2g: --- → 2.0M?
Hi Sotaro,
Thanks for the nomination, I make it a 2.0M+
blocking-b2g: 2.0M? → 2.0M+
https://hg.mozilla.org/mozilla-central/rev/e36449d3325c
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Duplicate of this bug: 1068502
Hi Norry,
qawanted for Woodduck 2.0M. Thanks!
Flags: needinfo?(fan.luo)
Keywords: verifyme
Hi  Josh,
  No steps to reproduce,please add.
Flags: needinfo?(fan.luo)
Does this need to land on v2.1 as well? Please nominate it if so :)
Flags: needinfo?(sotaro.ikeda.g)
A patch for b2g v2.1. Carry "r=nical".
Flags: needinfo?(sotaro.ikeda.g)
Attachment #8509458 - Flags: review+
Comment on attachment 8509458 [details] [diff] [review]
patch for b2gv2.1 - fix CbCr buffer address

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): none
User impact if declined: Some hardware's video thumbnail's color becomes incorrect.
Testing completed: locally tested. 
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: none.
Attachment #8509458 - Flags: approval-mozilla-b2g34?
Attachment #8509458 - Flags: approval-mozilla-b2g34? → approval-mozilla-b2g34+
No steps to reproduce, unable to perform bug verification.
QA Whiteboard: [QAnalyst-Triage?][QAnalyst-Verify-]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][QAnalyst-Verify-] → [QAnalyst-Triage+][QAnalyst-verify-]
Flags: needinfo?(ktucker)
Blocks: Woodduck_P2
Priority: -- → P1
No longer blocks: Woodduck_P2
You need to log in before you can comment on or make changes to this bug.