Try decoding screenshots lazily when edge swiping

RESOLVED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: etienne, Assigned: etienne)

Tracking

unspecified
2.1 S6 (10oct)
x86
Mac OS X

Firefox Tracking Flags

(b2g-v2.1 fixed, b2g-v2.2 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

46 bytes, text/x-github-pull-request
aus
: review+
Details | Review | Splinter Review
(Assignee)

Description

4 years ago
In bug 1044125 we (rightfully) stopped keeping all the app screenshots around all the time.

But we're loading all of them as soon as the edge gesture starts, which makes the beginning of a gesture quite sluggish.

We can probably load just the screenshot that will be displayed next to make it faster.
(Assignee)

Updated

4 years ago
Assignee: nobody → etienne
(Assignee)

Comment 1

4 years ago
Created attachment 8501198 [details] [review]
WIP

Hey Aus, what do you think?

After a bunch of tries I think the best approach is to show the screenshots one by one as we swipe but to keep the sheets-gesture-end handler to hide all of them at the end of the gesture.

Just a WIP for now, I'll work on the tests tomorrow.
Attachment #8501198 - Flags: feedback?(aus)

Comment 2

4 years ago
Comment on attachment 8501198 [details] [review]
WIP

Definitely a great start! This will help most definitely with low memory profile devices. Probably doesn't help that we also have other perf regression dragging down waking up of an application but we're dealing with that in another bug (1069450).
Attachment #8501198 - Flags: feedback?(aus) → feedback+
(Assignee)

Comment 3

4 years ago
Created attachment 8501747 [details] [review]
Gaia PR

Cool, moving on to review with test added then :)
Attachment #8501198 - Attachment is obsolete: true
Attachment #8501747 - Flags: review?(aus)

Comment 4

4 years ago
Comment on attachment 8501747 [details] [review]
Gaia PR

lgtm! :)
Attachment #8501747 - Flags: review?(aus) → review+

Comment 5

4 years ago
Etienne, it would be awesome to land this on 2.1 as well (although, I'm guessing you were already going to ask for approval :))
(Assignee)

Comment 6

4 years ago
https://github.com/mozilla-b2g/gaia/commit/76122f7ba317cf2aa7a091cb4512ca8ce69335b9
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

4 years ago
Comment on attachment 8501747 [details] [review]
Gaia PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): perf regression due to the memory optim in bug 1044125
[User impact] if declined: the beginning of an edge gesture is really laggy
[Device impact] there a big memory consumption spike when the user starts an edge gestures (we load all the screenshots) with this patch we load them progressively
[Testing completed]: edge gestures scenarios, card view scenarios, + about:memory
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8501747 - Flags: approval-gaia-v2.1?

Updated

4 years ago
Attachment #8501747 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Needs rebasing for v2.1 uplift.
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → fixed
Flags: needinfo?(etienne)
Keywords: branch-patch-needed
Target Milestone: --- → 2.1 S6 (10oct)
(Assignee)

Comment 9

4 years ago
https://github.com/mozilla-b2g/gaia/commit/9f3592eae1bc7649f9552c756d0f9abf379f76b9
status-b2g-v2.1: affected → fixed
Flags: needinfo?(etienne)
Keywords: branch-patch-needed
You need to log in before you can comment on or make changes to this bug.