Closed Bug 1079440 Opened 8 years ago Closed 8 years ago

[Dialer] When the user have multiple calls ongoing calls, the dialer screen will overlap

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.0 unaffected, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S6 (10oct)
blocking-b2g 2.1+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: psiphantong, Assigned: drs)

References

Details

(Keywords: regression, Whiteboard: [2.1-flame-test-run-3])

Attachments

(3 files)

Attached file dd.txt
Description: 
When the user have multiple calls ongoing calls, the dialer screen will overlap

Repro Steps:
1) Update a Flame to 20141007000203
2) Have multiple ongoing calls 
3) Tap the keypad > tap on the latest call(highlighted blue row)
4) Tap the numbers

Actual:
dialer screen overlap

Expected:
dialer screen display correctly

Flame 2.1 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141007000203
Gaia: 7f738edf66b9298bceef8a4981d05d04fd04e540
Gecko: b9d04c58580a
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/9250/
See attached: screenshot, logcat
Attached image 2014-10-07-11-23-18.png
This issue also reproduce on the Flame 2.2 KitKat Base (319mb), the dialer screen overlap

Flame 2.2 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.2 Master
BuildID: 20141006040204
Gaia: 470826d13ae130a5c3d572d1029e595105485fb0
Gecko: e0d714f43edc
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

------------------------------------------------------------------------------------------------------------

This issue does not reproduce on the Flame 2.0 KitKat Base (319mb), the dialer screen display correctly


Flame 2.0 KitKat Base (319mb)(Full Flash)

Environmental Variables:
Device: Flame 2.0
BuildID: 20141006000202
Gaia: 092d2b7678774c8b0b06dca0e0a8119e9eafdec3
Gecko: 69ca61f7edf3
Gonk: 2c909e821d107d414f851e267dedcd7aae2cebf
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Summary: [Dialer} When the user have multiple calls ongoing calls, the dialer screen will overlap → [Dialer] When the user have multiple calls ongoing calls, the dialer screen will overlap
[Blocking Requested - why for this release]: Visible regression from 2.0 on the Dialer
blocking-b2g: --- → 2.1?
Assignee: nobody → drs+bugzilla
Target Milestone: --- → 2.1 S6 (10oct)
Confirmed, I'm able to repro this. Just give more clear repro steps:

1) Update a Flame to 2.2.
2) Have two ongoing calls, with at least one of them with a contact.
3) Tap on the call with a contact.
4) Open the keypad.
5) Tap any number keys on the keypad.
Status: NEW → ASSIGNED
Bug 1010104 regressed this.
Blocks: 1010104
PR: https://github.com/mozilla-b2g/gaia/pull/24961

We were leaving an unneeded line-height on the number node. This fixes it by resetting it when we aren't explicitly setting it.
Attachment #8502088 - Flags: review?(gtorodelvalle)
[blocking]
regression, major UI defect, high user impact/
blocking-b2g: 2.1? → 2.1+
Comment on attachment 8502088 [details] [diff] [review]
Fix call indicators overlapping with multiple calls.

Review of attachment 8502088 [details] [diff] [review]:
-----------------------------------------------------------------

Very little to add here :) Simple and clean fix including new test cases, so r+ ;)

BTW, testing the proposed patch I noticed and created bug 1080482 ;)
Attachment #8502088 - Flags: review?(gtorodelvalle) → review+
https://github.com/mozilla-b2g/gaia/commit/d0969a2263120c2a1467f1ab8ab0b662689891bc
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 8502088 [details] [diff] [review]
Fix call indicators overlapping with multiple calls.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1010104
[User impact] if declined: See attachment 8501272 [details].
[Testing completed]: I did manual testing.
[Risk to taking this patch] (and alternatives if risky): Very low.
[String changes made]: None.
Attachment #8502088 - Flags: approval-gaia-v2.1?(release-mgmt)
Attachment #8502088 - Flags: approval-gaia-v2.1?(release-mgmt) → approval-gaia-v2.1+
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
The issue is verified fixed on Flame 2.2 Master  KK (319mb) (Full Flash) and Flame 2.1 KK (319mb) (Full Flash)

Environmental Variables:
Device: Flame 2.2 Master  KK (319mb) (Full Flash)
BuildID: 20141012040203
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 44168a7af20d
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Environmental Variables:
Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141012001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Result: When the user has multiple calls going on, the dialer screen does NOT overlap
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.