Bad work with window size and state property

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
17 years ago
5 years ago

People

(Reporter: janousek, Assigned: danm.moz)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

If I set property, that Mozilla may run as Maximizen Window, after start and
initialize it change window size of maximized (and adequate button on the right
up side from maximized icon to normal) to normal and move window about 20 pixels
to right - but the size of window is the same as maximized - so the right side
(scrollbar etc.) is out of screen and I must click on maximized button again...

This situation is repeated on this situation too:
When I'm in browser, window is maximized and now I click right mouse button on
anchor in HTML page and in context menu select 'Open in new window' - this new
opened window is also opened as maximized and after window instance initialize
it move about 20 pixels to right, change state from maximized to normal and the
scrollbar is out of screen.

Reproducible: Always
Steps to Reproduce:
1.Start Mozilla
2.Maximize window
3.Open some link in HTML page as new window

Actual Results:  New window isn't maximized, but moved about 20 pixels to right,
window state changed to normal (window size (height, width) seems the same as
maximized values) - right side is out of the screen.

Expected Results:  New opened window doesn't change its state - it may be
maximized as its parent.
Reporter: Your build is old. Please try a more recent build:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-talkback.zip
(as always, be sure to delete your old Mozilla directory before instlaling the
new one)

-> XP Apps
Assignee: asa → pchen
Component: Browser-General → XP Apps
QA Contact: doronr → sairuh
danm?
Assignee: pchen → danm
QA Contact: sairuh → jrgm

Updated

17 years ago
Component: XP Apps → XP Toolkit/Widgets
Whiteboard: DUPEME
(Assignee)

Comment 3

17 years ago
I'm having some trouble understanding exactly what this bug is. You're saying
that if I

1.Start Mozilla
2.Maximize window
3.Open some link in HTML page as new window

the new window is not maximized, and is moved to the right 20 pixels? I can't
reproduce this. Pavel, you mentioned other conditions that sounded important.
Sounds like I should (1) start Mozilla, (2) maximize, (3) quit, and (4) restart
Mozilla, so it's maximized and its maximized state has been saved to disk.
However, I still can't reproduce this.

I can believe that there could be problems with the normal window position as
windows are created maximized. Probably this would be dependent on the positions
of other windows, maybe before they were maximized. But I haven't been able to
see any bugs like that with a current build, either.

Could you specify just exact, straightforward steps to reproduce this bug?
Including relevant state information, like how many other windows are open,
whether they're maximized at the time, and their pre-maximized positions?

Comment 4

17 years ago
WORKS FOR ME 

Windows 2000
./nightly/latest-1.0.0/
Build 2002041617

Reporter: Have you tried a new build? 

Can someone (reporter?) mark this as fixed or Works for me?

Comment 5

17 years ago
Hm... I'm not the reporter but I still see this problem, exactly as described in
comment #3:

- maximize window
- open a link in a new window

expected result:
- new window gets opened maximized

actual result:
- new window gets opened as normal window but with saved width and height of
maximized window (not fitting on the screen)

I'm using Mozilla 1.0rc1 on Windows 2000 [Mozilla/5.0 (Windows; U; Windows NT
5.0; en-US; rv:1.0rc1) Gecko/20020417].

Comment 6

17 years ago
Hm... using 1.0rc3 now, this also works for me.

User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc3)
Gecko/20020523; using Windows 2000.

Comment 7

17 years ago
Then it's agreed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.