Page Stalls with proxying HTTPS over HTTPS

RESOLVED FIXED in Firefox 34

Status

()

Core
Networking: HTTP
RESOLVED FIXED
3 years ago
a year ago

People

(Reporter: mcmanus, Assigned: mcmanus)

Tracking

32 Branch
mozilla35
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox32 unaffected, firefox33 wontfix, firefox34 fixed, firefox35 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Two page loading stalls reported:

1] with squid doing https (h1) proxying to an an h1 https origin

2] with spdyprxy doing https (spdy/3.1) proxying to any https origin
(Assignee)

Comment 1

3 years ago
(In reply to Patrick McManus [:mcmanus] from comment #0)
>
> 
> 2] with spdyprxy doing https (spdy/3.1) proxying to any https origin

scratch that - that turns out to only be a failure with an uncommitted development branch. #1 is the only issue here.
status-firefox32: --- → unaffected
status-firefox33: --- → affected
status-firefox34: --- → affected
status-firefox35: --- → affected
(Assignee)

Updated

3 years ago
Whiteboard: [spdy]
(Assignee)

Comment 2

3 years ago
Created attachment 8501330 [details] [diff] [review]
Page stalls proxying over https part 1
Attachment #8501330 - Flags: review?(hurley)
(Assignee)

Updated

3 years ago
Assignee: nobody → mcmanus
Status: NEW → ASSIGNED
(Assignee)

Comment 3

3 years ago
https://tbpl.mozilla.org/?tree=Try&rev=42bcd493ddd9
(Assignee)

Comment 4

3 years ago
reporter verifies the try build resolves the issue.
Attachment #8501330 - Flags: review?(hurley) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/c39759a6771e
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/c39759a6771e
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
(Assignee)

Comment 7

3 years ago
Comment on attachment 8501330 [details] [diff] [review]
Page stalls proxying over https part 1

the feature this fixes is new in 33.. too late for that release, but its a conservative and targeted fix that should be uplifted.

Approval Request Comment
[Feature/regressing bug #]:378637
[User impact if declined]: potential stalls during page load when using new https proxying feature (in gecko 33)
[Describe test coverage new/current, TBPL]: try is good and has merged to m-c. reporter verifies fix
[Risks and why]: very conservative change only in code path of new feature
[String/UUID change made/needed]: none
Attachment #8501330 - Flags: approval-mozilla-aurora?
Comment on attachment 8501330 [details] [diff] [review]
Page stalls proxying over https part 1

Aurora+
Attachment #8501330 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/22c66a80bcc7
status-firefox33: affected → wontfix
status-firefox34: affected → fixed
status-firefox35: affected → fixed
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1047485

Updated

a year ago
Depends on: 1272798
You need to log in before you can comment on or make changes to this bug.