If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Load locale files based on system UI display language

RESOLVED DUPLICATE of bug 697238

Status

()

Core
Localization
RESOLVED DUPLICATE of bug 697238
3 years ago
3 years ago

People

(Reporter: aurimas.dev, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.124 Safari/537.36

Steps to reproduce:

On Windows 7 (but should also be applicable to all Windows versions since XP), you can install additional language packs for the UI. The setting can be found and changed under Control Panel -> Region and Language -> Keyboard and Languages. This is distinct from the Date and Time formatting, Location, or "Language for non-Unicode programs" (i.e. system locale) settings.

When init.locale.matchOS setting is set to true and a XULRunner application is started, the appropriate localization files are loaded based on the system locale.


Actual results:

Under Windows, XULRunner determines the system locale using the GetSystemDefaultLCID system call, which returns the "system locale" corresponding to the "Language for non-Unicode programs" setting. Unfortunately, this setting is not changed when switching UI display languages as described above and, accordingly, the language determine by XULRunner may mismatch the system user interface language.


Expected results:

XULRunner should use the GetUserDefaultUILanguage system call to determine the UI language chosen by the user.
(Reporter)

Comment 1

3 years ago
Some more information that may be helpful (apologies for the double post).

From Windows Help file about the "system locale":
> The system locale determines the default character set (letters, symbols, 
> and numbers) and font used to enter and display information in programs that 
> don't use Unicode. This allows non-Unicode programs to run on your computer 
> using the specified language. You might need to change the default system 
> locale when you install additional display languages on your computer. 
> Selecting a different language for the system locale doesn't affect the 
> language in menus and dialog boxes for Windows or other programs that do use 
> Unicode.

See http://msdn.microsoft.com/en-us/library/windows/desktop/dd374098(v=vs.85).aspx for additional info on other available system calls and how the UI language is determined.
(Reporter)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 697238
You need to log in before you can comment on or make changes to this bug.