Apply Call status bar styles as designed.

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: vicky, Assigned: crdlc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile app][not blocking][tef-triage][loop in 1.1][loop approved for 1.1])

Attachments

(9 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 8501651 [details]
Visual Mockup: Call_Status_bar

Call status bar should follow the specifications in order to speak the app's same language and interact well with the rest of the OS.
Visual design and specs for implementation are provided.
(Reporter)

Updated

4 years ago
Assignee: nobody → borja.bugzilla
(Reporter)

Comment 1

4 years ago
Created attachment 8501652 [details]
Visual Spec: Call_Status_bar
Blocks: 1036490
Whiteboard: [mobile app][not blocking][tef-triage]
Assignee: borja.bugzilla → nobody
(Reporter)

Comment 2

4 years ago
Created attachment 8501668 [details]
Loop icon for the call status bar in 4 sizes.
Assignee: nobody → rnowmrch
Status: NEW → ASSIGNED
Assignee: rnowmrch → crdlc
(Assignee)

Comment 3

4 years ago
Created attachment 8506714 [details]
Github pull request
Attachment #8506714 - Flags: review?(borja.bugzilla)
(Assignee)

Comment 4

4 years ago
Maria Angeles, I changed here a string just in case it ends in 1.1

See https://github.com/mozilla-b2g/firefoxos-loop-client/pull/211/files#diff-964b329a1e6469f66cec3e4991fbb538R94
Flags: needinfo?(oteo)
(In reply to Cristian Rodriguez (:crdlc) from comment #4)
> Maria Angeles, I changed here a string just in case it ends in 1.1
> 
> See
> https://github.com/mozilla-b2g/firefoxos-loop-client/pull/211/files#diff-
> 964b329a1e6469f66cec3e4991fbb538R94

ok, thanks!
Let's it land in master first and if there is not any issues we will uplift it to 1.1 branch
Flags: needinfo?(oteo)
Attachment #8506714 - Flags: review?(borja.bugzilla) → review+
Created attachment 8507758 [details]
bar.png

Vicky, could you confirm the UI is the right one? Thanks!
Attachment #8507758 - Flags: ui-review?(vpg)
(Reporter)

Comment 8

4 years ago
Comment on attachment 8507758 [details]
bar.png

"hello" word should be regular style if text (400), counter is missing and also, can you provide the screenshot of the case when the call is muted or on hold? I need to see how the respective icons are placed.

Thanks!
Attachment #8507758 - Flags: ui-review?(vpg) → ui-review-
(Reporter)

Comment 9

4 years ago
Comment on attachment 8507758 [details]
bar.png

Also, the system status bar should be visible, right?
(Assignee)

Comment 10

4 years ago
There is not system status bar while the call in progress bar is displayed behind us

(In reply to Victoria Gerchinhoren [:vicky] from comment #9)
> Comment on attachment 8507758 [details]
> bar.png
> 
> Also, the system status bar should be visible, right?
(Assignee)

Comment 11

4 years ago
(In reply to Victoria Gerchinhoren [:vicky] from comment #8)
> Comment on attachment 8507758 [details]
> bar.png
> 
> "hello" word should be regular style if text (400),

Firefox Hello is a placeholder and indivisible so same styles are applied for "Firefox" and "Hello"

> counter is missing and
> also, can you provide the screenshot of the case when the call is muted or
> on hold? I need to see how the respective icons are placed.

This will be done in another bug because it implies interaction and this bug only applies style to the current logic we already have 

> 
> Thanks!
(Assignee)

Comment 12

4 years ago
Created attachment 8507911 [details]
1079782.png

thanks
Attachment #8507911 - Flags: ui-review?(vpg)
(Assignee)

Comment 13

4 years ago
I've already implemented all suggestions except comment 10 because of system status bar is invisible behind our call in progress bar. The counter is also available in this patch. Please see [1]

BTW we need to fill a new bug in order to know what the mute icon is [2]. Is this a button to mute/un-mute the call? is this just an icon to inform users about the current state without interaction (no touchable). Which assets will be used here? etc...

Maybe this questions are for Monica, right? Thanks a lot!

[1] https://bug1079782.bugzilla.mozilla.org/attachment.cgi?id=8507911
[2] https://bug1079782.bugzilla.mozilla.org/attachment.cgi?id=8501652
(Assignee)

Comment 14

4 years ago
The ni? disappeared when I added the previous comment 13 :)
Flags: needinfo?(monica.meika)

Comment 15

4 years ago
Hey,

"Connected" Status:
- Icons: Camera/Not Camera , Mute/Unmute + 00:00.

"Hold" Status: 
- String + Icon

Others Status:
- Only string.

And please C on Call with Capital Letter, please

Thanks :)
Flags: needinfo?(monica.meika)
(Assignee)

Updated

4 years ago
Attachment #8507911 - Attachment is obsolete: true
Attachment #8507911 - Flags: ui-review?(vpg)
(Assignee)

Comment 16

4 years ago
Created attachment 8508713 [details]
status bar 9.png

:)
Attachment #8508713 - Flags: ui-review?(vpg)

Comment 17

4 years ago
Created attachment 8508716 [details]
Specs-Call-Status_Bar-Connected.pdf
(Reporter)

Comment 18

4 years ago
Comment on attachment 8508713 [details]
status bar 9.png

Cool! Thanks!
Attachment #8508713 - Flags: ui-review?(vpg) → ui-review+
(Assignee)

Comment 19

4 years ago
in master:

https://github.com/mozilla-b2g/firefoxos-loop-client/commit/113f28d0b89f86b3fd8fbcc5612846c21ca1f50f
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [mobile app][not blocking][tef-triage] → [mobile app][not blocking][tef-triage][loop not in 1.1]
Tested in master and working fine.
Although this is not a blocking issue the current call status bar in master looks a little ugly and Borja told me that the code was quite safe, so Cristian, let's go for the uplift!
Thanks a lot for your work and feedback!
Flags: needinfo?(crdlc)
Whiteboard: [mobile app][not blocking][tef-triage][loop not in 1.1] → [mobile app][not blocking][tef-triage][loop not in 1.1][loop approved for 1.1]
(Assignee)

Comment 21

4 years ago
in 1.1

https://github.com/mozilla-b2g/firefoxos-loop-client/commit/48e1ae9f3e04a4598bf67a2667a05738dbaec5a2
Flags: needinfo?(crdlc)
Whiteboard: [mobile app][not blocking][tef-triage][loop not in 1.1][loop approved for 1.1] → [mobile app][not blocking][tef-triage][loop in 1.1][loop approved for 1.1]
Created attachment 8517424 [details]
20141105_143152.jpg
Created attachment 8517425 [details]
20141105_142852.jpg
Tested. See attached image: 20141105_143152.jpg  and 20141105_142852.jpg 
Flame
eng
v2.0
Gecko-dde9d61
Gaia-7b8df99
Loop version: 1.1 , 2e7c3c2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.