crash/hang entering mail app

VERIFIED DUPLICATE of bug 107994

Status

SeaMonkey
MailNews: Message Display
--
blocker
VERIFIED DUPLICATE of bug 107994
17 years ago
14 years ago

People

(Reporter: tracy, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({smoketest})

Trunk
x86
Linux
smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
seen on linux commercial 2001-11-01-06-trunk (mac and win are fine)

-from the browser, open the mail app

sometimes it crashes, sometimes it hangs as it tries to complete building the 
window.  the hang happens before the password dialogue pops up.


talk back: Incident ID 37497725 
 Stack Signature
               Distance() 928f15bd 
 Bug ID
 Trigger Time 
               2001-11-01 08:22:04 
 Email Address 
               twalker@netscape.com 
 URL Visited 
 User Comments 
               crash entering mail 
 Build ID
               2001110106 
 Product ID
               MozillaTrunk 
 Platform ID
               LinuxIntel 
 Trigger Reason
               SIGSEGV: Segmentation Fault: (signal 11) 
 Stack Trace

Distance() 
nsScanner::RewindToMark() 
nsParser::Tokenize() 
nsParser::ResumeParse() 
nsParser::OnStopRequest() 
nsDocumentOpenInfo::OnStopRequest() 
nsUnknownDecoder::OnStopRequest() 
nsDocumentOpenInfo::OnStopRequest() 
nsHttpChannel::OnStopRequest() 
nsOnStopRequestEvent::HandleEvent() 
nsARequestObserverEvent::HandlePLEvent() 
PL_HandleEvent() 
PL_ProcessEventsBeforeID() 
processQueue() 
nsVoidArray::EnumerateForwards() 
nsAppShell::ProcessBeforeID() 
handle_gdk_event() 
libgdk-1.2.so.0 + 0x1700b (0x4032000b) 
libglib-1.2.so.0 + 0xfbe6 (0x4034dbe6) 
libglib-1.2.so.0 + 0x101a1 (0x4034e1a1) 
libglib-1.2.so.0 + 0x10341 (0x4034e341) 
libgtk-1.2.so.0 + 0x8c209 (0x40275209) 
nsAppShell::Run() 
nsAppShellService::Run() 
main1() 
main() 
libc.so.6 + 0x181eb (0x4044d1eb)
(Reporter)

Updated

17 years ago
Keywords: smoketest

Comment 1

17 years ago
This might be ben too, eh?

Comment 2

17 years ago
I'm getting the same crasher for clicking on links opening in a new window.
putting jag on CC for string input, rpotts, cause he checked in to htmlparser
today.
Not sure where to put this, but mailnews is probably wrong. Up for adoption.

Is Distance unhappy about aStart>aEnd?

###!!! ASSERTION: Infinite loop: can't advance a reading iterator beyond the end
of a string: 'one_hop>0', file ../../dist/include/string/nsStringIterator.h,
line 174
###!!! Break: at file ../../dist/include/string/nsStringIterator.h, line 174

Program received signal SIGSEGV, Segmentation fault.
0xff114d40 in ?? () at /tmp/mozilla/xpcom/glue/nsCOMPtr.cpp:90
   from /tmp/build/dist/bin/libxpcom.so
90        }


#5  0xff0d1814 in Distance (aStart=@0xc1db94, aEnd=@0xc1db80)
    at /tmp/mozilla/string/src/nsReadableUtils.cpp:99
#6  0xfda62820 in nsScanner::RewindToMark (this=0xc1db78)
    at /tmp/mozilla/htmlparser/src/nsScanner.cpp:266
#7  0xfda5e9bc in nsParser::Tokenize (this=0xf3b270, aIsFinalChunk=1)
    at /tmp/mozilla/htmlparser/src/nsParser.cpp:2599
#8  0xfda5c128 in nsParser::ResumeParse (this=0xf3b270, allowIteration=1, 
    aIsFinalChunk=1) at /tmp/mozilla/htmlparser/src/nsParser.cpp:1830
#9  0xfda5e750 in nsParser::OnStopRequest (this=0xf3b270, request=0xecc470, 
    aContext=0x0, status=2152398851)
    at /tmp/mozilla/htmlparser/src/nsParser.cpp:2525
#10 0xfde90634 in nsDocumentOpenInfo::OnStopRequest (this=0xf22540, 
    request=0xecc470, aCtxt=0x0, aStatus=2152398851)
    at /tmp/mozilla/uriloader/base/nsURILoader.cpp:271
#11 0xfdce0a2c in nsUnknownDecoder::OnStopRequest (this=0xa7f168, 
    request=0xecc470, aCtxt=0x0, aStatus=2152398851)
    at /tmp/mozilla/netwerk/streamconv/converters/nsUnknownDecoder.cpp:247
#12 0xfde90634 in nsDocumentOpenInfo::OnStopRequest (this=0xea7010, 
    request=0xecc470, aCtxt=0x0, aStatus=2152398851)
    at /tmp/mozilla/uriloader/base/nsURILoader.cpp:271
#13 0xfdd14bd8 in nsHttpChannel::OnStopRequest (this=0xecc470, 
    request=0xf00e4c, ctxt=0x0, status=2152398851)
    at /tmp/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp:2325
#14 0xfddc7728 in ?? () at ../../../dist/include/xpcom/nsCOMPtr.h:565

Comment 3

17 years ago
getting the CCs I lost in midair
same trace as in bug 107994.
dup.

*** This bug has been marked as a duplicate of 107994 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.