Hitting enter after interacting with options from Forget button closes the pop-up

VERIFIED FIXED in Firefox 33

Status

()

Firefox
Toolbars and Customization
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: bogdan_maris, Assigned: Gijs)

Tracking

Trunk
Firefox 35
Points:
1
Bug Flags:
firefox-backlog +
in-testsuite -
qe-verify -

Firefox Tracking Flags

(firefox33 verified, firefox34 verified, firefox35 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
STR:
1. Open Firefox
2. Move the Forget button to toolbar
3. Click the button and select one of the options (eg. 24 hours)
4. Using the arrow keys (up/down) move through the options
5. Hit Enter key

Expected results: Maybe after selecting an option using arrow keys, hitting enter will actually have the same behavior as clicking 'Forget'.

Actual results: After hitting Enter the pop-up just closes.

Notes:
1. Windows and Linux only.
2. Reproducible on latest Nightly and latest Aurora.
(Assignee)

Updated

3 years ago
Blocks: 1069300
(Assignee)

Comment 1

3 years ago
This should be fixable by adding closemenu=none on the radio buttons.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Iteration: --- → 35.3
Points: --- → 1
Flags: qe-verify-
Flags: in-testsuite-
Flags: firefox-backlog+
(Assignee)

Comment 2

3 years ago
Created attachment 8503031 [details] [diff] [review]
fix closing forget panel by adding a closemenu=none attribute,

This works in my testing; the event target is the radiogroup because that's a XBL binding so the original individual radio button targets get lost (yay XBL) and putting the attribute on there doesn't work...
Attachment #8503031 - Flags: review?(jaws)
https://hg.mozilla.org/mozilla-central/rev/c6e8abf0f825
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
(Assignee)

Comment 5

3 years ago
Comment on attachment 8503031 [details] [diff] [review]
fix closing forget panel by adding a closemenu=none attribute,

(approval req for 34)

Approval Request Comment
[Feature/regressing bug #]: panic button
[User impact if declined]: in some cases, panel will close if you use the keyboard when it shouldn't
[Describe test coverage new/current, TBPL]: nope
[Risks and why]: nope
[String/UUID change made/needed]: nope
Attachment #8503031 - Flags: approval-mozilla-beta?
Attachment #8503031 - Flags: approval-mozilla-aurora?
status-firefox34: --- → affected
status-firefox35: --- → affected
status-firefox36: --- → fixed
Attachment #8503031 - Flags: approval-mozilla-beta?
Attachment #8503031 - Flags: approval-mozilla-beta+
Attachment #8503031 - Flags: approval-mozilla-aurora?
Attachment #8503031 - Flags: approval-mozilla-aurora+
This landed prior to the uplift.
status-firefox35: affected → fixed
status-firefox36: fixed → ---
Landed in alder: https://hg.mozilla.org/projects/alder/rev/0de8444b8da0
Whiteboard: [fixed-alder]
(The 33/alder patch was based on e6441f98f159)
(Reporter)

Comment 10

3 years ago
Verified as fixed on Windows 7 64bit and Ubuntu 12.04 32bit using Firefox 34 beta 3 build 2, latest Aurora and latest Alder build.
Status: RESOLVED → VERIFIED
status-firefox34: fixed → verified
status-firefox35: fixed → verified
status-firefox33: --- → fixed
(Reporter)

Comment 12

3 years ago
Also verified using Firefox 33.1 on Windows 7 64bit, Ubuntu 14.04 32bit and it is fixed.
status-firefox33: fixed → verified
You need to log in before you can comment on or make changes to this bug.