Closed Bug 1079876 Opened 6 years ago Closed 6 years ago

crash in java.lang.RuntimeException: Parcel android.os.Parcel@<addr>: Unmarshalling unknown type code 4522062 at offset 736 at android.os.Parcel.readValue(Parcel.java)

Categories

(Firefox for Android :: General, defect)

35 Branch
All
Android
defect
Not set
critical

Tracking

()

VERIFIED FIXED
Firefox 35
Tracking Status
firefox32 --- wontfix
firefox33 --- verified
firefox34 --- verified
firefox35 --- verified
fennec 34+ ---

People

(Reporter: aaronmt, Assigned: rnewman)

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-ac45f3d7-beb0-4c5d-9b55-0ebc52141007.
=============================================================

java.lang.RuntimeException: Parcel android.os.Parcel@429b69e8: Unmarshalling unknown type code 4522062 at offset 736
	at android.os.Parcel.readValue(Parcel.java:2080)
	at android.os.Parcel.readArrayMapInternal(Parcel.java:2313)
	at android.os.Bundle.unparcel(Bundle.java:249)
	at android.os.Bundle.getString(Bundle.java:1118)
	at android.content.Intent.getStringExtra(Intent.java:4991)
	at org.mozilla.gecko.util.StringUtils.getStringExtra(StringUtils.java:194)
	at org.mozilla.gecko.BrowserApp.onResume(BrowserApp.java:753)
	at android.app.Instrumentation.callActivityOnResume(Instrumentation.java:1210)
	at android.app.Activity.performResume(Activity.java:5505)
	at android.app.ActivityThread.performResumeActivity(ActivityThread.java:2936)
	at android.app.ActivityThread.handleResumeActivity(ActivityThread.java:2975)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1307)
	at android.os.Handler.dispatchMessage(Handler.java:102)
	at android.os.Looper.loop(Looper.java:157)
	at android.app.ActivityThread.main(ActivityThread.java:5356)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:515)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:1265)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:1081)
	at dalvik.system.NativeStart.main(Native Method)
Regression from bug 1077645?
Flags: needinfo?(rnewman)
It looks like just a different manifestation of the error in that bug, just obviously with the safety wrapper in the stack.

The original was this:

ComponentInfo{org.mozilla.firefox_beta/org.mozilla.gecko.BrowserApp}: android.os.BadParcelableException: ClassNotFoundException when unmarshalling: com.facebook.events.common.ActionSource
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
tracking-fennec: --- → 35+
Flags: needinfo?(rnewman)
This seems super unusual, and we're playing whack-a-mole with Android's own awful runtime exceptions. This should address this particular crash.
Attachment #8502249 - Flags: review?(mark.finkle)
Attachment #8502249 - Flags: review?(mark.finkle) → review+
This flies up with Bug 1077645.
tracking-fennec: 35+ → 34+
Comment on attachment 8502249 [details] [diff] [review]
Handle unexpected exceptions when reading external extras. v1

Approval Request Comment
[Feature/regressing bug #]:
  Facebook broke us. It's not our fault.

[User impact if declined]:
  Crashes when opening links from affected Facebook versions.

[Describe test coverage new/current, TBPL]:
  No test coverage.

[Risks and why]: 
  This is an extension of Bug 1077645 to catch *another* case that we found in the wild. Very low risk.
 
[String/UUID change made/needed]:
  None.
Attachment #8502249 - Flags: approval-mozilla-release?
Attachment #8502249 - Flags: approval-mozilla-beta?
Attachment #8502249 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/75f9efa43bb4
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 35
Comment on attachment 8502249 [details] [diff] [review]
Handle unexpected exceptions when reading external extras. v1

Just like with bug 1077645, it is too late for 33.
Attachment #8502249 - Flags: approval-mozilla-release?
Attachment #8502249 - Flags: approval-mozilla-release-
Attachment #8502249 - Flags: approval-mozilla-beta?
Attachment #8502249 - Flags: approval-mozilla-beta-
Comment on attachment 8502249 [details] [diff] [review]
Handle unexpected exceptions when reading external extras. v1

We are going to make a build #2 for fennec & desktop, we can take them.
Attachment #8502249 - Flags: approval-mozilla-release- → approval-mozilla-release+
Comment on attachment 8502249 [details] [diff] [review]
Handle unexpected exceptions when reading external extras. v1

I see this has already landed on Aurora. That's fine. (I mean, it did get approval to land on mozilla-release.) I would have approved this one anyway.
Attachment #8502249 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Sorry, Lawrence; didn't notice that the bug hadn't been marked!
I'm marking this verified fixed since there have been 0 reports of this crash in over a week, although qe-verify- since QE didn't actually test anything here.
Status: RESOLVED → VERIFIED
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.